Jump to content
  • entries
    657
  • comments
    2,699
  • views
    899,827

New New Toy


SpiceWare

1,220 views

A little over 8 years ago I'd picked up an Acer Aspire One netbook to replace an old Thinkpad T22. I set it up with Ubuntu and it worked quite well, though the battery had worn out over the years and needed to be plugged in all the time.

At the start of September I'd moved it, then gently tossed the barrel plug of the power adaptor towards the back of the open Netbook. The cord hit just wrong, wrapped around from behind, and pinged the front of the screen:
blogentry-3056-0-07821100-1506265993_thumb.jpg

So I checked the deals at Frys and MicroCenter but didn't like what they had so started monitoring the daily deals at Woot! as inexpensive laptops show up there on occasion. A little over a week later this refurbished Dell Latitude E7240 showed up for $299.99. I thought the spec of 1.9 GHz with Turbo to 2.9 GHz was a typo, so checked it out to see what the Turbo really was - and it was correct :!: I decided to order one.

I thought the 128 GB mSATA SSD would not be large enough, as the 120 GB in the Aspire had become cramped over the years, so I picked up a 256 GB unit from MicroCenter, along with a USB 3.0 enclosure to put the old one in when I pulled it (I thought I'd try to get the included Windows 10 running in a virtual machine on my Mac Pro). When I opened up the Latitude to swap the drives I was surprised to see space for a second mSATA drive. I was also surprised to see that the 8 GB of RAM was done using a single DIMM module, leaving the second RAM slot free:
blogentry-3056-0-81082000-1506266671_thumb.jpg

I know WWAN is for a cellular network card, and mSATA is for mini-SATA for compact SSDs, I don't know what PP means (a search of the manual kept turning up words like "support"):
blogentry-3056-0-12964600-1506266732_thumb.jpg

So I picked up another 8 GB DIMM to max out the RAM and installed both in there:
blogentry-3056-0-93476000-1506266783_thumb.jpg

I downloaded Ubuntu 16.04 LTS * and created a live USB stick using Etcher (significantly easier than what I went through 8 years ago). I then installed Ubuntu on the new SSD and left the drive with Windows 10 alone. To choose what to run I just hit F12 during the boot process and select:

Internal HDD for Windows:
blogentry-3056-0-44217500-1506267147_thumb.jpg

Or MiniCard SSD for Ubuntu:
blogentry-3056-0-15189700-1506267180_thumb.jpg

I also set up Ubuntu so I can build my Atari projects there. Just finished compiling the code for last night's build of Draconian:
blogentry-3056-0-91498600-1506267228_thumb.png

Running the build:
blogentry-3056-0-21548400-1506267244_thumb.png

Works great with a USB Atari Joystick, though Stella initially acts weird and selects things on its own until I've moved the joystick in all 4 directions.
blogentry-3056-0-51211400-1506267299_thumb.jpg

I have not installed jEdit yet - I've been thinking it might be time to check out some other programmer editors. Any suggestions? It needs to be cross-platform(Mac & Linux), allow you to compile code and launch Stella, as well as let you configure the syntax highlighting so graphics contained in binary values are readily apparent:
blogentry-3056-0-66738400-1506268846_thumb.png

One thing the photos at Woot! don't show is the texture on the outside of the unit - makes it grippier so you feel like you're less likely to drop it while carrying it:
blogentry-3056-0-53626900-1506267367_thumb.jpg

I've also decided to leave Windows 10 on the laptop instead of turning it into a virtual machine on the Mac. In part so when my nephew next visits I can try to get him addicted to StarCraft, it handles the new remastered version without any problems:
blogentry-3056-0-10438600-1506267426_thumb.jpg

All in all, I'm quite happy with this laptop.

* I first tried 17.04 but it had major issues like requiring boot options to be configured, it didn't recognize the touchpad, nor that it had an internal battery,

2 Comments


Recommended Comments

Having to move the joystick in all 4 directions is a calibration thing. I don't use Ubuntu specifically, but I'm sure there's a preferences module to do calibration for joystick devices. You will probably need to do this eventually, since otherwise every time you reboot the device into Linux, you will have the same issue with Stella.

Link to comment

Thanks! I did notice I had to recalibrate each time. A quick search turned up some obsolete solutions, will look into it further later.

Link to comment
Guest
Add a comment...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...