Jump to content
  • entries
    657
  • comments
    2,699
  • views
    899,716

MenuMaker 0.2 source found


SpiceWare

634 views

This is a followup to the MenuMaker 0.2 blog entry from 2014.


@eyelyft approached me in 2019 about recompiling MenuMaker as it was a 32-bit program and MacOS is now 64-bit only. I'd done a clean install of my Mac since then, so downloaded the source from blog post but discovered it was missing files.  I wasn't able to find the missing files so thought I'd lost part of the source during the clean install.

 

Last week during a @ZeroPage Homebrew stream on Twitch discussion turned to Vectrex and MenuMaker. @Nathan Strum made a comment about getting the original source from @Richard H. again.

 

Yesterday I was thinking about that so on a whim searched my email and found this:

 

1382488068_ScreenShot2021-11-07at10_38_48AM.thumb.png.b33ae8347536b9194bd365e5bee336d7.png

 

 

 

The original AtariAge message is long gone, but the email did have the source that Richard had sent me all those years ago. On another whim I did a Spotlight search using some variable names from the source and found what appears to be the complete source for this project (I won't know for sure until I can attempt to rebuild it - bummer, turned out not to be as seen in the followup comments below).

 

 

Now I need to figure out how to get the current version of Lazarus to work so I can rebuild MenuMaker as a 64-bit program. After upgrading Lazarus it complained that it couldn't find Make or Debugger, which means it's not able to build any programs.

 

 

So I uninstalled Lazarus, then reinstalled it using brew which I had installed over the summer so I could install ImageMagick to do some SVG experiments* for work.  With the brew installation Lazarus is able to find both Make and Debugger:

 

1685029230_ScreenShot2021-11-07at10_07_54AM.thumb.png.1f59fda9d21c93ff3c6386d261246b17.png

 

471136415_ScreenShot2021-11-07at10_07_57AM.thumb.png.3bb52e517592dd38330333cecdbdd436.png

 

 

however it can't find FPC sources:

 

921470473_ScreenShot2021-11-07at10_07_50AM.thumb.png.4c75e744264c82dbdb1ff49e9bb7b7ad.png

 

Have plans with my folks today, so this is where I'm leaving off for now.

 

To be continued...

 

 

 

which failed, ImageMagick's support for SVGs was really bad. I ended up using the .Net WebBrowser control to render the SVGs, which worked but results in the loss of the SVG's alpha channel that I needed.  I figured out how to recreate it by rendering each SVG twice, once on a black background and once on a white - diffing the pixels allowed me to recreate the alpha channel.

  • Thanks 1

8 Comments


Recommended Comments

A little more progress during my lunch break. I tracked down the source from here and put it into /usr/local/share/fpcsrc/3.2.0/ which made Lazarus' config dialog happy:

 

944705479_ScreenShot2021-11-08at11_53_53AM.thumb.png.351112fefd11212992af02dde02e0c27.png

 

I was then able to successfully build and run one of the example programs:

 

1516803179_ScreenShot2021-11-08at12_00_51PM.thumb.png.be9a1f135722ac131b8a949af17ecfa5.png

 

To be continued...

 

 

Link to comment

That's a bummer - turns out the source I found was not from my MenuMaker 0.2 port - it doesn't even have the DirectorySeparator constant that I mention putting in place in this comment so I think it's the original file that Richard sent me.

 

I've started to relearn how to use Lazarus so I can redo the port.  So far I've created a basic Application and have been modifying it to look like the screenshots from here. The About button works, but that's it for tonight.

 

1739641799_ScreenShot2021-11-08at6_53_34PM.thumb.png.857870287c7fe93c508e7c44b85d5c4c.png

 

654080087_ScreenShot2021-11-08at6_53_40PM.png.a997b325aa59caa223fdc7034f0d1d16.png

 

 

Link to comment

Made some headway.

 

At the moment the program's hardcoded to use /Volumes/VECMULTI and /Volumes/VECMULTI/Games.

 

I downloaded Beluga Dreams, a Vectrex game I did not have, and put it in the Games directory on the SD card.  I then ran MenuMaker.

 

Beluga Dreams ended up as game #3, which was unexpected as I thought it would be sorted alphabetically and thus appear on page 2.  The routines are probably getting the files in whatever order they exist in the FAT directory structure, which is why utilities like FATsort exist.

 

IMG_2492.thumb.JPG.6d6455dd44cdffc6d039589a65917b76.JPG

 

 

Beluga Dreams in action:

IMG_2493.thumb.JPG.8e3f9c45d2c94f6f597f75ea1d7b7678.JPG

 

 

Link to comment

I haven't tried firing up my Vectrex in a long time. I have two of Richard's multicarts: an previous-generation VecMulti that has never worked in my Vectrex (I have a fussy Vectrex), and a VecFlash, which I can't use because of a lack of Mac software.

 

Richard has a newer VecMulti that seems to do better with fussy Vectrexes (Vectri?), but I can't use it with the Mac because of software. Richard wrote:

Quote

it requires a menu packer (written for PC). Darrell's Mac version menu packer won't work on the new revision of VecMulti.

He was going to think about if there might be a solution, but that was April 2020, and I haven't wanted to press him on it.

  • Like 1
Link to comment

That's a bummer.  I'll ping Richard about it.

 

Made some more progress - the SD card is no longer hard coded:

 

999278153_ScreenShot2021-12-09at8_33_45PM.thumb.png.2fc7c5f45107f924bc2741dce0cc70f3.png

 

Clicking ... brings up the Volumes on your Mac:

 

1148721234_ScreenShot2021-12-09at8_33_11PM.thumb.png.c140ca33ff579af22803b58869f87745.png

 

I decided to not make the Games directory also selectable as I never used that feature, so it gets set to SDCard/Games.  The TFileListBox has a Sorted setting - it defaults to true which means it should be sorted, but as seen before with Beluga Dreams it wasn't. I decided to see if I could manually sort the list box after it loaded in the files - that worked:

 

2060970198_ScreenShot2021-12-09at8_33_17PM.thumb.png.d39e5e86a55e9167c29cc50914fde604.png

 

So Beluga Dreams now shows up on Page 2 as expected:

IMG_2496.thumb.JPG.a047c4e1b7ab976d0a7f5d6e8d918a51.JPG

 

Still a few things to wrap up such as cleaning up the code (lots of experimental code is still in there, just commented out so it won't run) as well as figure out how to get the program icon to show up. You can see it in the window's title bar in the above screenshots, but it's not showing up on the program itself:

 

286688697_ScreenShot2021-12-09at8_45_42PM.thumb.png.078040471590353ba5a79fb66326ad69.png

 

Link to comment

If you do happen to figure out how to get the menu to work on the new MAC OS. Please feel free to post on Vectrex Vans Unite! I know a lot of people would appreciate it.
I currently use a VecFever to experience new games and demos, so this is not an issue anymore to me and many others that use VecFever and PiTrex currently.
I still use my VecMulti as well but just how is was last setup many years back and that's good enough for me.

Link to comment

Looks like Vectrex Fans Unite! is a facebook group - I'm no longer a member of Facebook, got tired of them censoring me.

 

Glad you found a solution in the meantime.

 

 

Link to comment
On 12/10/2021 at 7:35 AM, SpiceWare said:

Looks like Vectrex Fans Unite! is a facebook group - I'm no longer a member of Facebook, got tired of them censoring me.

 

Glad you found a solution in the meantime.

 

 

No worries.  I'll x-post there and a few other places.

 

 

 

  • Like 1
Link to comment
Guest
Add a comment...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...