Jump to content

Almost have a 2708 dumper working


Bruce Tomlin

202 views

I have an interesting... thing... with a bunch of 2708 chips in it, and I want to read them. But I'm very wary, because I don't want to fry them.

 

The problem is that the 2708 needs extra supply voltages of -5 and +12 volts just to read a chip, but it also needs +26V for programming. The extra cost of all the extra voltages means almost zero programmers support it without extra hardware.

 

A few months ago, I tried to do the simple idea, add a socket board with some pins changed so that I could try to read it on a regular EPROM programmer as a 2716, but get the voltages from a couple of wall warts. I've heard that not having the -5 volts is crossing-the-streams-bad, so I put LEDs on both voltages. I had one other 2708 chip, and its contents were already known and it could be replaced with a 2716. It didn't go well. I got a few partial reads, then the chip died.

 

So on to version two. Start with making a Blue Pill board read a 2716 chip. It was not a fast process, made slower because I'm trying to break away from the mbed web site compiler. I tried to get the old version of mbed working offline, but crappiness related to Python 2 vs 3, and Apple change-protecting chunks of Python 2.7's package storage made it impossible on my laptop. And the current version of mbed is super bloated, it includes all sorts of crap that makes a minimal program be like 30-50K. Eventually I not only got my own code working, I also got gdb working in text screen (ncurses) mode... more or less, but enough to be better than printf debugging through a serial port that you don't have working yet.

 

(To make things even more fun, a USB serial adapter I got from Amazon seems to have a bug when its internal buffer overflows before opening up the serial port on your computer, then it spews everything forever. Sometimes it even barfs out garbage with debug symbols.)

 

Tonight I finally got it to dump a 2716 chip. I had been poking at the various pins, and nothing would output data. So I started a new breadboard with a bunch of LEDs and DIP switches. After more poking around, finally the LEDs come on, and I recognized the bytes at 0x000 and 0x0FF. Turns out that the pin 21 (Vpp on 2716) needs to be connected to +5V, not GND. Now I just need to set up the extra voltages and cross my fingers. Maybe tomorrow.

IMG_20221010_215113439..jpg

Edited by Bruce Tomlin

3 Comments


Recommended Comments

What used 2708s?  Would it be possible to repurpose a PSU from one of those systems?  You should be able to get -5V & +12V from an old AT power supply.  Also need to make sure whatever microcontroller you're using has 5V compatible inputs.

 

Link to comment

What used 2708s? Very old retro-computing stuff. That only other chip I had and fried was from an Apple II card, when they were already going out of style.

 

And the problem wasn't getting the right power, the problem was getting everything together without being wobbly. A wobbly cheap hack is what killed that chip. I still haven't done the last steps yet, but I did find the rest of the parts that I need and put them in the bin.

 

Instead, I finished dumping a PROM for an in-circuit emulator that someone had that was missing the chip. Except it wasn't a chip, it was a board, and that was when things got interesting.

 

http://xi6.com/em-180/rom/U216.txt

http://xi6.com/em-180/rom/U216.zip

 

 

Link to comment

For what it's worth, I finally did it. But it wasn't without loss. While I was wiring up power connections, a wire I was holding made contact with something (probably +12V) for a moment. It took out the USB serial adapter (which was crap to begin with), my USB hub (which unfortunately had cool card reader stuff built in), and it also zapped something on the Blue Pill board. The CPU runs hot, but I can still program it, which is weird. It didn't take out the STLink that I had modified to bring out the proper reset signal. (some of those gumstick STLink clones only bring out the STM8 reset)

 

I slapped some tape onto the -5/+12 barrel jacks to avoid further accidents, plugged in another Blue Pill board I had ready, then I added some tiny switches so that I could manually stage the +5 and +12 power after putting the chip in the socket. I was surprised by one thing, however. Out of 16K of EPROM on two boards, I found three separate code regions, all with an effective origin of zero, so there must have been some basic memory remapping on the CPU board. The other interesting thing was that the EPROM boards had one -5V regulator for each group of four chips, so there were two on each board.

Link to comment
Guest
Add a comment...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...