Jump to content

Atari 1050 Turbo Module Test FAIL


Recommended Posts

I bought another one via local shop - only 16 Euro, but drive was not responding

Check the baud_base setting (with "setserial -a /dev/ttyS4"), most certainly the linux kernel set it to 115200 instead of 921600. If that's the case either do a "setserial /dev/ttyS4 baud_base 921600" before loading the atarisio kernel module or use the following config in /etc/modprobe.d/atarisio.conf:

options atarisio port=/dev/ttyS4 baud_base=921600


Also check dmesg, you should see something like this:

AtariSIO kernel driver V1.06 (c) 2002-2011 Matthias Reichl
atarisio0: detected 16C950: id = 16C950 rev = 0C
atarisio0: using extended 16C950 features
atarisio0: minor=240 port=/dev/ttyS4 io=0xd000 irq=20 baud_base=921600


BTW: Also check the docs of your card if baud_base is really 921600, not 460800 or so. Anyways, use the baud_base mentioned in your card's docs.


and when I was trying test it with null modem cable (another 4 Euro) this happened: https://bugs.launchp...nux/+bug/871270 will wait for some time.

Looks like the same issue as here: http://lkml.org/lkml/2011/5/17/469. This bug was fixed in, not sure if it ever got backported to 2.6.38.


so long,



Link to comment
Share on other sites

  • 1 year later...

partly solved: (maybe helpful)

i had to format a disk to single density on a working disk drive BEFORE using the RPM tool. IMPORTANT!

and insert it while adjusting RPM in the 1050 turbo RPM tool. the RPM was out of adjustment.. so i fixed it. by pressing select you can switch between lower and higher RPMs.


now i have to create a turbo masterdisk. but that's another hassle as far as i can see for now... crawling through spartados manual which seems only support US Doubler drives.

1050 Turbo should as well support any new copied dos disk without any modification, cause its ROM writes the sectors in another interleave automatically. if enabled at boottime of course. and if i understand it correct.

Edited by marquisor
Link to comment
Share on other sites

next problem:

all stuff is working so far UNTIL so it seems the drive has been longer running/turned on. didn't measure the time, would say working 15-30 mins with the drive it then gets read errors, stops reading, booting, recognizing any disk.


even the track seek movement if a before working disk or new disk or whatever disk is inserted is different from normal working drive then. it doesn't seek the same way as if everything was normal. turning the drive off/on for half a minute doesn't help.

the mechanic is ok, tested in another circuit board without any mods (turbo) and working for hours just fine.


maybe a heat issue? or power supply?

i don't think it's the FDC.

Link to comment
Share on other sites



I have one or two drives (Turbo 1050 or Speedy 1050) with the same issue(s) here. They work absolutely ok for approx. 10 minutes and then refuse to format, read or write any disks for whatever reason...


Sorry, that I cannot help you, but attached you can find my Turbo 1050 tooldisk with lots of tools for the original 1050 Turbo and tools for the compatible TOMS turbo drive. There are also turbo drivers included for Sparta-DOS or SDX (not sure if they are for the disk or cart version, since I never use SpartaDOS)...


-Andreas Koch.


Link to comment
Share on other sites

hmm, somehow good to know i'm not alone with this.

who could help us with that? i don't want to use spare parts from my working drive or set it up with turbo and then get the same issues.

it's just a feeling but maybe the voltage stabilizers/regulators can't match any higher current usage? for a longer time? i'm not a electrician, just a suspicion. as the heat plate is warmer than in my working drive.

thx for the tools btw, may come in handy :D

Link to comment
Share on other sites

Sounds like the capacitors in the power supply are dried out, which is placing a heavy load on the bridge rectifier (converts the incoming AC into DC). My guess is that if you measure the 5V and 12V rails when cold, and then when the drive is failing, you will see them dropping. There are threads here about that. The two basic options are to repair the internal power regulation section in the drive, or bypass it using a PC power supply (which will supply both the 5V and 12V lines).

Link to comment
Share on other sites

got two 9V/3A power supplies here. i would exclude them from being defective.

btw what do you mean by 5/12v the power supply does 9V/3A..

so you mean 9V AC -> 5/12V DC gets converted inside the drive. and this capacitors you mean? the large 3 near the heat plate?

good idea to measure the voltage and maybe usage of PC power supply is a good consideration for testing purpose. should produce enough wattage / current. :D

would have to know where to "inject" these voltages and if i would have to cut something for it?

you don't think the voltage regulators are weak? i don't know if a voltage regulator would die instantly or getting weaker like capacitors.

well ... i'll have a look. thx


EDIT: some typos, misunderstandings.. ;)

Edited by marquisor
Link to comment
Share on other sites

ok here's what i've done so far. got the 1050 service manual and focused a bit on the power issue topic...

well the results are not satisfactory.


took 2h of testing with open drive case.





Voltage measured


Time	TP13	TP14	QP7	QP8	Remark

0:00	4,85	3,42	4,86	11,93
0:06	4,84	0,10	4,85	12,01	1
0:10	4,85	3,33	4,85	11,98	
0:20	4,84	3,31	4,85	11,98
0:30	4,84	3,30	4,84	12,00	2
0:38	 no results, but no failure
0:55	 no results, but no failure
0:60	4,85	3,30	4,85	11,97	3
1:30	4,85	3,30	4,85	11,98	3
2:00	4,84	3,29	4,85	11,98	2,4
2:03	4,84	0,10	4,85	12,03	4,5
2:05	4,85	0,10	4,85	12,03	4,5

  1. while running TDOS 2.1 DiskCopy reading
  2. after formatting, loading, copying, running MyDOS now
  3. not used, drive only let turned on (idle)
  4. failure starts, some read errors get more and more
  5. while access/retry to read

measurements done with - on heatplate, + on TP13, TP14, right pins of QP7 and QP8.


the "no results" come from simple tests displaying directory twice etc. and no measurement because i was doing other stuff.


so the voltage at TP14 is strange.. the voltage regulators seem to be ok. seem... can anybody confirm any low voltage at TP14? especially CharlieChaplin with same issue?


measurements on a working circuit board only, no mechanics attached:

TP13 5,01V ; TP14 3,22V ; QP7 5,01V ; QP8 12,20V

but this drive is working fine even after 12hrs. unmodified, no turbo.


what now?

Edited by marquisor
Link to comment
Share on other sites

By looking at the schematic, TP14 comes from the regulated output of Q8 with should be 12 volts.

If you're showing a bit over 3 volts at TP14 but 12 volts at Q8, then I would check the physical trace for burns, breaks or a cold solder joint.

Another possibility would be some part on the 12 volt rail is shorting out...

Link to comment
Share on other sites

on both drives? the working one's circuitry also has only 3,xxV there.

but in the schematics it's true. straight 12V from output to TP14...

C65 (can't read exactly, damn lores blurry pdf i got, but C63 is elsewhere) and C70 is on the way.

funny thing: on the another, working 1050 without mods it's nearly the same voltage..



Edited by marquisor
Link to comment
Share on other sites

Are you sure you are taking the measurements at TP14 and not the feed through hole that goes to the bottom leg of R63?

I just did a continuity check on mine between TP14 and Q8 and I'm showing zero ohms here...


god damn it. yes... measured the solder spot NEAR the TP14, but not TP14... well... same here 0 Ohms and same voltage as on output... so far.. dang...

better remeasure it all? but why. 0 Ohms... running and not running.

now got another power supply directly attached to QP7/QP8 output 5V/12V from external SCSI HDD Drive case. bootup fine... disk operation normal.. i'll see if that works.

should be near enough power, as harddisks need 30-40W for spinup.

Edited by marquisor
Link to comment
Share on other sites



Just some remarks and recommendations.

Start at the basics. The drive needs a 9V AC at the power input.

This AC is rectified into a pulsing voltage that feeds a voltage doubler. That's the reason for 3 big capacitors and some extra diodes in the circuit.

The 5 volt for the logic is (almost) ok.

For the regulators to work, they need the input to be at least 3V higher than the output.

My guess would be that one or more of the capacitors is not good enough anymore. (Due to age)

And the supply has always been a problem with these drives. Once the unit gets warm, bad capacitors will be worse.




  • Like 2
Link to comment
Share on other sites

well... after installing and testing with a PC style power supply which gives me 5,10V / 11,90V directly connected to QP7 and QP8 output gives similar results... after 2hrs now the first read errors start... WTF :mad:


i don't think it's the rectifier, doubler, regulator issue then?! because the capacitors etc. aren't needed / used anymore for supplying 5V/12V by my workaround...

maybe the module (or any other IC) gets too hot? but switching off for 5 mins doesn't work.



maybe it's not a power problem? i'm at loss...

Link to comment
Share on other sites

I think you might be on the right track, could be a thermal problem where an IC breaks down or the frequency of a crystal changes.

You can use a hair dryer to warm up the parts to see if they fail earlier or try some cold spray after each hour to cool them down to see if that helps...

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...