Jump to content

my controller suddenly giving me powering problems


Recommended Posts

it will only work with the play & charge cable plugged in. once the light goes green, i should be able to unplug it and still use it but it immediately dies. brand new AAs in the battery shell don't work anymore either.


is this a common thing that happens over time? is there a fix? it's the Limited Edition green (Halo 2?) controller if that makes a difference...

Link to comment
Share on other sites

  • 2 weeks later...

i (finally) bought a second 360 controller after owning the system since somewhere in 2008. i thought that since the Play & Charge worked flawlessly, then it must be the shell for the AA batteries that is faulty.


i tested the brand new AA battery shell (with brand new AAs) in my problematic controller. it connected, although the green light was very faint. as soon as i touched a key on the chatpad, the chatpad lit up like it was supposed to and the controller immediately died.


so then i thought it was the chatpad causing the problems. i disconnected that and again tried connecting my old controller (with the new AA shell). instead of the player 1 light coming on, all four lights came on dimly for a split second and went off. i tried this repeatedly. same result.


i hooked up the Play & Charge up once more to make sure the controller wasn't now completely dead. it STILL works flawlessly with and without the chatpad.


it's definitely the controller.


then i tried removing the outer-casing of the new black controller to swap it out for my old green one, but even my precision tool set won't turn the screws.


ah well. i can still use the old one as a wired controller. so eff it.

Edited by bomberpunk
Link to comment
Share on other sites

The same thing happened to my stock controller that came bundled with my Slim unit (about a year old now). I bought another play 'n charge kit thinking that the battery pack was simply dead (it was an old model from '06 or so), but a new kit didn't help much. I think there may be a general defect in some of these controllers. At least I can still use it with the charge cable hooked up, but it's not ideal.

Link to comment
Share on other sites

yeah it makes absolutely no sense how only a constant USB connection is the only way they will work. it's almost as if the normal voltage or current is no longer enough to power them. i'm no electronics expert, but perhaps by sucking power from the console gives it a little more juice than usual to make it work properly. **shrugs***

Link to comment
Share on other sites

Could be the radio transceiver thing in the controller has died....that would stop it from working, unless it was plugged in....but I thought plugging it in only powered it, not was a com cable as well. I would expect it to last at least as long as the system is expected to though.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...