Jump to content

Classic99 on LINUX (Fedora 15) and Windows


Recommended Posts

Yes, I realize that Classic99 is only really targeted for Windows, but I've been working with it through Wine on a Fedora 15 system as well as a Windows XP instance running in Virtual Box. In general, it works very well. Speech synthesize is not that good in this instance, but everything else is quite good.


The problems I've had are:


On LINUX, getting some Infocom games, sp. Leather Goddesses of Phobos, running doesn't work. For starters, I cannot access the file system through the DSK1 menu option - it crashes. No problem - I just change the .ini file to have that disk in the right place. (I'm using the Infocom disks from Western Horizons, by the way.) All of the Infocom games I've worked with in this form work fine, but LGoP goes to a green screen and freezes. I get the same result when I try to use this file through MESS, but if I go to the WinXP instance, it runs fine with Classic99.



On a Windows XP system (Virtual Box instance) I was trying to get Disk Manager 3.0 in place as a User cartridge by modifying the .ini. I'm able to do the Pole Position example in the manual, but when it comes to Disk Manager 2.0 (or 3.0) it just doesn't work. The ROM file is called dskmg2g.bin, so I add this:



name="Disk Manager 2.0"



The result is that when I choose this cartridge from the menu, there is only the "1 TI BASIC" option to choose from after the title screen.



Any tips are appreciated.




For the Disk Manager carts, I changed the ROM line to this:




and it works great. Simple memory address issue.

Edited by KirkDCO
Link to comment
Share on other sites

You got my first guess on the Disk Manager carts already...


As for the lockups under Linux, that's odd. In Classic99 at least, you can open the debugger before you launch the game, and watch the debug log. If the lockup has anything to do with disk, it may print some interesting messages before it freezes.


I'm not familiar with how Wine handles the disk interface, but inside of Classic99 little parsing is done, it pretty much just prepends the configured path with the filename you ask for. So it may (should?) be possible to specify Linux pathnames if that is useful.

Link to comment
Share on other sites

Thanks for the response, Tursi.


I ran the debugger but didn't find anything. No messages outside the normal operating messages. During the process, I was exploring the Infocom disks as well as some others. It seems that classic99 can't actually read the disks. Either the V9T9 format or the FIAD format (the DSK1 contents that are default with classic 99, too) when I go to a disk manager and try to get a catalog it gives a partial disk name and and empty disk. All of the Infocom disks I checked give a no disk found error (7, I think). These exact same disk files work fine on the WinXP VM. It would appear that there's a file system read problem., but I'm not sure how to approach it.


I checked the same disks under MESS and they read fine. Here I get the green screen and freeze up when trying to start Leather Goddesses of Phobos while other Infocom disks work (Planetfall, Zork, Ballyhoo).

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...