Jump to content
IGNORED

Images generated by RastaConverter


Philsan

Recommended Posts

29 minutes ago, a8isa1 said:

These are the best pictures I can manage

They are more than good enough.

So, the 800 clearly shows the 'Spiderman'-type artefact in this test (missing blue block), as well as the line 6-level artefact.

I assume your XL shows the blue block fine?

Link to comment
Share on other sites

12 minutes ago, drpeter said:

They are more than good enough.

So, the 800 clearly shows the 'Spiderman'-type artefact in this test (missing blue block), as well as the line 6-level artefact.

I assume your XL shows the blue block fine?

Yes, 800XL display appears as in your photo except with the NTSC palette.

Link to comment
Share on other sites

7 hours ago, drpeter said:

PS @Philsan, am I correct that the modified Spiderman xex I posted above no longer shows the artefact on any of your machines, after any wait?

I am sorry, I forgot to test your modified Spidey, I'll do it tonight, together with you new Artefact Test.

Thanks!

  • Thanks 1
Link to comment
Share on other sites

Antic emulation core in RastaConverter needs fixing - I did it according to old Altirra Hardware Reference manual which later Phaeron improved. I'm out of time and also interest (sorry, other projects in pipeline) to do it. The project is open source so maybe some other programmers will be willing to improve it.

  • Like 1
  • Thanks 3
Link to comment
Share on other sites

2 hours ago, ilmenit said:

Antic emulation core in RastaConverter needs fixing - I did it according to old Altirra Hardware Reference manual which later Phaeron improved. I'm out of time and also interest (sorry, other projects in pipeline) to do it. The project is open source so maybe some other programmers will be willing to improve it.

I think we all understand that. This issue is I believe a new observation that goes slightly beyond the known issue in RastaConverter's PMG emulation to document a small further variation between versions/instances of real hardware that I'm hopeful we can pin down and get documented and possibly implemented in Altirra.  We already have the knowledge and means to fix the vast majority of little glitches that RastaConverter throws up- a small price for such a brilliant facility.

  • Like 4
Link to comment
Share on other sites

15 hours ago, rensoup said:

Glad you like that BS tune, it's also one of my favourite tunes, and Vinscool's cover is my favourite A8 cover ever ?

(and also covered at my request ?) It runs at 100Hz but can be converted down to 50Hz easily with RMT2LZSS with minimal loss.

You bet... the LZSS player is much faster than RMT so if RMT can be played, it's no problem either for LZSS. I don't know if anyone did RC + LZSS though I know @pps did a G2F + LZSS app.

 

Any volunteer ?

@rensoup Hi. Whilst I have the opportunity I am just gonna go off topic for a sec. I just wanted to personally thank you and others involved for your dedication and hard work in bringing Price of Persia to the A8.:grin: I was totally blown away to see it was actually a reality and also relieved that the trademark quality animation has been painstakingly recreated. You could have made it easier for yourself and had very rudimentry character animation and colours - but the game would have been far worse off for it. (One of the reasons I love Tommingi, (A8 Lemmings clone), was it faithfully recreated the Lemmings character animation - just a pity it was only ever released in greyscale)). I loved playing PoP in the 90s and can't wait to see and play the finished product. (Really excited to see the cut scene animations also).

 

Anyhoo - back to Rasta and BattleSquadron. I have yet to check out Vinscool's cover. I am currently cooking the image for it so I'll post it once done. Then maybe someone can have a go at pairing it with an LZSS tune - even better if it is the BS LZSS tune. ;)

 

I am also cooking up a whole load of new images which I hope to post by the weekend. :cool:

 

 

Edited by Beeblebrox
  • Like 1
Link to comment
Share on other sites

@drpeter, in your modified Spidey, line doesn't appear.

 

Here's the result of Artifact Test 2.

 

Cold machine:

 

1499749078_Artifact2Cold.thumb.jpg.8403d35c4d382053f7b82b82d054a251.jpg

 

After some minutes, of the center left rectangle only one/two lines remained at the bottom of it, then after a few seconds the lines disappeared too:

 

2025286973_Artifact2Hot.thumb.jpg.32dc7cab150e22c38d1ee3af73320777.jpg

  • Like 2
  • Thanks 1
Link to comment
Share on other sites

7 hours ago, Beeblebrox said:

I loved playing PoP in the 90s and can't wait to see and play the finished product. (Really excited to see the cut scene animations also).

Thanks, it took far longer than I hoped but but it's coming together... Next version won't be final but close!

 

7 hours ago, Beeblebrox said:

Anyhoo - back to Rasta and BattleSquadron. I have yet to check out Vinscool's cover. I am currently cooking the image for it so I'll post it once done. Then maybe someone can have a go at pairing it with an LZSS tune - even better if it is the BS LZSS tune. ;)

Should be easy enough but don't count me in... I got other plans and you'd rather get your hands on a new PoP release wouldn't you ? ?

Link to comment
Share on other sites

1 hour ago, Philsan said:

After some minutes, of the center left rectangle only one/two lines remained at the bottom of it, then after a few seconds the lines disappeared too:

 

Ah! Well we've reproduced the phenomenon under controlled conditions...  Need to give this a bit more thought...

  • Like 3
Link to comment
Share on other sites

1 hour ago, rensoup said:

Thanks, it took far longer than I hoped but but it's coming together... Next version won't be final but close!

 

Should be easy enough but don't count me in... I got other plans and you'd rather get your hands on a new PoP release wouldn't you ? ?

@rensoupGreat re PoP - looking forward to it. Best of luck with it coming together. :) thanks again.

Link to comment
Share on other sites

13 minutes ago, drpeter said:

 

Ah! Well we've reproduced the phenomenon under controlled conditions...  Need to give this a bit more thought...

@drpeter I am watching from the sidelines with great interest. ;-) Anything that can improve on this already fantastic asset and help weed out these annoying visual anomalies is a bonus. Thanks to all for the collective work going on here. (Must admit it takes a good few re-reads of some of the tech content in these posts for it to sink in mind heh heh! :dunce:)

I am picking up my Atari hardware this weekend so - if it all still boots up - I should be able to see these images on the real thing - fingers crossed. :)

Link to comment
Share on other sites

OK fellow investigators, @Philsan, @a8isa1, @Faicuai- this one should be interesting.

 

The colour banding in the left margin should appear and persist (gives GTIA 7 colour-clocks notice of player display) but the checkerboard on the right gives only 6 colour-clocks notice for each player repositioning, so may either not appear at all, or only in part, or appear on cold-start but gradually or suddenly disappear as the chips warm up...

 

The exact conditions of the 'Spiderman' artefact (horizontal player position and vertical position on screen) are reproduced for player 3 (light blue) on row 12...

 

Enjoy!

Untitled_3.png

drpeter_Artefact_Test_3.xex

Edited by drpeter
  • Like 1
Link to comment
Share on other sites

10 minutes ago, drpeter said:

blue box absent and the line at level 6 from the start

The machine was one for very little time.

 

When I fired it up, I first ran a couple of SIO tests, and then loaded yours. Barely 5 mins.

 

There was no "warm up" as I know it. So I would say it was there from the start.

 

 

Link to comment
Share on other sites

33 minutes ago, Philsan said:

 

Video of what happened after 8 minutes (final part of rectangles vanishing):

 

Fascinating.  So on this particular machine it only happens with Player 3, after about 8 minutes of warming up, and only on the far left side of the scanlines. Furthermore, there seems to be a consistent slight variation dependent on the vertical point on the screen, as the rectangles don't all disappear at an identical time/rate...

 

I wonder whether the horizontal variation is due to exactly that, or the fact that the leftmost rectangle on each line represents in-scanline reuse of the player (whose previous incarnation provides the leftmost vertical colour banding).

 

This is a rejig of drpeter_Artefact_1 that places Player 3 on the left of the screen.  I wonder if with this the leftmost bar jumps up to 6 after warm-up?

drpeter_Artefact_1a.xex

  • Like 2
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...