Jump to content
IGNORED

Images generated by RastaConverter


Philsan

Recommended Posts

please rename this, the forum can't sort the two of them in it's attachments search. You have two named the same.... I made it dark forest2 after going back in alpha sort since this replaced the first one.

  • Like 1
  • Thanks 1
Link to comment
Share on other sites

3 minutes ago, _The Doctor__ said:

please rename this, the forum can't sort the two of them in it's attachments search. You have two named the same.... I made it dark forest2 after going back in alpha sort since this replaced the first one.

oops my bad I don't have access to rename or delete can you just delete it.  sorry :(

  • Like 2
Link to comment
Share on other sites

9 minutes ago, Atari8man2004 said:

oops my bad I don't have access to rename or delete can you just delete it.  sorry :(

Maybe some admin can help?

Link to comment
Share on other sites

Here's another Doom demon. After several restarts I gave up on the PMG errors. I thought that was fixed? @Sheddy I can send you the intermediate files if you want to have a look.

 

Original:

 

demon2.png.6c2d44fb4d3dfed284761c949d134a6e.png

 

What RastaConverter thinks:

 

output.png.18accb8b91c2093b037f794ca4083986.png

 

Actual output:

 

atari000.png.d46eba10a13abf831162a90b6e42e95b.png

 

There are two bugs at the right side of the eyes and one near his shoulder in the black area.

 

33 colors.

 

 

ivop_demon.xex

  • Like 9
Link to comment
Share on other sites

1 hour ago, ivop said:

Here's another Doom demon. After several restarts I gave up on the PMG errors. I thought that was fixed? @Sheddy I can send you the intermediate files if you want to have a look.

 

Original:

 

demon2.png.6c2d44fb4d3dfed284761c949d134a6e.png

 

What RastaConverter thinks:

 

output.png.18accb8b91c2093b037f794ca4083986.png

 

Actual output:

 

atari000.png.d46eba10a13abf831162a90b6e42e95b.png

 

There are two bugs at the right side of the eyes and one near his shoulder in the black area.

 

33 colors.

 

 

ivop_demon.xex 22.16 kB · 1 download

Nice one. 

Are you running the latest beta 10? 

 

AFAIK I didn't think it was possible to completely eradicate the hpos pmg line errors. 

  • Like 1
Link to comment
Share on other sites

@ivop

If you could share all the output files so a /continue can be done that'd be great.

 

The display emulation of players wasn't changed because of how RastaConverter works made that difficult. Instead, lines with position timing issues or overlaps are given a high error score, so strongly discouraged as a good solution.

Unless it was only running a short while the output does seem odd that it hasn't come up with a line with fewer errors. But given how random and crazy the things RastaConverter does is, you may well have hit an edge case that isn't accounted for.

 

 

 

 

Edited by Sheddy
  • Like 1
Link to comment
Share on other sites

17 hours ago, Beeblebrox said:

Are you running the latest beta 10? 

Yes. I compiled the latest version from github.

 

6 hours ago, Sheddy said:

@ivop

If you could share all the output files so a /continue can be done that'd be great.

I'll send you a zip-file via personal messages.

  • Like 1
  • Thanks 1
Link to comment
Share on other sites

On 6/9/2024 at 8:47 PM, ivop said:

Here's another Doom demon. After several restarts I gave up on the PMG errors. I thought that was fixed? @Sheddy I can send you the intermediate files if you want to have a look.

 

Original:

 

demon2.png.6c2d44fb4d3dfed284761c949d134a6e.png

 

What RastaConverter thinks:

 

output.png.18accb8b91c2093b037f794ca4083986.png

 

Actual output:

 

atari000.png.d46eba10a13abf831162a90b6e42e95b.png

 

There are two bugs at the right side of the eyes and one near his shoulder in the black area.

 

33 colors.

 

 

ivop_demon.xex 22.16 kB · 5 downloads

 

What version of Atari800 did you get that screenshot from Ivop?

Interestingly, it displays correctly on Altirra 4.2

I haven't tried Atari800 for a while, but on the old Atari800win plus 4.1 I have to hand it does have the same issues you're seeing.

I thought the player emulation issues were pretty much all ironed out by the time of that old version, and I can't remember seeing other (maybe old version created) RastaConverter pictures with different issues than Altirra. Looks like that isn't the case though :(

 

Edited by Sheddy
Link to comment
Share on other sites

18 minutes ago, Sheddy said:

What version of Atari800 did you get that screenshot from Ivop?

Interestingly, it displays correctly on Altirra 4.2

I haven't tried Atari800 for a while, but on the old Atari800win plus 4.1 I have to hand it does have the same issues you're seeing.

I thought the player emulation issues were pretty much all ironed out by the time of that old version, and I can't remember seeing other (maybe old version created) RastaConverter pictures with issues. Looks like that isn't the case though :(

Ah, that was it. I was using 5.0.0, which I thought was recent enough, but apparently it wasn't. 5.2.0 works correctly though. Thanks for investigating.

  • Like 1
Link to comment
Share on other sites

errors are not errors if they do not appear so on real hardware. emulation issues and fpga issues are really a bane/nuisance to the programmer at large. I always thought Ivop was a real hardware guy, so emulation errors did not occur to me.

  • Like 1
Link to comment
Share on other sites

2 minutes ago, _The Doctor__ said:

errors are not errors if they do not appear so on real hardware. emulation issues and fpga issues are really a bane/nuisance to the programmer at large. I always thought Ivop was a real hardware guy, so emulation errors did not occur to me.

I am a real hardware guy, but not always ;) And I was under the impression that the atari800 emulator did not have any HPOS bugs anymore, but it shows that even v5 was not right. 5.2 is though.

Edited by ivop
  • Like 3
  • Thanks 1
Link to comment
Share on other sites

5 hours ago, ivop said:

I am a real hardware guy, but not always ;) And I was under the impression that the atari800 emulator did not have any HPOS bugs anymore, but it shows that even v5 was not right. 5.2 is though.

But some people say Altirra is better. Because they hate GNU/Linux?

Link to comment
Share on other sites

11 hours ago, GravityWorm said:

But some people say Altirra is better. Because they hate GNU/Linux?

Not sure what your point is. Altirra is a better emulator. No doubt about that. But it's Windows only and there's no feasible way to make it cross-platform as its code is heavily tied to a multitude of Windows APIs. Atari800 on the other hand runs on systems ranging from the Atari Falcon to Android phones. Combined with its faster startup time, I mostly use atari800 for development, and only test on Altirra periodically, and finally test on real hardware. I run Altirra with wine on Linux. Recently upgraded my distro and now D3D11 is broken and Altirra doesn't render correctly. Luckily phaeron still supports D3D9 as a command line option, which works fine under wine.

  • Like 4
Link to comment
Share on other sites

Hi @Atari8man2004!
i'm working on an image made by You
i changed some details...
This is how it looks on my CRT:
Soon i will post final results...

DSC_0042_.PNG

Edited by GravityWorm
  • Like 5
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...