Jump to content

Playing SMS games on the Genesis using the Everdrive MD


Recommended Posts

Does an SMS light phaser work with the Genesis and an Everdrive? If not, does the phaser worth with this adapter mod?


I can't test it, because like a moron I sold all of my SMS light guns. I so hate repurchasing things... but I will gladly do it if someone else can verify that everything works...


I tried it on my Model 2 with the NeoFlash cart - it works fine. I ran Shooting Gallery with the standard SMS Phazer gun, and after I moved it to port 1, it worked like a charm. So it should be fine with the Everdrive as well - they both work the same way on running SMS games.

Link to comment
Share on other sites

I would just cut the wire in the controller that leads to that pin, wire a switch to them, cut a hole into the controller in a place where its out of the way.


Cutting a hole in the controller and wiring up a switch sounds like a lot more effort than pulling a pin out of a connector. Why bother with the extra effort of controller mangling?


Because I like the challenge, plus having a switch on it to select the modes would be what I want

Link to comment
Share on other sites

I got the male/female pass thru(s) and pulled pin 7 out with a pair of needle nose pliers. The only issue I had was that the adaptor doesn't seem to plug tightly enough into my Model 1 Genesis, so I used it between an extension cable and the controller cable. Worked perfert. I have to say I really like the SMS version of Montezuma'a Revenge.


Thanks to everyone for the responses.

  • Like 2
Link to comment
Share on other sites

  • 2 years later...

I use a Nomad for most of my Genesis/Megadrive game playing, so obviously using an SMS pad is not an option.

Is there any patched version of Wonder Boy in Monster Land that would work properly when played on a Nomad/Genesis ?



I think that has what you're looking for.

Link to comment
Share on other sites

  • 8 years later...

Today I made myself an adapter so I could try the SMS version of Montezuma's Revenge. I used a male db9 connected to a female db9 with a short piece of controller cable. No wire connects pin 7 from male to female and I removed pin 7 from the female db9 plug. I plugged my Genesis controller with the adapter into the console with a Mega Everdrive cartridge, powered it on and quickly realized that the controller didn't work. No d-pad, no buttons. Is this expected behavior?





I found I could play Montezuma's Revenge only if I first "select and start" it from my Everdrive cart WITHOUT the adapter. Once the title screen showed, unplug the controller, plug it into the adapter, then plug the adapter into the console and finally press B button all before Joe starts ascending the steps of the pyramid on his own.


I mention this because nobody else talked about swapping adapter/controllers to get the game to work during the progression of this thread. Maybe I messed something up.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...