Jump to content

Pong C-100 Wont Keep Score and starts by itself


Recommended Posts

Hello all,


I was just throwing this out to hopefully find an answer. I have a Pong c-100 that I found at my mom and dads this weekend that I used to play when I was a kid. Anyhow, It will display the game, play sound, but it starts on its own and will not keep score. I have it taken apart, and found that it has the 3659-3 IC in it. It also has a 7404-n Hex inverter in it. My question is, does anyone know what could be causing the issues with the score and self starting or if anyone has the pin outs for the 3659-3 IC? Any help would be appreciated. I tested the start switch, no shorts; also tested the diodes, good. I've tested most of the resistors, good. I haven't tested all the caps yet but none seem to be leaky. That leaves the chip or the transistors from what I gather. But I am not to sure. I would love to play my original old pong system that I played back when I was 4 year old again. I also included a schematic of the c-100 to help you help me out...


Link to comment
Share on other sites

  • 6 years later...
  • 2 years later...
On 8/22/2019 at 2:13 PM, willwinter said:

Hi again linuxfanman,  

I replaced the .001uf capacitor at C14 and it indeed fixed my issue! I did not replace the resistor at R12.  

Thanks again! My Pong C-100 is working perfectly now.  


Will Winter

Hello, sorry to resurrect this old thread, but I'm having the exact same issue and trying to replace C14 but need help finding the replacement part. Does the voltage matter? All the .001 uf capacitors I'm finding are 1000V.  Any links would be appreciated. Thanks.

Link to comment
Share on other sites

10 hours ago, ahofle said:

Does the voltage matter? All the .001 uf capacitors I'm finding are 1000V.

The voltage indicated in capacitors specs is the max rating, so, as long as it's not less than the actual voltage that will be applied to it in the circuit (5v in this case), it's fine.


Link to comment
Share on other sites

OK...so I actually have a Super Pong (C-140) and I've replaced this damn C14 capacitor 3 times now with no luck. I've also replaced the NC reset switch with no luck. Once or twice I was able to play with the score working, but usually it just zeros out. Obviously something is intermittent. I put a piece of metal between the capacitor conrtacts and held it in place and everything worked perfectly. Once I let it go, it's back to no scoring. Any suggestions on what to try next? At a loss here. One note is on my C-140 there is no resistor in the R12 spot. I guess that's normal for the C140?

Link to comment
Share on other sites

Updating this for the benefit of others...it turns out the issue was neither the capacitor nor the reset switch itself. The little blue plastic connector that plugs into the board was actually the issue. I was never able to get a clean connection. When I manually bridged the two pins on the board everything worked fine. Tried cleaning it and the contacts with no luck. For kicks, I reattached it 180 degrees from normal and everything magically works perfectly now.


Edited by ahofle
  • Like 1
  • Thanks 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...