Jump to content

Vectrex Problem - Very faint white dot, no sound


Recommended Posts

So a friend picked up a Vectrex with a few games recently while on vacation. Worked great when he tested it at the seller's house. Placed the system in his trunk, drove home from Florida (we're in Tennessee), and then tried playing with it again once he got home. Only this time, it wouldn't come up. When he turned the power knob, the only indication that it was getting power at all was a bit of static when adjusting the volume knob. That initially led me to believe that it was something to do with the vibration or possible jarring in the trunk on the ride home that might have caused it to stop working.


So he gave it to me to take a go at fixing it since I have at least basic electronic repair skills. I did a bit of research and went through all the basic repairs: popped open the case, discharged the tube, pulled, polished, and reseated all the removable ICs, re-flowed the 4 power pins coming in from the power board to the logic board, cleaned the power pins, checked the voltages coming into the logic board (got all good readings of -5, +5, and -13 reading from the PCB), and just did some general cleanup of the 30 years of crud that had accumulated on the board and in the case. Still no dice.


I wanted to see if the monitor was lighting up at all, so I turned off all the lights in my office, then fired up the Vectrex. Sure enough, after turning it on and waiting 10-15 seconds, I gradually saw a little white dot rising from the bottom of the screen and coming to a stop a bit northeast of center. When I turned off the power, the white dot illuminated a bit brighter for a split-second, then immediately went away (rather than slowly fading out like my working Vectrex does at power-down).


That behavior makes me think it's most likely to be a capacitor problem, but I wanted to check here with the experts before making any assumptions and dropping money on a cap kit that may be either unnecessary or futile. Of course, I don't know if that would necessarily explain why the BIOS (or whatever) doesn't still fire up and play the little musical ditty on startup. My own uninformed theory is that, even though the voltages are reading good, it's possible that bad capacitors on the power board are not supplying the amperage that the logic board or tube needs.


Ok! Now that my own highly-amateur insights are done with: Any advice on how to proceed? Other places to check for voltages that might help? Maybe there are pics I could take and share that would assist with the diagnosis? I'm determined to resuscitate this glorious little black box, but I need some nudges in what is presumed to be the right direction. :)


Thanks in advance!

Edited by gzsfrk
Link to comment
Share on other sites

im not familiar with the guts of a vect, but caps could be a problem, course check the big can ones to see if they are shorted or not storing energy (its hard to get an accurate measurement in circuit though) or obiously failed (bulges leaks etc)


I wouldnt buy a cap kit, I can never tell what quality they are, I usually get a notepad and write down each cap's voltage, capacitance, and with calipers get their rough width and height, once I do that its off to digikey to get some modern high quality, high temp (105c) high lifespan caps (like Panasonic) which usually costs about the same as getting a mystery bag off ebay or joes parts shack


small ceramic caps are also susceptible to vibration so check them as well, they usually fail with an open circuit


PS: caps can hold quite a bit of energy so dont let them whack you

Edited by Osgeld
Link to comment
Share on other sites

PS: caps can hold quite a bit of energy so dont let them whack you

Especially the CRT ballast :o


I once launched a dismantled disposable camera 20 feet across the Kitchen when I was a teenager, ouch! I was repeatedly charging up the flash cap and shorting it with a screwdriver tip, making a loud Black-Cat-like "pop" every time, annoying my mom to no end in the process... :P

  • Like 1
Link to comment
Share on other sites

modern high quality, high temp (105c) high lifespan caps (like Panasonic)

FWIW, these are the only kinds of caps I include in my kits icon_smile.gif High-temp ratings and well established brands.


I do sell Vectrex cap kits BUT I don't think the OP needs a cap kit. A center dot & no game sound would point to a digital problem and if the voltages are in spec then the problem is probably in one of the IC20X chips. I would begin by verifying the clock & /RST and then move on to the logic probe and see what the bus is doing.

Link to comment
Share on other sites

  • 3 weeks later...

Apologize for the tardy update; been busy with life (kids, Easter, et. al.).


So I notice that the more I mess around with this Vectrex, the weaker and weaker the little white dot gets. It's actually to the point now that I can't even make it out any more. I also should have mentioned before that, when my friend first tried this unit, the games played, but he said they looked faint, even with the brightness turned all the way up. I also will mention that there is absolutely NO buzzing coming from the system when it's on. In fact, the only evidence I can now detect that the unit is on (short of using the multimeter) is that there is very faint scratching noise when adjusting the volume. But even that is weaker than it was when I first started working on this.


Is it possible that the power supply is going bad, and that there isn't enough amperage being supplied to the display? I seem to recall reading somewhere that the logic board won't execute the code if it doesn't detect that the display is functional. (But that could have just been forum tripe.)


Any ideas? If the PS is going bad, would it be a safe bet to assume that replacing the caps would be my best shot at fixing it?


Thanks to all for the replies so far! Definitely don't want to see this clean little unit lost to posterity.

Link to comment
Share on other sites

One more quick update: Left it off for an hour or so, then when I decided to turn it back on one last time for the night, the dot was back and looking about the same brightness as before (which is to say, not very bright at all; but it WAS visible, at least). Not sure if that's helpful information, but there you go. :)

Link to comment
Share on other sites

In the event the power supply is bad, the brick can be replaced. I would test the brick with a multimeter, both with the system on and off. Assuming the voltage unloaded is close to or slightly higher than the nameplate, and doesn't droop by a significant amount when plugged into the system, the the PS is presumably good. If the voltage droops when the console powers on, it could indicate a short draining the power, or the PS is weak. Test the Vex with another supply of similar rating. If the PS is bad, replace it. I don't know what voltage/amp rating on the Vex PS is, but I assume it's more than a regular console because it has to power the CRT ballast. If you know how to use the ampmeter function, check to see if the Vex is draining too much current. An ampmeter is basically a short, so you need to connect it in series with the power supply. Wire the minus on the power supply to ground on the power jack, being sure to observe polarity. Wire the plus on the adapter to the ampmeter, and the other lead to the plus on the power jack. Use the ungrounded high current setting on the multimeter. Otherwise you'll blow a fuse in the meter if it's over 250ma. Turn on the Vex. If more current flows than the rating on the faceplate of the Vectrex, there is likely a short somewhere. Disconnect the power and check for the presence of blown fuses in the Vex. If a fuse is blown, replace it with a fuse of the same rating. May require soldering. If it blows again, you've got a fault somewhere.


I don't know much about diagnosing CRT tubes, but the next thing you'll want to check is the 5V regulator that powers the digital electronics. If the 5V regulator isn't putting out any juice, then nothing's going to work. If VCC reads 4.9-5.1V with the Vex plugged in, then it's working. Next check the filter cap which should be nearby the reulator. You may need a shematic or diagram to identify it. I would replace the filter cap first before recapping the entire board.


Atari used "chicklet" caps. My four switch Atari had terrible noisey signal when I first got it. Replacing the voltage regulator and filter cap revitalised it.



Edited by stardust4ever
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...