Jump to content
IGNORED

Extended Basic 2.7. She never CALLs!


PeBo
 Share

Recommended Posts

Ya, long time no talk, but moving right along....

 

Noticed some strangeness recently...not sure when it started happening.

 

None of XB2.7's CALLs are working....not CALL CAT, or CALL CHIME OR CALL «gamename» etc. Also the CF7/NanoPEB CALL MOUNT (which still works on the regular XB cart and TI BASIC) seems fried as well.

 

Not only do they not work, but trying to use them locks the system (no FCN QUIT only power off/on)

 

All the standard XB CALL commands (SAY, LINK, LOAD etc) work. I have tried using CALL commands with the nanoPEB OR the PEB attached - makes no difference.

 

I installed an F18A, last week, but I really can't say if that's when things stopped working (and the installation went off without a hitch), but everything was cool and groovy until recently. Noticed it first with CALL MOUNT, but since that works in TI-Basic, I wasn't concerned. Just noticed yesterday that all the new CALLS (and CALL MOUNT) are effected

 

Using OPEN #1/INPUT works, as does OLD DSK.

 

Has anyone experienced anything similar????

 

I have version 2 of 2.7 (black border/green screen FCN AID) if that helps.

Edited by PeBo
Link to comment
Share on other sites

Yup, I'm experiencing the same thing. I've just decided to 'live with it', because after repeated attempts to fix it, I'm obviously not up to the task. (sigh) I play very little in XB anyway and I'm VERY pleased with the latest "BOOT upgrade" and the other aspect of the cartridge that I use.

 

If I recall there was an upgrade that was supposed to address some of the quirks, like the DSC2HEX issue, but I never got that to work either.

 

I too am using the black border, green screen version dated April, 26 2015 with an F18A. Curious.

 

BTW - Welcome back PeBo, yes, it's been too long!

Link to comment
Share on other sites

Did you update the cart?

 

What color screen do you get with Fctn-6?

 

See here for a possible fix:

http://atariage.com/forums/topic/229718-extended-basic-v27-suite-cartridge/page-18?do=findComment&comment=3235105

 

Already mentioned in my original post....Version 2 - green w/ black border. No need for the update if I'm correct - still trying to figure our how to use BOOT, so could be wrong.

 

(and I'm assuming you mean FCN-7?)

 

 

Link to comment
Share on other sites

Did you update the cart?

 

What color screen do you get with Fctn-6?

 

See here for a possible fix:

http://atariage.com/forums/topic/229718-extended-basic-v27-suite-cartridge/page-18?do=findComment&comment=3235105

 

I have followed this fix but it still does not work for me. The cartridge looks ok at the menu, but press F6 tells me it's compromised.

 

I think we need to wait for Gazoo to chime in on this one.

Link to comment
Share on other sites

 

I have followed this fix but it still does not work for me. The cartridge looks ok at the menu, but press F6 tells me it's compromised.

 

I think we need to wait for Gazoo to chime in on this one.

As long as he doesn't try to use the CALL CHIME command. It doesn't work.

 

(Sorry, I couldn't resist)

Link to comment
Share on other sites

PeBo!!!!

Welcome back!

I was starting to get a little worried about you mate.

Ralph

 

Thanks Bro!

 

I'm going to be off work for a couple months again soon ("we have the technology, we can rebuild him" - or so the doctors keep telling me), so I'll try to participate more in the coming months.

 

Obviously I just couldn't live without you guys!

Link to comment
Share on other sites

I too am using the black border, green screen version dated April, 26 2015 with an F18A. Curious.

 

BTW - Welcome back PeBo, yes, it's been too long!

 

Hmmm, mine comes up black border/green screen but is dated September 9, 2014...maybe I SHOULD update it???

 

I'm confused, but I DO confuse easily.

 

btw the link you sent me to the color BBS sweetness was jaw-droppingly awesome!

 

p

Link to comment
Share on other sites

Yup, I'm experiencing the same thing. I've just decided to 'live with it', because after repeated attempts to fix it, I'm obviously not up to the task. (sigh) I play very little in XB anyway and I'm VERY pleased with the latest "BOOT upgrade" and the other aspect of the cartridge that I use.

 

If I recall there was an upgrade that was supposed to address some of the quirks, like the DSC2HEX issue, but I never got that to work either.

 

I too am using the black border, green screen version dated April, 26 2015 with an F18A. Curious.

 

BTW - Welcome back PeBo, yes, it's been too long!

 

 

 

I have followed this fix but it still does not work for me. The cartridge looks ok at the menu, but press F6 tells me it's compromised.

 

I think we need to wait for Gazoo to chime in on this one.

 

I never updated anything to address any of the 'quirks' like people having problems with Decimal To Hex or calls (other than CALL DM2 which apparently never worked until recently reported by Arcadeshopper) because, frankly and bluntly, there's something wrong with your system or you didn't successfully complete the upgrade. All I added was the verification routine to make sure the cartridge data was correct by pressing F6. The version that this was added is the most recent one of May 13th. This should be the one you use if you're interested in checking the validity of your cart. Decimal To Hex and all the calls other than CALL DM2 have always worked in every version.

 

All I can offer is that some people went into the advanced options after upgrading their cart and set the 4 options as previously mentioned. Most people that upgraded their cart correctly didn't do this, as there's no need to and imho it's a bad idea. The best way to be successful is to press fctn-quit after the upgrade process is complete, turn off the console for a few seconds, turn it back on and press F6 to verify the cart. I've tried it for what seems like 100 times with 2 different carts and it works correctly every time.

 

Omega, you are the one person who's cart will not verify correctly on the ROM side as you have a beta ROM chip. It's ok as is as long as you don't mind the ROM side not verifying, but you should get a good report on the Grom side. If you want an updated ROM chip I can send you one, I've got a few left.

 

Gazoo

Link to comment
Share on other sites

i have done the upgrade on both an F18A equiped system and stock system with the same results.

 

I have done both carts without changing the switch settings via gromcfg as well and still the same results.

 

I did reprogram it on the stock 99/4a and changed the switches as noted as a fix and got it to verify.

 

I turned off the system for a few minutes and just for giggles verified again. and it with the Compromised message again.

 

The 0513 file you sent me will not even load.

Edited by Cschneider
Link to comment
Share on other sites

i have done the upgrade on both an F18A equiped system and stock system with the same results.

 

I have done both carts without changing the switch settings via gromcfg as well and still the same results.

 

I did reprogram it on the stock 99/4a and changed the switches as noted as a fix and got it to verify.

 

I turned off the system for a few minutes and just for giggles verified again. and it with the Compromised message again.

 

The 0513 file you sent me will not even load.

 

Link for complete package:

http://atariage.com/forums/topic/229718-extended-basic-v27-suite-cartridge/page-19?do=findComment&comment=3239384

 

 

"The 0513 file you sent me will not even load."

The 80 track disk image you requested was intended to be written sector-for-sector to a real disk, not to be used with another transfer method. If you make a valid sector copy of the image to a real floppy, it will work.

 

If the Grom portion of the cart is not verifying then there is probably a problem with data corruption somewhere along the way. It could be in the download process on the PC, transferring the files from the PC to the TI disk, reading of the TI disk, or bad memory on the TI. If you have another TI'er close by, it might be worth the effort to try and do the upgrade on his system.

 

Gazoo

Link to comment
Share on other sites

...there's something wrong with your system or you didn't successfully complete the upgrade. All I added was the verification routine to make sure the cartridge data was correct by pressing F6. The version that this was added is the most recent one of May 13th. This should be the one you use if you're interested in checking the validity of your cart. Decimal To Hex and all the calls other than CALL DM2 have always worked in every version.

 

All I can offer is that some people went into the advanced options after upgrading their cart and set the 4 options as previously mentioned....

 

Gazoo

 

As I explained Gazoo, in my case I haven't upgraded my cart because I didn't think it was necessary. All I did was install an F18A (and I can't even say with certainty that is when I started having problems - only that it is when I first noticed it). I loaded the gromcfg program once when I took a quick look at using boot, but I never edited anything with it (for fear of fiddling above my level of knowledge)

 

So I guess I am simply asking if you would have any idea what could have changed in my system to stop the custom 2.7 CALL commands from working suddenly, when they worked perfectly for months. Would this not be a memory address issue (or am I demonstrating my ignorance?)

 

Also, since my F7 info screen is dated September 9th, 2014, should I updrade to a newer version??? Is there even a possibility that doing so might fix my problem??? I had read that if I had a black border on a green screen that I should not upgrade, so I never did so.

 

If the upgraded Rom chips you mentioned might restore full functionality, then private message me, and I'll get you to send me one. I'm really willing to try anything to fix this, and will happily buy a replacement chip if that's what it takes. I use Extended Basic 2.7 more than anything else on my TI right now, and it's frustrating to be missing these commands now that I've grown accustomed to having them available..

Link to comment
Share on other sites

 

As I explained Gazoo, in my case I haven't upgraded my cart because I didn't think it was necessary. All I did was install an F18A (and I can't even say with certainty that is when I started having problems - only that it is when I first noticed it). I loaded the gromcfg program once when I took a quick look at using boot, but I never edited anything with it (for fear of fiddling above my level of knowledge)

 

So I guess I am simply asking if you would have any idea what could have changed in my system to stop the custom 2.7 CALL commands from working suddenly, when they worked perfectly for months. Would this not be a memory address issue (or am I demonstrating my ignorance?)

 

Also, since my F7 info screen is dated September 9th, 2014, should I updrade to a newer version??? Is there even a possibility that doing so might fix my problem??? I had read that if I had a black border on a green screen that I should not upgrade, so I never did so.

 

If the upgraded Rom chips you mentioned might restore full functionality, then private message me, and I'll get you to send me one. I'm really willing to try anything to fix this, and will happily buy a replacement chip if that's what it takes. I use Extended Basic 2.7 more than anything else on my TI right now, and it's frustrating to be missing these commands now that I've grown accustomed to having them available..

 

The ROM chip that you have does not need upgrading as there is no upgrade for it. The only person with a beta ROM chip is Omega.

You don't have to upgrade if you don't want to, the only fix for the newer version is that the CALL DM2 command was repaired. And while not a fix, the F6 verification program is just a tool to make sure your cart contains the correct data.

 

If the problem started when you installed the F18A, then maybe that is an indication of where the problem lies. You may want to try a stock console, or put the 9918A chip back in the one you modified and see if the problem corrects itself.

 

Gazoo

Link to comment
Share on other sites

 

I loaded the gromcfg program once when I took a quick look at using boot, but I never edited anything with it (for fear of fiddling above my level of knowledge)

 

Tursi explained here that just running GROMCFG will turn on the flash device, so you don't have to edit anything in order to make changes to the cart.

Link to comment
Share on other sites

 

The ROM chip that you have does not need upgrading as there is no upgrade for it. The only person with a beta ROM chip is Omega.

You don't have to upgrade if you don't want to, the only fix for the newer version is that the CALL DM2 command was repaired. And while not a fix, the F6 verification program is just a tool to make sure your cart contains the correct data.

 

If the problem started when you installed the F18A, then maybe that is an indication of where the problem lies. You may want to try a stock console, or put the 9918A chip back in the one you modified and see if the problem corrects itself.

 

Gazoo

 

Perhaps I was negligent in mentioning that while not a fix, there is the addition of the catalog functions using keys 1 through 9 and the option to load BOOT once per session and have it autostart on every reset during that session instead of the XB v2.7 Suite menu. Your version does not have those functions, and you can upgrade to the newer version if you are interested in those functions.

 

It may be a good idea to get your system sorted out before doing any upgrades, though. Your cart is probably good the way it is for now until you get everything else working ok.

 

Gazoo

Link to comment
Share on other sites

 

Perhaps I was negligent in mentioning that while not a fix, there is the addition of the catalog functions using keys 1 through 9 and the option to load BOOT once per session and have it autostart on every reset during that session instead of the XB v2.7 Suite menu. Your version does not have those functions, and you can upgrade to the newer version if you are interested in those functions.

 

It may be a good idea to get your system sorted out before doing any upgrades, though. Your cart is probably good the way it is for now until you get everything else working ok.

 

Gazoo

 

 

And again I offer to update anyone's cart just mail them to me with $5 for us postage back or $10 for europe and I'll reprogram them to latest version free

 

Greg

  • Like 1
Link to comment
Share on other sites

 

 

And again I offer to update anyone's cart just mail them to me with $5 for us postage back or $10 for europe and I'll reprogram them to latest version free

 

Greg

Nice! I might hit you up on that Greg if I ever figure out what BOOT is and decide I cannot live without it :)

Link to comment
Share on other sites

Nice! I might hit you up on that Greg if I ever figure out what BOOT is and decide I cannot live without it :)

 

BOOT is a MENU LOADER program, that was good to begin with, but coupled with the XB2.7S is makes an AWESOME PACKAGE!

 

Here is a quick video demonstration...

https://www.youtube.com/watch?v=lQQR93oQeH0

Now if you liked that, << CLICK HERE >> to download the program.

 

@ Gazoo, I'll take you up on that offer! A PM is on the way! Thanks! :thumbsup:

  • Like 2
Link to comment
Share on other sites

 

Perhaps I was negligent in mentioning that while not a fix, there is the addition of the catalog functions using keys 1 through 9 and the option to load BOOT once per session and have it autostart on every reset during that session instead of the XB v2.7 Suite menu. Your version does not have those functions, and you can upgrade to the newer version if you are interested in those functions.

 

It may be a good idea to get your system sorted out before doing any upgrades, though. Your cart is probably good the way it is for now until you get everything else working ok.

 

Gazoo

I accidentally figured the catalog features out last night, by accidentally pressing a number key instead of the letters at the boot menu. COOL..

Link to comment
Share on other sites

 

BOOT is a MENU LOADER program, that was good to begin with, but coupled with the XB2.7S is makes an AWESOME PACKAGE!

 

Here is a quick video demonstration...

https://www.youtube.com/watch?v=lQQR93oQeH0

Now if you liked that, << CLICK HERE >> to download the program.

 

@ Gazoo, I'll take you up on that offer! A PM is on the way! Thanks! :thumbsup:

BOOT is great to have. I have mine setup almost exactly like Ω does.

Edited by Cschneider
  • Like 1
Link to comment
Share on other sites

 

Tursi explained here that just running GROMCFG will turn on the flash device, so you don't have to edit anything in order to make changes to the cart.

 

haven't read it yet, but I would think that's exactly what happened. Bizzare results though.

 

I feel the clue to fixing this is in the fact that the nanaoPEB's CALL MOUNT is also not working.

 

It works fine with a TI Extended Basic cart, but not the 2.7. So if I can figure out what broke Mount, I, it should help identify what broke the 2.7 CALLs.

 

Didn't even know GROMCFG was going to load when it appeared on screen....thought the autoLOAD on the disk I had mounted would take me to the standard BOOT menu...The old story of rushing in and not reading the instructions first. (I'm embarassed because I KNOW that nobody here would ever do anything like that! « evil grin »)

 

BOOT just looks so damned cool that I wanted to dive in.

 

I'll follow the message board link provided in a bit and see if I can figure this out. At least I'm not the only one with similar symptoms...hate when that happens.

 

Thanks!

Edited by PeBo
Link to comment
Share on other sites

 

haven't read it yet, but I would think that's exactly what happened. Bizzare results though.

 

I feel the clue to fixing this is in the fact that the nanaoPEB's CALL MOUNT is also not working.

 

It works fine with a TI Extended Basic cart, but not the 2.7. So if I can figure out what broke Mount, I, it should help identify what broke the 2.7 CALLs.

 

Didn't even know GROMCFG was going to load when it appeared on screen....thought the autoLOAD on the disk I had mounted would take me to the standard BOOT menu...The old story of rushing in and not reading the instructions first. (I'm embarassed because I KNOW that nobody here would ever do anything like that! « evil grin »)

 

BOOT just looks so damned cool that I wanted to dive in.

 

I'll follow the message board link provided in a bit and see if I can figure this out. At least I'm not the only one with similar symptoms...hate when that happens.

 

Thanks!

 

You shouldn't ever load GROMCFG again after upgrading the cart, that may be the source of your problems. When GROMCFG is loaded, it changes the advanced options. The update process sets the advanced options the way they need to be for the XB v2.7 Suite cart to work properly. I have a hunch that people were reloading GROMCFG after they upgraded their carts, then complaining that the cart didn't work. But I'm here sitting in my chair, and I can't see what others are doing sitting in their chairs, so I can only guess. :)

 

Gazoo

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...