Jump to content
IGNORED

jaguar tv problem


wesofthedead
 Share

Recommended Posts

so i just bought a jaguar and it didnt come with the wires, but i read you can use the nes rf switch and an ac adapter that outputs 9v dc which i do have. so i turn the jaguar on and go to channel 3 and i tried 4, but it just has a black static screen. the system powers on so its not that issue. i also can tell its giving the tv a signal because the screen changes when the power goes on. does anybody know what the problem might be? im thinking maybe its the rf port on the console because i tried the wires on my nes and they sure do work

Link to comment
Share on other sites

It's worth buying an AV cable for the Jag for better picture quality. If that doesn't work then you have a motherboard problem. I've never tried the NES RF on my jag personally but as far as I know it would work.. The jag is also a bit finicky with the cart slot. Try cleaning it and the cart with the distilled water/rubbing alcohol solution applied to an NES cleaning board and then clean any carts you have as well.

Link to comment
Share on other sites

Even if the cartridge or cartridge connector has bad contacts, if the console powers on you should see the red Jaguar logo and hear the "roar" sound.

 

If you only get a black screen (without static) and no sound, the RF modulator may be defective, but it is more likely than something else is wrong and prevents the console from booting. If you want to be absolutely sure, you can tap the composite video and sound from the inside (see below) -- it's cheaper than buying an AV cable just for testing.

Link to comment
Share on other sites

Even if the cartridge or cartridge connector has bad contacts, if the console powers on you should see the red Jaguar logo and hear the "roar" sound.

 

If you only get a black screen (without static) and no sound, the RF modulator may be defective, but it is more likely than something else is wrong and prevents the console from booting. If you want to be absolutely sure, you can tap the composite video and sound from the inside (see below) -- it's cheaper than buying an AV cable just for testing.

the console boots up, the light turns on, and i dont get a blank black screen. when i hit power it takes a second and then the screen changes to a black snowy screen

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...