Jump to content

my diy multicart works with some eeproms but not another?


Recommended Posts

Hi everyone,


I wired up a little 2k/4k multicart that uses a 74LS04 for a CE hex inverter.


It works with the AMD 29F010A-90PC and with some minor wiring changes, the smaller Atmel 28C64-15PC

However, it will NOT work with the Atmel 29C010A-12PC and I've tried several.
Sometimes I get a glimpse of the game screen before it blanks out.

An older post http://atariage.com/forums/topic/21851-2732-eeprom-and-problem-with-6-switch-atari/?do=findComment&comment=240804

describes a similar problem (though I have a 4 switcher) and he solved it by using a 7406 inverter.

Before I take a chance on that inverter does anyone know what might be causing this problem?

I'm trying to understand why it would effect the 120ns chip but not the 90 or 150?
I really would like to use these chips since I have a few lying around.

Many thanks.

Link to comment
Share on other sites

  • 2 weeks later...

I fixed my problem. Sounds strange but by disconnecting the ground wire from the ground pin of the eeprom all glitches & flickering disappeared. It had nothing to do with the inverter or speed of the chips. All my Atmel and AMD eeproms work perfectly without a ground wire attached. I even tried this on my handmade 8k multicart based on the pixelspast schematic. That also works better now. Maybe someone has an explanation but I'm glad to have it working.

Link to comment
Share on other sites



Are you using a decoupling (0.1uF) capacitor across the +5V/GND of the EEPROMs? I had similar issues when developing a multicart for the atari 8-bit.

On a breadboard, I also found that I sometimes also needed an additional 10uF capacitor too.




Yes, I had the 0.1uf cap connected to the 5v & GND pins. Honestly, I tried it both with and without the cap & never noticed a difference.

It was only after removing the wire from eeprom GND pin to the GND on the cart that my problem was fixed.


I still have the decoupling cap but it's connected to 5V on the eeprom with the other leg directly to ground on the cart. Nothing connected to GND on the eeprom.

Link to comment
Share on other sites



First one is the bank switching cart based on the PixelsPast schematic. EEPROM on top, GAL20V8B underneath.

Got a bit messy tearing it down looking for the original problem. A jungle of wires but amazingly it all fits inside the case.


I added extra DIP switches so I could turn on/off the address lines depending on whether there's a F8/F6/F4 GAL in the socket

or just running a chip with 2k/4k games. Game selection just uses one DIP. They hold 128k so its (32) 4k games or (16) 8k games, etc.


The second board is the first I made. It's a 2k/4k with inverter for chip enable plus an LED just for fun.






Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...