Jump to content
IGNORED

Yellow in Deskmate II (solved)


buttertweet
 Share

Recommended Posts

Are you up late at night, red- and teary-eyed, because you saw the Tandy 1000 commercial, showing the beautiful sunny yellow background in Deskmate? And all you can get on your DOS-emulating machine is a sorry diarrhea brown? You're not alone, friend. I have spent many hours perplexed over the same issue, desperate to strike gold on my screen and make Bill Bixby proud. I am happy to say that there IS a solution, and all it takes is a small third-party utility program, and a little tinkering.


I don't know why the yellow background is not available by default in Deskmate II. You can definitely have yellow text. It may be as simple as today's monitors not showing the same thing that the old RGB-whatever monitors did back in the day. Or perhaps RS really wanted you to buy their 1000 with the original Deskmate installed. Whatever the reason, it sure sends us non-Tandy users on a wild goose chase. Well, that has to stop, and it's going to stop now.


First things first. Make sure you are on Deskmate II. The original Deskmate I will not run on your modern machine. Even though 80 Micro mentions a fix to properly map the function keys, the save function still seems to be tied to the original Tandy 1000 ROM, meaning crash city when you try to save a file. You could also try a later version of Deskmate, which allows you to set a wide variety of color shades (including yellow), but what fun is that?


Next, get the color-changing utility mentioned in this excellent thread: http://www.vogons.org/viewtopic.php?t=27687

Basically, what this will do is tell your computer to re-map the screen colors to your liking. In this case, you will replace that awful puke color with "high intensity yellow" which is what you want. From the command line, the magic formula is:

CHGCOLOR 6:62

and voila, your Deskmate will now be yellow-enabled. (To open up even more possibilities, you can look up the full spectrum of color codes on Wikipedia's EGA article. If you want all of your colors to be shades of red and pink, you can do that. I won't.)


We're not quite out of the woods yet, for those of you using Dosbox. Two of the color-swapping keys in Deskmate (Ctrl-F1 and Ctrl-F4) just so happen to be linked to emulator commands, so if you press these keys you will not enjoy yourself. To get around this, go ahead and hit Ctrl-F1 while running Dosbox. A screen with an amazing facsimile of your keyboard will appear. What we'll do now is change the default keys to something else. Right now Ctrl-F1 is linked to the Mapper, so click on Mapper and change it to something else. I like to just click on "mod2" at the bottom, which will add Alt to the hotkey sequence, so that it is now Ctrl-Alt-F1. Then click Save. Do the same for Swap Image and remember to hit Save.


There's still one more catch. CHGCOLOR only works for EGA resolutions and above. Sadly this means no dice if you set the resolution to Tandy. VGA looks beautiful, but it appears that the Deskmate programmers at the time had little to no knowledge of such a technologically advanced resolution. As such, if you run Deskmate with VGA or higher, the cursor will completely disappear. Doable, but not much fun when you are trying to edit something in TEXT and not in the mood to play guessing games. I tried everything and settled on plain ol' EGA.


For convenience, I created a new .conf file with "machine" set to EGA, as well as a Deskmate-specific shortcut for Dosbox, adding -conf and the location of the new .conf file to the command line. I also added the CHGCOLOR line and "desk" command to the autoexec at the bottom of the conf. Now comes the biggest puzzle of all: what screen size ("fullresolution") to set. This gave me fits. My guess is that it is highly dependent on your monitor and/or video card. If you set the size to something your system doesn't recognize, you will end up with a teeny-tiny Deskmate that does you no good. Other sizes may get the size right but the fonts will look horrible.


One big clue is that EGA is inherently a widescreen resolution, so you will do well to set fullresolution accordingly. After 408 or so experiments, I found that 1280x720 works best on my machine (it basically fills my entire widescreen monitor). I also like 640x400, which shrinks the Deskmate display and aligns it near the top. It still looks great and has a certain charm to it. One note: my current video card settings preserve the aspect ratio. You may get better results if you disable this; I have not charted this territory.


As for the yellow? Hit Ctrl-F3 in Deskmate until the golden goodness appears, and there you have it. Deskmate as Mr. Bixby intended it. Now that you have a big smile on your face, get some sleep. You'll have plenty of time to play with your yellow-fied Deskmate tomorrow.


gallery_40980_1463_10877.jpg

Edited by buttertweet
  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...