Jump to content
IGNORED

Emulation Issue


Recommended Posts

Aight so please excuse the ignorant question, but I've been trying to get a game I played as a kid on my PC. I have Windows7 (possibly 10 soon) and have tried STEEM (including the SSE version), Hatari, and one other emulator (name escapes me). When I run Mousetrap, it runs through the preview sequence of a few seconds of each level, but I can never seem to assume control of the game to start playing.

 

I can play at least another game (Lotus racing) on STEEM, but can't get Mousetrap to respond to any key commands (despite messing with the joystick setup multiple times). I KNOW this worked at some point because I emulated the game on an old Pentium circa 2005 - I can't figure out why I can't get this to work now.

 

Anyone have any ideas? Is it the ROM, is there some config setting I'm screwing up...what's the deal?

 

Any help would be VERY much appreciated.

Link to comment
Share on other sites

Is it just mousetrap that can't see your joystick commands, or any joystick game (perhaps you were using the keyboard commands on Lotus)? Mouse Trap works fine for me in Steem SSE.

 

With Steem, the keyboard-joystick isn't enabled by default- I think the default is to press 'Scroll Lock' to switch it on. This is because you won't be able to use the keys that are assigned to the joystick (cursor keys by default) when it is enabled.

 

You can also just play on keys: start the game with 'Space', then 'Z', 'X', and 'Shift'.

 

I seem to remember that the sprite images in the AUTO folder can be edited in Degas (we took the opportunity to make a copy of the game 'hilariously' obscene). Keep lots of backups while doing this though because at some point we made a change that just messed everything up and that copy wouldn't run.

 

Good luck!

Edited by galax
Link to comment
Share on other sites

That's a good suggestion, I forgot to mention I tried a few TOS versions and it seemed to work fine, even 2.06 on an STE.

 

Another possibility is that your emulated joystick is using 'space' for 'fire', and I can't see a way of starting a game without pressing 'space' - you might need to either reassign the joystick fire button, switch off joystick emulation temporarily, or play on keys.

Edited by galax
Link to comment
Share on other sites

Wow - this was extremely helpful. I had fiddled with every joystick setting, but apparently never tried the spacebar to kick the game off. Somehow when trying every key on the keyboard, I must have missed spacebar....thank you all so much!!! (I told you this was an ignorant question!).

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...