Jump to content
IGNORED

Figuring out which ROM I've got in the TI drive controller...


aftyde
 Share

Recommended Posts

Hi All,

 

Have a TI controller with the 80 track mod in it and 2 Lotharek drives. Trying to sort out which images to run / get predictable working diskette images built would be so much easier if I knew which sets of roms were in the controller. I think I have 80 track DSSD on 1 and 2. I can read and write to diskette images but not format them...

 

Any ideas??? Is it possible to dump the roms without a programmer and compare?

 

Cheers, Arthur...

 

---

 

 

This is a modification for the TI Disk Controller card which enables
the use of 80 track drives for a total of 1440 sectors per 80 track
drive. There are several configurations available. Please distribute
this archive freely.
Tony Knerr 07-15-01
The files in this archive are as follows:
readme.txt This file.
80trackti.doc Instructions for installing 80 track eproms on the
TI disk controller card.
80t1r1.bin Replacement for U26, 80 track drives on 2&3, 40 track
on drive 1.
80t1r2.bin Replacement for U27, partner to 80t1r1.bin.
80t3r1.bin Replacement for U26, 80 track drives on 1&2, 40 track
on drive 3.
80t3r2.bin Replacement for U27, partner to 80t3r1.bin.
40tk1.bin Original TI rom U26.
40tk2.bin Original TI rom U27.
*end*
Edited by aftyde
Link to comment
Share on other sites

hmm, without an eprommer, I would use one 80-track-drive with a 80T/DSSD-disk

(maybe a HxC with 80T/DSSD-HFE-mounted, does not matter)

and jumper this drive beginning from 1 up to 3, with trying to format an 80track-DSSD-disk in each step.

 

The DSKs configured with only 40tracks will bring up an error, the one configured with 80 track will pass this normally.

 

But this is trial-and-error only, of course :)

Link to comment
Share on other sites

I'm using a Gotek. With firmware from the same guy as the Lotharek drives. Formatting has never worked for me. So I use TiImageTool java app on PC to create a blank sector image, then I convert that to hfe with the hxc desktop software. Once there, TI software can read and write just fine, and rename the disk too.

 

There was a thread on the hxc2001 forums about formatting on TI that never seemed to be resolved. Does anyone if formatting on the Lotharek drives works on TI now?

 

Somewhere we must have a DSR rom image dumper? If aftyde had that, the image could be diffed against each of the available mod images.

 

I'm assuming you already opened up the controller board and looks at the labels on the eproms? I'm pretty sure mine came labelled. ( I didn't burn them myself )

  • Like 1
Link to comment
Share on other sites

hmm, so you have an 80track-modded DDCC-1 and come to 2880 sectors and 720 KB ?

(have this too :)

 

Can (or did you?) try to use (read, write and then at last format) this HFE here with the DS/SD-80T-Controller:

(But only if HFE like this was not part of your test up to here)

 

001_360K_80T_DSSD_E.dsk

Link to comment
Share on other sites

Hmm,

 

if we can believe on this errorlist here below, it means "Lost data on print" (=write?)

 

Maybe you try this DiskMan here as it is a bit newer ?

(From a 2nd floppy in HxC, if you have configured it this way)

 

 

 

DM1000v61.dsk

 

 

 

ErrorCodes (from DM2.0 I think):

 

post-41141-0-97785100-1447494783_thumb.jpg

Link to comment
Share on other sites

I'll give it a shot - I have two disk controllers and have the same issue, and have a real SSSD drive - all the same. Have swapped the console - only thing left is the firehose. I'll give it a try!

 

 

hmm,

1. so there are 2 x 80track-modded TI-controllers with that problem ?

2. and the MyArc-80T is NOT involved in the problem ?

3. So, the very only problem here is that formatting does not work ?

 

 

As I never have formatted .HFEs - better: the DSKs "inside" - on the TI,

I should try that here for a first time....maybe this does not work in general with HxC, as Jedimatt described....

And yes, I remember this thread on the HxC-forum, but I thought it was "solved" with a new firmware froom Lotharek...

I´ll revise that too, next days.

Link to comment
Share on other sites

I have formatted disks on the Myarc controller - no problem. Yes, I have two modd'd TI controllers. One with the Guion mod, the other with th 80 track mod. Both will not format the Lotharek, or even a SSSD floppy in a physical TI floppy drive. (DSK1 and DSK2 are both Lotharek emulators, DSK3 is a genuine external TI SSSD Shugart drive.)

 

When I had back to Manila in Dec - I am going to bring some of the .HFE files to see if I can format them with the Myarc.

Edited by aftyde
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...