Jump to content

VecMulti, DEV mode? Windows 98?


Recommended Posts

Got an old computer in the laboratory, was able to run the ROM_patcher.exe utility after some dll downloads, the VecMulti.exe that is used to transfer files from PC directly to cart.

I hooked up a known good USB to serial adapter (works with the C64) according to the ReadMe.txt placed on VecMulti microSD-card root.

Problem is that VecMulti.exe doesn't show any ports at all in the small box on the left, if I enter "3" or "COM3" VecMulti.ini after "ComPort=" it doesn't help and it's blank again after quitting VecMulti.exe.
As it's a rather fresh installation I'm perhaps missing some file?

It should look something like this, left white box is empty and no choices to select.

I will try it with a WinXP laptop later, just thought I'd ask if anyone has had it running from Windows 98 (SE), I sent Richard an e-mail but he probably has a real life to attend to and doesn't sit around waiting for e-mails to answer. ;-)

The VecFlash had software for Amiga... so why not Windows 98 for the VecMulti?
I tried Hyperterminal as well, guessing various settings but got nothing.

Edited by e5frog
Link to comment
Share on other sites

im not sure about windows 98, perhaps you might have trouble with that (but im not an expert)


hopefully Richard can offer advice, i expect he would reply to you soon


i believe these cables below are suitable (but again, perhaps only windows xp or newer)




you would only use the GND, TXD and RXD pins, you would not use the VCC (5v) pin (because the vecmulti is already powered by the vectrex console)

Edited by vtek
Link to comment
Share on other sites

Yes there's only three pins connected on the VecMulti, G, T, R (and one N/C), TX goes to RX and vice versa - the problem is either the software won't run with Win98SE or I'm missing some Windows-releated file/s.

I'll try on XP and make sure it works there.

Link to comment
Share on other sites

I'm an electronics engineer, it's familiar territory, mostly wanted to know if anyone had used the dev functionality and if so, under win98?

I have a cable like this one with a semi transparent shell where the electronics are located, mine runs on 5V though not 3V3 as in this advert:

When I tried Hyperterminal with it hooked up I got LED flashes when sending but no reaction back, I even swapped TX RX to see if anyone had made a mistake, no change.

Link to comment
Share on other sites

Got it going from the Windows XP machine, the COM-port was found, listed and selected automatically after the FT232R-chip cable was installed (it found the drivers automatically online) and then starting "VecMulti.exe", the normal COM-ports were not selectable. So perhaps the FTDI-driver for Win98 is so old that the VecMulti-chip doesn't recognize it?

The ReadMe.txt actually said how to connect the development cable, it doesn't list the pinout of the VecMulti, which is a bit odd as it lists pin 4 as not/connected - so if following instructions it works (on the second attempt).

So, the troublesome Vectrex has no problems running anything that is loaded via serial cable, when going through the menu trying to start anything on the microSD it just goes black, voltage levels seem fine so I guess there must be some interference - works fine on my machine (version 3 Vectrex).
At least I got the Test cartridge running and could make some image adjustments, as suspected the image was much to narrow.

Still wonder if it could be made to run under Windows 98, perhaps with some other cable (not FTDI based).

Link to comment
Share on other sites

I am not familiar with Windows 98 but for your USB to serial adapter what do you see when you look in [Control Panel][system][Hardware][Device Manager] and then look under "Ports (COM & LPT)? If the USB to serial adapter is working, you should see it assigned with a COM number. There you can also check the Port Settings properties.

Link to comment
Share on other sites

I could assign a COM-port number myself, I chose COM3 as it was the lowest available.

It seems the software doesn't recognize it in the same way it does on Windows XP, perhaps it's a simple driver issue, I fetched the only one that seemed to fit:
The 1.09.06.

Looking here however:
Perhaps the 1.09.05 is a better choice.

The FT232R is however listed with that driver here:

Edited by e5frog
Link to comment
Share on other sites

I took a pair of photos of my USB to COM-port adapter, I assume it's some cheap copy and not a genuine FTDI chip - which may or may not be part of the problem.
As I mentioned, it works fine from Windows XP, it would be interesting to know if someone had got the dev mode going from Windows 98. I may have another cable to try out, I used something similar for NES and PowerPak where you can do the same thing, that cable is hardwired to a NES connector though.

As can be seen below it's marked with FT232RL

IMG_20160125_202500.jpg IMG_20160125_202747.jpg
Edited by e5frog
Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...