Jump to content
IGNORED

Drive!


Lumi
 Share

Recommended Posts

 

 

Thank you! :)

 

Hmm... you might need to manually switch to paddle mode. Try pressing tab while the game is running > Game Properties > Controller. Then set P0 Controller to Paddles in Left Port. Then you'll have to close the ROM and reopen it for the changes to take effect.

 

(Also, if you want to be able to save your high scores, set P1 Controller to AtariVox in Right Port.)

 

That did the trick...........Thanks!

 

Will this title be published?

Link to comment
Share on other sites

That did the trick...........Thanks!

 

Will this title be published?

No problem! That tripped me up quite a bit while developing this.

 

And if this got published, I would be ecstatic. I'm just not sure what the process is. Should I send it to Albert for approval?

  • Like 2
Link to comment
Share on other sites

Thanks guys, I've messaged Albert and he's going to test it soon!

 

Also, what do you think about this instruction sheet? Is it too wordy? Are these dimensions correct? (Ideally it would be folded in half vertically.)

 

post-44583-0-57863000-1463271475_thumb.jpg

  • Like 2
Link to comment
Share on other sites

Awesome job !
A game of reflexes and concentration as I have not seen in a long time... and in only 4Kbytes !!!
It reminds to me Asterix and Gremlins... if only in both could be implemented the use of the paddle instead of the CX-40... ;) )
Bravo !
My 1st game (NTSC version) :
post-10922-0-58653200-1463424312_thumb.jpg

My 2nd game (PAL version) :
post-10922-0-97117700-1463424313_thumb.jpg
[ both done on Stella emulator, with mouse used as the paddle controller... still have to grab an Harmony (Encore) for my H,L & Jrs... ]
I promise I'll try to do some artworks for an eventual (and likely !) label contest... :thumbsup:
  • Like 1
Link to comment
Share on other sites

  • 2 weeks later...

Thanks a ton, guys! Your feedback has been really encouraging! :) I have a ton of news now.

 

I have another update based on my conversations with Albert, v1.5.2. Here's what's new:

  • The environment now changes color depending on the speed
  • High score screen now says "Game Over"
  • Fixed a bug with Speed Freak mode that only happened on real consoles, not in Stella
  • PAL version now plays sound effects at the correct speed, making it essentially identical to the NTSC version in all aspects
  • Playing on the lowest speed only lasts half the time it did, to make retries less painful

The new versions are attached to this post, and also to the first post.

 

What I could really use now is some help with testing! Especially looking for differences in how the game plays on actual hardware compared to Stella. If anyone is willing to try it both emulated and on an actual console and compare the two, that would be very helpful!

 

Additionally, I have part of the manual complete! Take a look:

post-44583-0-45283100-1464647194_thumb.jpg post-44583-0-85533300-1464647215_thumb.jpg

 

Finally, I am running a label design contest! The winner will receive a free copy of the game, their artwork featured on the label and manual, and their name in the credits! For more information, click here: http://atariage.com/forums/topic/253231-drive-label-contest/

 

Thanks for the support and help, everyone! :)

 

Drive! v1.5.2 NTSC.bin

Drive! v1.5.2 PAL.bin

Edited by Lumi
  • Like 2
Link to comment
Share on other sites

Played on actual hardware, via Harmony.

 

Like the changing background colors, although the third stage (kinda reddish) was a bit washed but that might be my TV or maybe my console. I'd be interested to hear from others.

 

Can confirm that the save functionality via AtariVox works and I like the addition of "Game Over" on the High Score screen. "Game Over" and "Try Again! give it a more polished look.

 

Couldn't play too much, due to work, but will play around with the colors later.

 

Thanks for making this game and for sharing with the community. :thumbsup:

 

 

post-21941-0-41819700-1464737026_thumb.jpg post-21941-0-29887100-1464737038_thumb.jpg

Link to comment
Share on other sites

Thanks, sramirez2008! :)

 

However, I'm a little concerned by your description of the third stage as "reddish", because that stage is supposed to be purple. That could be happening if you're playing the NTSC ROM on a PAL console. If not, are you sure the color settings on your TV are correct?

 

Is the third stage red for anyone else? The stages on normal mode should go: yellow/brown -> blue -> purple -> green.

Edited by Lumi
Link to comment
Share on other sites

Is the third stage red for anyone else? The stages on normal mode should go: yellow/brown -> blue -> purple -> green.

 

Yup...corrected the colors and am now seeing them as described above. Also reached a new HS.

 

post-21941-0-81242300-1464992059_thumb.jpg

Link to comment
Share on other sites

Left difficulty A, but right difficulty set to B. Was having a hard time reaching 50K with the right set to A.

 

Great game. The game ends and I immediately want to play "one more time" and for me, that's the sign of a great game. :)

Link to comment
Share on other sites

  • 3 weeks later...

Thank you all for the amazing support over the past few months!

 

The label contest is now over, and the winner is Corey Kramer, who you probably know for making the label art for Wall Jump Ninja! Well done, Corey! :-D

 

Thanks to him, the label art and manual are now complete! Check it out!

 

Labels

Front label:

post-44583-0-06392500-1466483902_thumb.jpg

End label:

post-44583-0-48787400-1466483954_thumb.jpg

 

Instructions

Front cover:

post-44583-0-25124400-1466484187_thumb.jpg

Inside:

post-44583-0-36710300-1466484250_thumb.jpg

Back cover:

post-44583-0-61045900-1466484270_thumb.jpg

  • Like 5
Link to comment
Share on other sites

  • 2 weeks later...

Hmm... I have the right difficulty at A an I got past the first "stage" the second time and these non-moving blue blocks have been going for at least a full minute now... Is this supposed to happen? Like I'm literally just staying at the middle and not moving.

 

tumblr_o9ofhdxIB21sxn2jfo1_1280.png

Link to comment
Share on other sites

Thank you so much, everybody! I appreciate the kind words! :-D

 

Hmm... I have the right difficulty at A an I got past the first "stage" the second time and these non-moving blue blocks have been going for at least a full minute now... Is this supposed to happen? Like I'm literally just staying at the middle and not moving.

Oh no, really? I thought I fixed this bug a long time ago. Basically it's a problem with the RNG looping in sync with the blocks being displayed. I thought I had fixed this, I haven't experienced it in a long time...

 

Let me tinker with the code a bit more. I'm guessing there's some way to fix this once and for all.

 

 

EDIT:

This update should fix the issue once and for all. I decided to incorporate adding random ROM data into the RNG function, so there's no way the RNG could loop like that now.

 

Drive! v1.5.3 NTSC.bin

Drive! v1.5.3 PAL.bin

Edited by Lumi
  • Like 4
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...