Jump to content
IGNORED

Color Computer 2 suddenly stopped work.


ceratophyllum
 Share

Recommended Posts

-ing. (I can't edit a title once it is posted? That makes it hard to mark a post as SOLVED. Oh well.)

 

Anyway....

I was playing MegaBug yesterday evening and the computer froze. Everything just stopped moving on the screen. So I turned it off, removed cartridge and cables (drivewire + joystick) and when I turned it back on BASIC would not appear.

 

The first time I turned it on there was a solid yellow screen.

I turned it on and off a few times and I mostly get this pattern of vertical bars that shifts very slightly if I press keys.

 

Does anyone know what has failed? Looking in the top vent, it looks like most of the big chips are in sockets.

 

Is there any point in even troubleshooting this, since I doubt I will be able to get replacements? I don't find CPU, SAM, PIA, etc. part numbers MCXXXX outside of retro computer sites when I search.....

 

 

Here's what it looks like:

post-28728-0-71106300-1459859275_thumb.jpg

post-28728-0-02863400-1459859323_thumb.jpg

Edited by ceratophyllum
Link to comment
Share on other sites

Ooof...video seems stable so the 6847 is probably OK...maybe...

 

If any of the chips are socketed, reseating them would be a good step to try. Beyond that, the 6809E might be worth swapping out as a test, and all of the memory is worth swapping out as well if you have the parts available.

 

I suppose the PIA that controls the video mode could be acting-up as well. Do you see any change in the graphics if you type on the keyboard?

Link to comment
Share on other sites

The previous owner definitely did some work: two of the screws were missing when I took it apart.

 

It looks MC6847 is not seated properly because one of the pins is sticking out. It looks like it is just barely making contact with the socket. It is near the top resistor in the picture. Ugh. It is hard to reach that chip with the RF modulator so close, the keyboard connector (it seems to have become one with the ribbon--I dare not pull too hard), and the DIN ports surrounding it.

 

Very little change typing.

 

Entering SOUND 60,20

 

does not make sound.

post-28728-0-65820600-1459868605_thumb.png

Edited by ceratophyllum
Link to comment
Share on other sites

I can recall seeing such a screen on a Coco that was restarted immediately after a power-down. Happily, a hard reset cleared things up; there was no permanent damage.

 

I concur with Linville that the 6847 video chip is very probably OK. The striped pattern on the screen looks very much like a RAM dump. The system is not initializing properly, so it never starts the executing ECB ROM.

 

Do you have any way to check your power supply? That may be the original cause of the problem.

Link to comment
Share on other sites

If the patter changes slightly between resets or power on/off cycles, then the RAM is *probably* ok.
The 6847 uses SAM to read RAM so that might be ok as well.
That means it's probably a PIA. Those have been what I've had to replace in every dead CoCo I've had to fix.

Link to comment
Share on other sites

Yea it looks like the machine was putzed around with by the previous owner. I can't see that pin popping out like that on it's own. I have a coco 1 where there was some work done on it, perhaps a ram upgrade to 64k, and it's a rats nest of wires running everywhere and the thing is you never know what the expertise level is of the person doing it. I'm kinda surprised, if that pin was out all this time, that it worked up to this point before failure.

Edited by AtariLeaf
Link to comment
Share on other sites

I'm kinda surprised, if that pin was out all this time, that it worked up to this point before failure.

 

Me too. It was just barely touching: the pin was bent like this ">." I mean the bottom part was going back into the socket.

 

I've got the service manual and I'm going to check the power supply when I have some time at home tomorrow.

 

The computer stopped working the first time I tested it with stuff attached: a "flash pak" cart (containing HDB-DOS) in the side and a Drivewire cable connected. Maybe the power supply was really weak and about to fail; straw that broke camel's back.

 

There's a troubleshooting flowchart, but I'm not sure I want to go much deeper than checking that it's putting out close to 5V. Maybe just try another power supply if it's not. I don't have a good scope, one of those cheap slow scope-meter combos with a bad, impossible-to-see LCDs. Unusable without a headlamp.

 

Is there anything funky about the original or would any old regulated 5V DC power supply like the one from a Play Station Portable (good for 2 amps) do it?

Link to comment
Share on other sites

Do you have any way to check your power supply? That may be the original cause of the problem.

 

I get 5.08 V at the side of R2 closest to SALT (IC1).

Tried to look for AC ripple with my crap scope. If it's there, it's not much...shows a pretty flat 5.08V.

 

At pin 15 of SALT, I get -13.05 volts.

 

According to page 57 of the service manual(attached below), these are indications the power supply is OK.

 

 

 

If the PIAs are both socketed, you can try swapping them to see if the behavior changes.

If it does then at least one of them is bad.

 

6822P is socketed, 6821P is soldered to the board. I guess I'll look for another 6822P first....

 

How hot is Q1 supposed to get? I see it has a heat sink on it, but I can feel it through the case even with the coco switched off. I noticed this right after I got the system, while it was still working. Could this be a sign of trouble? The manual says check that the amplitude of the ripple at the cathodes of D3,4 is less than 1V, and check at anodes of D1,2 to see if its less than 0.4V. (Compare to figure 5-1, included below with a snap of my scope screen. I can't get an image AC-coupled, so this is the best I can do. D3,4 looks OK, but the ripple at anodes of D1,2 might be a little big? Damn this scope.)

post-28728-0-91707100-1460051017_thumb.png

post-28728-0-42143400-1460053359_thumb.png

Link to comment
Share on other sites

Haven't given up...Just ordered a few MC6822P PIA from el cheapo dodgy Chinese part supplier. Should arrive in a fortnight if I'm lucky.

 

Possibly PIA-related: Is a coco2 supposed to click the cassette relay when you turn it on?

This never happened for me, even when mine was working.

Link to comment
Share on other sites

  • 2 weeks later...

I replaced the socketed 6821 with a 6822. The coco2 still doesn't work and the junk on the screen looks the same.

 

I also tried another CPU. The screen got a little less fuzzy, but the pattern of vertical bars remained the same.

 

I'm not in a huge hurry to unsolder the other 6822 and I'm still waiting on the socket to come in the mail. It was nice when one could just go to Radio Shack and get parts same day.....

 

The SAM is also in a socket, but I don't know where to get a replacement except from another coco.

 

Then there's the 8 RAM chips soldered to the board.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...