Jump to content
IGNORED

Atari 5200 4-port - some games not working


manopac
 Share

Recommended Posts

Hi all !

 

I have an issue with my recently purchased Atari 5200 4-port (unmodded) with 11 games - about half of the games have issues - either garbled screen, characters showing instead of graphics or incorrect characters appearing on screen - more details below:

 

The following games work flawlessly:

Pole Position, Missile Command, Defender, Soccer, Frogger

 

not working:

Q-Bert, Pac-Man, Berzerk, Centipede

 

the question is - anyone knows what's different in the games in the lower list ? special memory management that points to a faulty chip? I did rule out that the games are faulty - a collector friend brought his copies of the games and the behaviour is exactly the same ....

at least Q-Bert and Berzerk did work immediately after switching on the system - which means that the problem get's worse once the machine is running for a few minutes ...

 

any hints are very appreciated !! Thank you in advance !

Edited by manopac
Link to comment
Share on other sites

ok - but wouldn't there be a consistent behaviour then ? and not getting worse once the system is running for a few minutes ?

 

On a "cold" system, Q-Bert works perfectly fine - once I play it for a while (or use some other carts and then re-insert Q-Bert again) the errors start to appear ...

Link to comment
Share on other sites

I am not sure what you mean - "I now 5200 Pacman which is a 1st party game worked before and after the upgrade." - that's what I would have expected ... or do you mean it did NOT work after the upgrade ?

 

Oop a rapid mistype sorry.

 

The 5200 Pacman game worked before and after the upgrade. I have not heard of ANY 1st party game produced directly from Atari not working on either 2 or 4 port 5200 consoles. The Factory Upgrade fixed the 2600 adapter compatibility on the four ports. I think some of the 3rd party games (Mountain King for example) had issues on 2 port models. Fortunately the upgrade still allowed compatibility of the 3rd party games.

 

http://atariage.com/forums/topic/92263-5200-2-port-incompatible-questions/

 

I doubt the RAM chips would be bad, this would affect ALL the games. Unlikely non moving parts would fail unless a power surge.

 

In your case, the most likely suspect would be the cart connector.

 

1. Unplug your console.

2. Tap the power button a few times to purge the capacitors.

3. Insert a alcohol dampened cardboard a few times, followed by a dry side.

4. Wait until all the alcohol evaporates before plugging back in.

 

Clean the game carts as well.

 

1. Push in the cart dustcover by unlatching the release slots with a scribe.

2. Clean the contacts with QTip and alcohol followed by dry end.

3. Dry fully before inserting.

Link to comment
Share on other sites

I don't think its the cartridge connector (or the carts - I tried different carts of the same game with same results)

 

take Q-Bert as an example: the game works when I first power on the system, and it's fully playable without problems - once the system runs for a while, I insert different cartridges and re-insert Q-Bert, it wouldn't work properly any more

 

my guess would be some kind of capacitor that is acting strange once it's fully loaded ?

Link to comment
Share on other sites

  • 3 months later...

Did you ever find the problem? I have a similar issue with a 2-port system... Came with breakout works fine. Pac-man seems to start and then garbled screen and locks up pretty much...

Same behaviour with other carts.

All tested on another 4-port I have and ALL carts work fine...

Edited by walterg74
Link to comment
Share on other sites

  • 1 month later...

I've had similar problems that were caused by the flip flop IC that is located near the power button. The IC is a CD4013, console5.com sells them. First I had thought that the IC was bad so I bought some, but as I looked at things further I found that the IC wasn't making good contact with the mainboard. It connects to traces on both sides or the mainboard. The ICs on my 5200 are all socketed, I removed and then re-soldered the socket. I think that all of the flexing I did to the board when I was taking it out of the case and putting it back in, (for cleaning and modding), must have cracked the solder around the socket. After re-seating the socket the graphical glitches went away, as well as the problem I was having with the power not turning off. Might be something to check, good luck with it.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...