Jump to content

Recommended Posts

So I picked up a "non-working" CV from eBay ($25, bundled with 2 OEM controllers, power supply, and Illusions). The also-bundled RCA output cable was severed and frayed at the end. Powered on, tested all 4 connections, voltage checked out. No picture with replacement RCA (using a RCA-to-coaxial adapter; love those things). Concluded it was the RF modulator, so I decided to give Ben Heck's composite mod a try (http://www.benheck.com/Games/Coleco/Video_Mod.htm).

It worked!...with two unexpected results (both may be unrelated to the mod, I'm not sure).

1. There is about a five-second delay after the console powers on, after which the ColecoVision title screen has about a three-second fade-in. After fade-in, the picture and colors are as clear and perfect as composite can give me. I'm using a 32" Toshiba CRT; all other consoles using composite output don't have this picture delay. The micro-potentiometer in my mod is turned up all the way. I should also point out that I tested the mod's circuit, and all components--including the video out--were getting the proper voltage (~12V DC).

Is this a normal/typical "side effect" of the Ben Heck mod? Or is there something wrong/off with one of the components?

2. I noticed these stray, square sprites in fixed positions in a few of my games. (See attached pics for reference.) I first noticed a couple of them in the rivets stage of Donkey Kong...


and then I saw a couple on the level start screen of Illusions....


It was then that I inferred they might be appearing in the same places regardless of the game, and that they won't appear on a black/"null" background. And then I put in Zaxxon....


Eureka! There looks to be a vertical row of these sprites, evenly spaced, across the entire height of the screen. Has anyone seen/solved this issue before?

Thank you each for your time and help with this one. Love ya, appreciate ya.

Link to comment
Share on other sites

I'm no expert, and off the top of my head I don't recall any real issues. But I did have something similar happen! For me it was 2 dots or slashes that would appear after the word JOUST on the Joust homebrew title screen. If the dots or slashes appear, the game would often glitch into weird, messed up graphics afterwards. Somehow I figured out it was a Power Supply issue (even though everything seems tight). Yours might be something completely different. What I do is put just a little weight on the power supply cord coming out of the CV, and then the dots/slashes disappear and the game works fine. For mine even just a little bit of weight (like a cartridge or an NES controller, anything really) did the trick. You might try lightly holding in your power supply cord when turning it on and try putting just a little weight on it at various angles and see if anything happens.

Link to comment
Share on other sites

No this is not normal.


Btw the Ben heck mod uses a transistor. A better mod uses the LM318.




Same as most hook the audio direct to the chip, this can pass on dc voltage. A better audio attachment point is RF side of C88.


Your video issue could be a couple of things. Bad vram or dirty cartridge connector. Clean your power switch and cartridge connector.


Part 8 right near the end shows what it might look like on the title screen.



Edited by cdn2a
  • Like 1
Link to comment
Share on other sites

Huge thanks, cdn2a!


I will look into the other mod & techniques as soon as I get the chance.


And thanks for the link to the tech manual; I just know it'll be a handy reference for years to come. As for this issue, however, I don't think I'll be able to make a diagnosis based on part 8, simply because the CV title screen looks perfect on each startup (if the squares are there, they probably all fall on the black/"null" areas of the screen, and thus won't appear; none of them happen to be where "COLECOVISION" appears).

Link to comment
Share on other sites



So I decided to tinker with my CV a bit more today. I moved the audio-out connection from the chip to the C88 capacitor, and I cleaned the cartridge slot connectors as best as I could.


Result: same exact issues as before. At least my audio is better configured for if/when I get an expansion module. Looks like I'll have to get a replacement cartridge slot, maybe?


So then I decided to try and clean the cartridge connectors on the only non-working game I own (Ladybug). This is where things went reeeeeeally wrong (because I'm a doofus). After removing the board from the cartridge case and cleaning everything thoroughly, I decided to leave the board out (in case the problem needed more solving), which is fine!...as long as you don't insert the cartridge in reverse. Eerie, Atari-esque, "not working" sound (you all know the sound). Immediately powered the CV off, said "oops", and then went to a working cartridge. Nothing. I'm preeeeetty sure I shorted something; power supply? cartridge slot? both? other things? I'm not sure.


This is obviously going to be a much more involved project, for another day. In the meantime, if any of you have any tips on what I can do to save my console, that'd be great. Please be gentle; I know I'm a dummy here. Thanks!

Link to comment
Share on other sites

  • 2 years later...

Two years later, an update!


I put my CV on the "I'll do it later" shelf for quite some time, but tonight I tackled it once again. Here are the steps I took:


- I tested the voltages coming from the PSU and from the switch. All the voltages were surprisingly spot-on. Good.

- I removed, cleaned, regreased (dielectric), and resoldered the switch. Voltages remained good.

- I undid the Ben Heck mod completely and installed a composite mod from retrofixes.com instead, carefully following the instructions.

- I plugged in the power supply, connected composite to TV, then tested with a spare copy of Donkey Kong.


No video. No bios screen, no menu screen, no game picture. No static. The screen is just as black as it was before powering on. BUT...I COULD hear the familiar audible hum of a ColecoVision bios and menu. So after 30 seconds or so, I pushed "1". And out of the speakers, crystal clear, came the Donkey Kong starting tune and level music.


I moved the joystick right, but no sound of Mario moving. I pushed each trigger button, but no sound of jumping. Interesting.


I'm calling it a night tonight, but I'm going to test voltage getting to the yellow video RCA port and report results. In the meantime, any ideas? What else should I test? Can someone look at the installation instructions provided by the manufacturer and tell me whether they look correct? http://www.retrofixes.com/2015/06/colecovision-svideo-or-composite.html?m=1


I feel like I'm close...kind of?

Edited by HeadcolorsTV
Link to comment
Share on other sites

Thanks for the confirmation. I wasn't sure, because one picture in the instructions shows the audio coming out of one of the RF board joints, and then a picture further down shows the same audio wire coming out of a different joint. The pictures are all fairly low-quality, but it did appear the video wire was coming out of the same joint in both pictures; I just wanted to make sure everything was legit.

Link to comment
Share on other sites

Okay, following up...


- Tested voltage going from GD in RF board to video RCA: 0.02. Hmm.

- Tested from GD in RF to audio RCA: 8.0-10.0. Okay.

- Tested pins 1(-5v), 8 (+12v), and 9 (+5v) on my 4116 vram chips. Perfectly fine on all eight.

- Tested from GD in RF to 12v IN on the retrofixes PCB. Good.

- Tested to VIDEO IN on retrofixes PCB. Good.

- Tested from GD IN on PCB to VIDEO OUT: 0.02v. Uh-oh.


After testing the other joints, reballing all of them, and retesting, it looks like I'm getting a drop at one of the pins of the IC. I contacted the retrofixes Twitter with my issue, hopefully we can get this figured out.

Link to comment
Share on other sites

A couple of those voltages coming out of the RF box seem a tad high. The 12 v tap on the bottom right is normal but the audio and video points don't seem right. I've never had 12 volts coming out of those signal points. My readings generally run around 8 - 8.5 volts for the audio point and 5 - 5.5 volts on the composite point.

Link to comment
Share on other sites

That makes sense, Ruggers. The audio is indeed in that 8 range, so that's good. The 12 from the RF is I guess "intercepted" by the mod board before it's converted in the RF. Then it's converted to 5v by the IC, I'm guessing. So the voltage I'm aiming for is +5, then. Again, that makes sense; the voltage reading in the resistor that's getting a reading is 5. Thus, the drop is from 5 to almost 0. Problem is, the traces are so tiny, it's difficult to follow them without desoldering nearly the whole thing, so I can't really tell (with my very limited experience) which component/pad/trace is the culprit.

Link to comment
Share on other sites

Okay Ruggers, my mistake. The video tap is giving me roughly +5.5v (serves me right for not writing each reading down as I test it).


I'm attaching the pinout for the LM318 IC chip in the mod PCB. It was quite helpful in getting me to understand the circuit, but once again, more answers lead to more confusion.


I desoldered the PCB from the wires and tested all the leads with an ohmmeter, and everything successfully she from >0 to 0 within a half second. I resoldered the wires to the PCB and tested voltage again; same problem, but this time, I knew where to look for the drop. Here are the voltages I got for each pin:


10.8v | 12v | 0.02v | 0




0 | 0.02v | +5v | (GD)


The positive input (pin 3) is at the right voltage, but outputs very low from pin 6. When it loops through the components and comes back around to the negative input (pin 2), it's at the same 0.02v. From what I can tell, pins 1, 5 and 8the "COMP" pinsaren't connected to anything.


So what to make of this? Is the drop happening inside the IC? What's with the nearly 11 volts at chip 8? Should that be happening?


Edited by HeadcolorsTV
Link to comment
Share on other sites

Ah okay, no worries man. I was just going by your pic and you had 12v listed on each of the taps. However that's good that your voltages are good and you hooked the modboard up properly according to your pictures as well. I'm curious, does RF still work?


Edit: I'm up late working too haha :P


Edit 2: Let me hook back up my diagnostic Coleco and I'll measure the voltages on my LM318 and see if they match yours. Give me a few minutes.

Link to comment
Share on other sites

On my LM318 here are the voltages I'm getting. Hopefully this can help by giving you something to compare to.


Pin 1 = 9.14 v


Pin 2 = 5.69 v


Pin 3 = 5.69 v


Pin 4 = 0


Pin 5 = 9.15 v


Pin 6 = 5.69 v


Pin 7 = 11.49 v


Pin 8 = 1.35 v



I might be wrong but it might be possible that the lm318 was maybe installed backwards? Is there a silkscreen marking on the modboard showing which way the LM318 should be facing? Or that chip might just be bad period. :(


Edit: Okay, I went to retrofixes website and looked at a picture of their amp board. It appears from their pic and yours that everything on the modboard itself is installed right.

Link to comment
Share on other sites

Going back to 2016...


The issue with the corrupted vertical line of graphics would most likely have been an issue with the power supply, power switch or RAM chips.


Now in 2018...


Could the issue be the VDP chip? I would also inspect all traces on the CV motherboard, especially those dealing with the VDP. Do yourself a favor and remove the Retrofixes mod and test the original system again using RF output. I know you didn't get any picture back in 2016, but you could start a game with the controller and did get audio from the Donkey Kong game. If the game starts and you got audio playing, then we know the original issue is with the RF board or the VDP.


Just my two sense here and this is not a knock on the Retrofixes composite mod board, but I still don't understand why everyone doesn't use the Yurkie Composite Mod Board. It is such a well designed, small and clean install compared to others that I have seen.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...