Jump to content
IGNORED

Original NES Game Loading Issue


Smack2k
 Share

Recommended Posts

I have tried to fix the pins on the 72-pin connector my NES already had and got them back to looking new...I have tried a newly bought 72-pin connector that was un-used and have this same issue.

 

When I put games in the NES and hit power, the screen is blue most of the time (sometimes the game will start fine). But if I push down on the cartridge, holding it down, and dont let it pop-up the little bit it does after you release the cart loader (about a 1/2 inch it comes back up), the game loads fine and can be started.

 

What else can I look at on my system? Its driving me nuts as two different connectors do the same thing..and one was new!

Link to comment
Share on other sites

I'm just guessing here but I think when you put it back together you did not get the little plastic tab in the center of the plastic tray below the main board. I'm pretty sure I had your issue in the past and I think that was the cause. You are causing the pressure to hit the pins at the wrong time.

Link to comment
Share on other sites

  • 1 month later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...