Jump to content

Odyssey 2 Select Game Issue

Recommended Posts

So, I've been looking through the forums to see if anyone has had the same issue as I have, but I haven't been able to find anything. Last week, I purchased an O2 that looked to be in really good condition. I turned the console on and was able to get to the "Select Game" screen, but couldn't get past it. I tried different carts and it seemed that pressing a number to choose the game did nothing. I figured something might be wrong with the keyboard, so I decided to buy another O2, but it seems to have the same issue. Has anybody had this problem before, and if so, is there any way to fix it? I really don't want to have to look for a third O2 and would like to fix these if possible.

Link to comment
Share on other sites

Open up the O2 and look at he ribbon connecting the Keyboard to the main board. If it doesn't seem broken then carefully pull it out from the connector and clean the ends with contact cleaner or rubbing alcohol and then plug it back into the connector. I have had this happen to me once and that solved it.

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...