Jump to content
IGNORED

Yet Another Atari Lynx II Won't Power Up...


bradd1978
 Share

Recommended Posts

Hey,

 

I'm relatively new to the Atari Lynx and had the opportunity to grab three broken units pretty cheap. So after doing the headphone ground trick none of them powered (i used 6 AA batteries). I was worried that the system was getting 9V throughout and these were toast. I watched a video where a guy fed 5V through the battery terminals along with the headphone ground trick and they fired up. So I tried this and Boom...both fired up with INSERT GAME. Plugged in a game and it worked excepted the screens were damaged with dead pixels. Thats ok, I've got a McWill LCD standing by :-)

I replace the Mosfet and zener diode, remove the headphone ground wire, put it together and fired it up, but nothing....I recheck everything and see that Q8 was fried. I replaced that, but lifted a pad in the process so soldered up a jumper wire. Fire it up again, nothing. I start probing around checking voltage - my multimeter probe accidentally bridged the Gate and Drain on the Mosfet (left and middle pins) and the unit fired up! I recheck my soldering and reseated the replaced Mosfet but it still didn't help.

So I'm a bit stumped now, is something else bad in the power section? Bad Mosfet? Because I'm new to the Lynx, I don't know a lot about its power section or how it works. I feel like its something really silly and I'm close to getting this running.

 

Any help would be appreciated. The other unit is another story I'll save for another thread ;-)

 

post-35160-0-43083200-1470767230_thumb.jpg

 

Link to comment
Share on other sites

I have one behaving similarly. It was working great, then bam.. nothing. Fires up with the shorted MOSFET as well.

 

I'm going to check the 4069 IC and see if that's the culprit.

 

 

Yeah shorting it now with the 5V mod just brings the backlight on. I did the headphone ground trick and used batteries and it will fire up. So bizarre

Link to comment
Share on other sites

I'm not sure about battery/headphone mod. It killed one of my Lynx 2 systems.

 

I think the better solution is to short the top of the mosfet and the right pin (solder in a wire). That seems to work for me.

Thanks I'll have to try that. I really want these to work properly using the power button. The headphone trick I don't trust myself.

 

On a side note, I'm definitely interested in buying a working unit if anyone has an extra :-)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...