Jump to content
IGNORED

Weird fire button problem


Dennis90
 Share

Recommended Posts

A PAL 6 switch Atari 2600 console I have is acting weird, the whole screen flashes when you press the fire button on player two's controller, and when you hold the button down you can see the picture like get a little bit brigther, and as soon as you let the button go it's normal again. I have tried diffrent controllers and swapped out the three main chips, the CPU, RIOT and TIA, but I still got the same problem. Anybody have an idea what the problem might be? :( Everything else works fine with the console except that. And it is AV modded btw if that has anything to do with it, it's modded with a transistor and two resistors.

Link to comment
Share on other sites

Zylon: You mean like one of the caps that sits right behind the controller port? And aha yeah, or mabye it is the HEX chip, but guess i try to replace the cap first and see if it gets better.

Jason_Atari: I am not sure, i just tested the console a little before i modded it to see if it powered up and stuff, but guess it mabye was like that before.

Link to comment
Share on other sites

I tried to replace the cap that sits right behind the controller port but that did not work, so i desoldered the HEX chip and put in another one i have and now it works fine! :) thanks for the help!

 

Problems with that are common. :)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...