Jump to content
IGNORED

UDS issue


Shift838
 Share

Recommended Posts

I have been chatting with a couple of my buddies across the US that are toying with the idea of running a BBS. of course this will be a old DOS based BBS, but they are willing (if they put it up) to include some TI/Geneve message and file areas.

 

The issue we have encountered when calling their BBS' right now is that from a real TI with a UDS device (tested with UDS10/100/1000) when connected into the BBS and when I type in an input field for say a user name if I press any key i will return 2 characters on the TI side but only one shows on the BBS side.

 

i have definitely determined it's an issue with the UDS. if I use TCPSER and my raspberry Pi hooked to the TI as the emulated modem we do not see this behavior.

 

I have scowered the internet to no avail for a solution. Lantronix has been clueless. We have messed with every possible setting like the Disconnect Mode, but no luck.

 

Has anyone see this behavior before and possibly came across a solution?

Edited by Shift838
Link to comment
Share on other sites

Check your end-of-line settings. Most systems use CR-LF, while DOS recognizes both as EOL.

 

EDIT: Thinking about it and re-reading your post, I still think this may be an EOL setting issue. The DOS BBS is accepting the CR part of the CR-LF combo as the EOL, but then SOMETHING, whether the BBS software, one of the UDS, or the TI is echoing the LF back to your terminal.

 

This would be easier to figure out if one of you has a firewall which can do packet captures. I am out of town and will not have time until later in the week, but I would be willing to help out with packet captures from my firewall. Just need to make sure I have everything I need on my end TI-wise: TI, PEB w/TI serial, several UDS-10s. Anything else?

 

Apparently I "don't read so good". I swear I read your post to say that everything work properly EXCEPT when you hit RETURN. Forget what I said above.

Link to comment
Share on other sites

Is every character echoed or just the CR/LF?

 

Remember, TCPSer and the UDS have their differences when it comes to Telnet. What you are seeing may also be an artifact of TCPSer (and the BBS) acting upon Telnet commands the UDS and TI terminal emulator ignore during connection negotiation.

 

Every character, so if I type 'A' I get 'AA' on the TI end. If I type 'C' I get 'CC' and so on.

Link to comment
Share on other sites

I had the same issue trying to use my UDS-10s as serial terminals to my Solaris machines. Later tonight I will check on the configurations and see if they help. I actually talked to a Lantronix tech guy and told him the UDS-10s were getting popular in the retro-community. He was tickled.

 

Other than that, I think IM may be correct about the differences in telnet implementations.

Link to comment
Share on other sites

Sorry, been tied up. I will swing up there tomorrow. Aside from this thread, not having the serial available if something goes awry would leave me in an inconvenient spot so I need to take care of it. This time I will label the MasterSwitch outlets so I can power-cycle remotely without fear of switching off NASes.

  • Like 1
Link to comment
Share on other sites

Here are my UDS settings. Hope these help.

 

*** Channel 1
Baudrate 9600, I/F Mode 4C, Flow 00
Port 00023
Connect Mode : C0
Auto increment source port disabled
Remote IP Adr: --- none ---, Port 00000
Disconn Mode : 40
Flush Mode : 00
Terminal name:

*** Expert
TCP Keepalive : 45s
ARP cache timeout: 600s
Monitor Mode @ bootup : enabled
HTTP Port Number : 80

Link to comment
Share on other sites

Here are my UDS settings. Hope these help.

 

*** Channel 1

Baudrate 9600, I/F Mode 4C, Flow 00

Port 00023

Connect Mode : C0

Auto increment source port disabled

Remote IP Adr: --- none ---, Port 00000

Disconn Mode : 40

Flush Mode : 00

Terminal name:

 

*** Expert

TCP Keepalive : 45s

ARP cache timeout: 600s

Monitor Mode @ bootup : enabled

HTTP Port Number : 80

 

This seems to work. but... I have not figured out how to dial out from the terminal with the UDS attached (on the TI) with these settings. I cannot see the echo and issuing an ATDT IP,PORT does nothing. If I connect between the TI and the PC via a terminal program, then exit without hanging up and launch the BBS program on the PC there is no double characters.

 

So how do you issue a connection attempt in this mode?

Link to comment
Share on other sites

What was the difference between your earlier settings and what works? Perhaps you changed too much; turning the modem echo bit back on (1) might be worth trying. If you look in the UDS manual, there is the modem mode and a manual mode. Modem mode uses AT commands; manual mode uses "C" to connect, i.e., Cx.x.x.x,port instead.

 

On a related note, today I discovered that my UDS-10 is of the IAP variety . It was failing to disconnect idle users/connections. By chance during testing, I noticed the TCP keepalive (expert setting) was 45s. If the activity timer was less than the TCP keepalive timer, the UDS disconnected properly. I ended up disabling the TCP keepalive timer, setting the connection timeout to 5:05 minutes, and now the UDS is disconnecting properly. Crossing my fingers there aren't any other bugs in this device...

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...