Jump to content
IGNORED

Lynx kaput after recap


af0l
 Share

Recommended Posts

So, I decided to recap my Lynxes MKII the other day. Both had beeen working OK before, age considered. Both had leaking C39 so I was glad i finally got to it.

 

The first one went fine. The second one, however, didn't. After I finshed and assembled it back, I get only black screen when I thurn it on. The power led is turned on (but faded). The backligkt turns on, and a high pitched whine is coming from the speaker. It is unresponsive (have to take batteries out to turn it of).

 

 

Any ideas? Please?

Link to comment
Share on other sites

So, I decided to recap my Lynxes MKII the other day. Both had beeen working OK before, age considered. Both had leaking C39 so I was glad i finally got to it.

 

The first one went fine. The second one, however, didn't. After I finshed and assembled it back, I get only black screen when I thurn it on. The power led is turned on (but faded). The backligkt turns on, and a high pitched whine is coming from the speaker. It is unresponsive (have to take batteries out to turn it of).

 

 

Any ideas? Please?

If it worked before the re-cap, then it has to be related to the caps replaced. You should inspect each one replaced carefully to make sure there are no shorts, solder splashes, broken connections, and that the correct caps are in the correct positions. Also check the ribbons are connected properly - sometimes you can get behaviour like that because the screen ribbon isn't making a good connection.

Edited by GadgetUK
  • Like 2
Link to comment
Share on other sites

Well there was a cold solder there, but thatt does not fix it.

 

Another thing, serious noise ffrom the speaker (like old tv).

 

I measured the voltages and I'm getting clean 9V on C39 and measly 2.6V on C41!

 

But everything seems fine to the eye... Any ideas are welcome...

Link to comment
Share on other sites

So, after reading a bit, I soldered an iPhone cable that kitty went badass on to the C41 and voila, the thing works. I'm going to convert both Lynxes to 5v and lipo anywy, so this is just fine :)

 

I'd still like to know what I managed to mess up, but I guess it does not matter now...

 

Thank you for your input, GadgetUK!

 

post-40763-0-76935100-1480295506_thumb.jpeg

Link to comment
Share on other sites

So, after reading a bit, I soldered an iPhone cable that kitty went badass on to the C41 and voila, the thing works. I'm going to convert both Lynxes to 5v and lipo anywy, so this is just fine :)

 

I'd still like to know what I managed to mess up, but I guess it does not matter now...

 

Thank you for your input, GadgetUK!

 

attachicon.gifimage.jpeg

Excuse me...(happy you solved) .have you connected the C41 to what with that cable?

Link to comment
Share on other sites

....I have tried also on mine that solution now....I hoped to have the same effect of yours....(see my question here: http://atariage.com/forums/topic/99383-lynx-2-repair-help-needed-only-blank-screen/) but unfortunately for me the cat with a game inside goes on but always blank screen and no audio.

I've measured the current at C41 giving the 9v to the plug and it's 3V. So I hoped to have life giving 5v with your method.... but it's not. :(

 

Listen...if you can measure....

Also for you in the D10 diode, current seems to pass through?

 

I'm sure D13 is bad but I don't know if I would obtain something changing it (anyway I've ordered it, I hope it will arrive soon)

Link to comment
Share on other sites

Hmm, sure I will take it apart and measure the voltage (I asume you wanted that). I don' have it here at the moment, but will get back to you asap.

 

Thank you, I'm looking forward to see your measurements.

 

(P.S. yes, values in Volts using the diodes tester funcion. The one that make a buzz if there isn't resistance)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...