Jump to content
IGNORED

C64 Troubleshooting Sanity Check


ToyguyVT
 Share

Recommended Posts

A friend gave me a C64 system a few years back. I'd forgotten about it and stumbled on it this past weekend and decided to try and get it going. I got an adapter and cabled it up to my MAME cabinet's TV F connector. It's got a 1541 with it so I hooked that up. On power up, it boots, the blue background and border look fine but the lettering is flashing rapidly. I only have 2 games that came with it to test with so I loaded both up. ELITE comes up and generally looks good, with some flashing in the various lines of the control panel at the bottom of the screen. Starfields and ship graphics look OK. One joystick I tried did not seem to work correctly, haven't tried the second one yet.

 

The other game is Bard's Tale II. It also boots but looks really bad. The EA logo page has a white border and you can see the EA graphic but the background is a bunch of rapidly changing color bars. Upon booting into the game and asking for the character disk, the UI looks generally good, but there is a lot of flashing at the top border and in the small window on the upper right. I can't go further than that as it appears the character disk is bad, throwing a read error.

 

Sounds seem to be OK as far as I can tell, never having heard them before, but it's full and rich and does not sound "off" in any way.

 

The PCB looks to be the later model with the fingered heat sink shield. I think the board number was the one that ended in 425 but I forgot to write it down.

 

Based on some web surfing, I think I'm looking at a replacement of the U17 PAL and the 2114. Does that sound about right? I also know I'll need to do something with the power supply eventually but I don't want to buy a new one quite yet until I see if I can get this sorted out. If so, I'll pick one up from Ray Carlsen.

 

Thanks for any advice/validation.

 

Dave

Link to comment
Share on other sites

Common problem. Be sure to bookmark this very handy guide if you haven't seen it yet: http://personalpages.tds.net/~rcarlsen/cbm/c64/c64-ic.txt

 

Ray knows his stuff. And I do recommend C64 saver or alternate replacement power supply that is built better. 9v AC is easy, use a spare 2600 adapter or spare NES adapter (genuine, not cheap aftermarket) and 5v can be obtained from decent quality USB hub power supplies or from decent quality 2.1A+ cell phone charger. (skip the cheap ones, they may add unwanted noise or ripple to 5v DC)

Link to comment
Share on other sites

I opened it up tonight and did some quick testing. The +5v line, measured at the LED connector, is only showing about 4.7v. The 9v AC is showing around 10.7 volts. The 9v fuse looks and tests fine. I forgot to measure the 12V regulator - have to do that tomorrow but I am thinking maybe the 5v logic power is just too low and preventing the thing from booting. A quick glance at the schematics seemed to indicate that the 9v AC is used only in the modulator. Is that correct?

Link to comment
Share on other sites

It ain't dead yet! :-)

 

After some research I went down and measured the output at the regulators. Both were pretty solid - 12.1v and 4.9v. I'd prefer another tenth or so on the 5v rail but at least they're good. I decided to spend a little time and re-seat all the socketed chips. This included the 3 ROMs, the 2 CIAs, the MPU, the PAL, the SID and the VIC. I also cleaned off the old heat sink goop, bent the fingers down a bit on the heat sink and re-coated everything with new goop. Turned it on and it's back to its old self. Still has the flashing letters so now I need to hunt down a PAL and probably a 2114.

 

Anyone making PALs still these days? I saw there were some aftermarket replacements but I got the impression they were long gone. True or no?

 

Thanks!

Link to comment
Share on other sites

  • 2 weeks later...

OK, so I picked up a PLA pull chip and popped it in. The machine now boots up normally and the flashing text is gone. Never having ever used one of these back in the day, is the normal screen display a light blue text on a darker blue background? Seemed kind of odd to me that the text wasn't white. Or maybe it's the color memory chip?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...