Jump to content
IGNORED

MyBIOS, an alternative OS for your Atari.


mr-atari
 Share

Recommended Posts

MyBIOS update #3, 27-05-2017 !
http://www.mr-atari....yBIOS/BETA_wip/

Change-log:

http://www.mr-atari.com/MyBIOS/BETA_wip/change-log.txt

Can be use as alternative OS in Altirra and other emulators.

(MyIDE-][ firmware included)

Features:
Fully XL/XE-compatible
Fully 400/800-compatible
Fast math pack routines (FMP)
Supports:
PBI (if present on your hardware)
MyIDE-][ (if present and updated)
SIO2BT
U1MB, ANTONIA and other upgrades with flash-able OS-space.

post-6668-0-29976000-1495869034.png

post-6668-0-10768300-1495869042.png

  • Like 12
Link to comment
Share on other sites

As you probably know I'm still extremely happy with the 4.8.0A R1 edition. But seeing you still release new versions of MyBIOS, I think I really should give this new version a try. Looks good.

 

It is perhaps not the right place to do feature requests, but since you start the topic here. I give it a shot. Feel free to do with the request whatever you want.

 

As you know in AtariLand today we have the IDE+ 2.0, the SIDE2 standalone, the SIDE2 with U1MB combination, the SIDE and the fabulous MyIDE and MyIDE ][ carts.

 

IDE+ 2.0 and SIDE and SIDE2 have embraced the APT partition format. This means that the CF card and the contents are 100% interchangeable with each other.

I also can use the APT partitions on my CF card when I run SpartaDosX from MyIDE or MyIDE 2. This is fabulous.

 

So far the introduction.

 

My Request is: could you consider that MyBIOS could handle the APT partitions too? I am still, after all these years, a fan of MyBIOS. It has a plethora of features that I love, and the best feature is the on-the-fly partition swap menu.

I love my IDE+ 2.0 too though, and I use that interface a lot, but I do not want to carry my IDE+ 2.0 around when I'm on my way (which is quite a lot during spring, summer and fall). Or in other circumstances would it be handy too if I could use the apt format.

 

I think MyBIOS is a very well developed product, with a long history of inventive ideas and solutions. With all these other gadgets around it is truly a pity that MyBIOS does not support apt partitions.

 

So that is my feature request.

  • Like 2
Link to comment
Share on other sites

Hi Mr.A-

 

Flashed my II this AM and all of the basics seem to work good. My "fallback" is 4.9.B16 in case anything should go seriously wrong with the WIP.

 

Looks very good so far! BTW, very useful "readme."

 

-Larry

  • Like 1
Link to comment
Share on other sites

Just a quick note:

Since MyBIOS is a stand alone OS, I started to post it here/my homepage.

 

The MyIDE plugin does not support apt, sorry.

The only thing it supports is during partitioning,

that you can combine apt/fat/myide on 1 card.

So you not need to swap cards all the time.

 

Basically you download 2 betas....

 

Most issues are with the MyIDE plugin, the OS and it support seems to run fine.

Link to comment
Share on other sites

Why not add the Maxflash Studio file to this download so we have the option to put different game roms in the menu. There is only one game rom that I play a lot and it is not on the menu listing.

 

Also there is not a 32k pack file in this download.

Link to comment
Share on other sites

I second the Maxflash Studio file. I enjoyed having that with the last release on the AtariMax forum so I could move things around to the way I like them. Thanks. I really appreciate the work you put into this. It's really added to the usefulness of my 130XE lately.

Link to comment
Share on other sites

OK, I remember that for the next update.

 

At the moment the places in rom are fixed, cant be changed (yet)

without distroying this working setup. Cant upload the mcw either,

since that is hacked for this purpose too....

 

Beside that, most users are average and cant custom make their content.

But next time, I will include the pac-file you need.

 

The games were for testing MyBIOS, no special meaning.

Link to comment
Share on other sites

It is a pity you decide so soon not to go for apt.

 

It would make it even more awesome.

 

Think it over please. When you work with more devices you will notice that the lack of apt support is a serious downside of mybios. And that is a pity since MyBios itself is really amazing.

  • Like 2
Link to comment
Share on other sites

It is a pity you decide so soon not to go for apt.

APT requires around 100 bytes of "safe" RAM just for the partition table pointers and access flags were it to be implemented properly, so it's probably not practical for a modified OS to support it anyway. It was rejected already when the specification was first published, and there's the additional issue of code space for the API calls.

  • Like 1
Link to comment
Share on other sites

Could FlashJazzCat build those nice

Installer ATRs for MyIdeII and Ultimate?

I'm afraid I already forgot how to do it.

Yeah... I have a neglected backlog of software tasks and updates as long as your arm. I will try to get around to this soon. :)

 

Also it occurs to me that the custom OS (based on the Altirra OS) we used for the UNO Cart could be adapted for use as a MYIDE II APT OS. There's a fair bit of code space left in the OS, and the partition table could go in the cartridge RAM... projects, projects.

Edited by flashjazzcat
  • Like 4
Link to comment
Share on other sites

The main goal of this new setup is the stand-alone OS called MyBIOS.
:D
With benefits of being downwards compatible.

 

MyIDE is a plug-in, that runs from cartridge.

So no MyIDE-][ means no MyIDE-support.

 

My first objective is to get the OS up and running nicely.

So I am concentrating on that.

Bug-fixing the MyIDE-plugin second.

Link to comment
Share on other sites

Does this work with MyIDE+Flash?

No, sorry, support for the older 1mb+IDE ended some time ago....

Latest update was 4.8.05 firmware.

 

But I did some bug-fixes in 2017 ;-)

I can highly recommend this one.

 

http://www.atarimax.com/flashcart/forum/viewtopic.php?p=9942#p9942

 

P.S.

If you want, I can update the image to contain altirra basic to 1.54

:grin:

Edited by mr-atari
  • Like 1
Link to comment
Share on other sites

No, sorry, support for the older 1mb+IDE ended some time ago....

Latest update was 4.8.05 firmware.

 

But I did some bug-fixes in 2017 ;-)

I can highly recommend this one.

 

http://www.atarimax.com/flashcart/forum/viewtopic.php?p=9942#p9942

 

P.S.

If you want, I can update the image to contain altirra basic to 1.54

:grin:

Can Fast math pack routines (FMP) be added?

Link to comment
Share on other sites

That's right.

 

OK, the request was off topic, but....

 

Here you are:

Freshly compiled: MyBIOS 4.8.0A for the older MyIDE+1Mb

-Updated with FMP

-Updated with Altirra Basic 1.54

 

Includes MCW (atarimax), PAC (packed BIOS), ATR (flasher) and BIN (Altirra/emulator)

 

The easy way:

Just boot the flasher and let it re-program your cartridge.

post-6668-0-24605400-1496039830.png

MyIDE+1Mb -FE -FMP.zip

  • Like 4
Link to comment
Share on other sites

 

OK, the request was off topic, but....

 

Here you are:

Freshly compiled: MyBIOS 4.8.0A for the older MyIDE+1Mb

-Updated with FMP

-Updated with Altirra Basic 1.54

 

Includes MCW (atarimax), PAC (packed BIOS), ATR (flasher) and BIN (Altirra/emulator)

 

The easy way:

Just boot the flasher and let it re-program your cartridge.

Awesome, and thanks!

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...