Jump to content
IGNORED

Sio2Sd stalling


Recommended Posts

Guys,

 

I have an Sio2sd (from lotherek) I got it probably 2 years ago. On certain .atr disk images it stalls while booting. This has happened since I got it and just thought they are bad disk images or something. But recently, I got a floppy drive and was writing files to a blank disk image and it will stall while writing and reading (I am using Sparta 3.2d). Now if I hit the break key it will finish reading or writing the file, sometimes I have to hit the break key multiple times. This trick does not work when it stalls booting an image. (Most of the images I have tried to boot are various versions of Spartados)

 

I went into Altirra recently to see if all those spartados disk images that stall are truly bad or there is something going on with my Sio2sd. Well, they all seem to boot up no problem.

 

I am guessing maybe my setting are goofed up. I have top drive off and device Id at 0. Could there be other settings that are causing this issue?

 

I did try to update the firmware with the latest from http://sio2sd-dev.gucio.pl/but when I try to update the firmware it says no firmware on the sd card.

 

I am using a stock 130xe.

 

Any thoughts or suggestions?

Link to comment
Share on other sites

recent versions of SDX do not work with SIO2SD at all. I have to disable SDX serial I/O support and revert to the Atari ROM SIO in order to make it work. otherwise, I get the stalling problems you describe.

 

I haven't tried older SpartaDOS versions, but it is likely the same issue.

Link to comment
Share on other sites

I have been sticking with 4.47 or lower, problems with mixed drives and ape happen for me otherwise...and you are correct the later versions don't like my sio2sd's either.... I was always a fan of SpartaDos and enjoyed SpartaDosX's continual progress including 4.47.. I am not sure what's up with later date 4.48 or 4.49... I have not had success with them... I of course use standard 130XE, a rambo XL as well as a peterson 320XE...

 

If the idea has become to insist on accelerated or very large memory machines, and or specific drive type.. I'll have to pass...

Edited by _The Doctor__
Link to comment
Share on other sites

I did give divisor 5 and 8 a shot neither worked. Neither did turning high speed off. So I just started going through each divisor option. Finally "0A" seemed to work. I still have to test it with writing to a real floppy but copying from the sd to a ram drive seemed to work flawlessly, it stalled doing that prior as well.

 

Thanks for the help!

Link to comment
Share on other sites

This could also be a firmware bug causing marginal timing. A similar thing happened while I was debugging some Z80 high speed code, with both my SIO2CP/M utility and work I was doing with SDX's INDUS.SYS and the RAMCharger.

 

It would freeze until BREAK was pressed (until I fixed it).

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...