Jump to content
IGNORED

Intellivision 1 - Power Cord


Fushek
 Share

Recommended Posts

I'm looking to see if anyone has a working Intellivision 1 power cord. I have a unit that is working, however, the cord has wire showing and it doesn't exactly look safe. I would be happy to buy one or work a minor trade with anyone who has one.

Link to comment
Share on other sites

I'm looking to see if anyone has a working Intellivision 1 power cord. I have a unit that is working, however, the cord has wire showing and it doesn't exactly look safe. I would be happy to buy one or work a minor trade with anyone who has one.

Is there anything special about the inty power cord? I thought it was just a 2 prong cable, which you could get from pretty much anything. At least wrap it in electrical tape, and if you are worried about the internal conductors shorting then replace the cable.

 

Sent from my A1-840FHD using Tapatalk

Link to comment
Share on other sites

I'm looking to see if anyone has a working Intellivision 1 power cord. I have a unit that is working, however, the cord has wire showing and it doesn't exactly look safe. I would be happy to buy one or work a minor trade with anyone who has one.

Go to any hardware store a get a replacement "lamp cord"

http://www.homedepot.com/p/GE-8-ft-Replacement-Cord-Set-with-Polarized-Plug-on-1-End-Brown-54435/203735885?gclid=COPb6K7DvNQCFRa5wAodye0FPA&gclsrc=aw.ds

 

The original is black non-polarized and is wired directly into the power transformer.

You will have to pry open the transformer and resolder.

Here is a pic:

post-47811-0-20045000-1497415675_thumb.jpg

Edited by H454
  • Like 1
Link to comment
Share on other sites

If you can time video problems, than it might be hardware.

As for cabling-

Any shielded RCA cable:

https://www.amazon.com/dp/B003NMVG64/_encoding=UTF8?coliid=IAPO9LQH4RAFT&colid=AFG0R2G5Z5K1

http://www.acehardware.com/product/index.jsp?productId=1339917

 

Basically any RCA cable that's more than 3mm in diameter will work.

I use the style with more of the side metal exposed, it fits better in older stuff( circled in red).

post-47811-0-39149100-1497494894.jpg

Edited by H454
Link to comment
Share on other sites

Awesome, thank you H454! Your help is appreciated.

 

I tried to play Intellivision with my 2 Y/O son for the first time.. only to be so disappointed.. it worked fine 3-4 months ago. :(

 

I will give an update when I get a chance to try your suggestion..

"Real Life" has been rather crazy and awesome at the same time.

 

(A new Baby Girl and a Two Year Old Son combined with a 4+ hour daily commute as a freelancer in NYC = No Time +Little $$).

 

 

;O

Link to comment
Share on other sites

Awesome, thank you H454! Your help is appreciated.

 

I tried to play Intellivision with my 2 Y/O son for the first time.. only to be so disappointed.. it worked fine 3-4 months ago. icon_sad.gif

 

 

That sounds like component failure - caps or power supply.

Old caps will be fine one day, then sit for awhile and the next time you turn it on the caps die.

I have an apple 2 monitor that it happen to.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...