Jump to content
IGNORED

Atari 800 Help


cawley1
 Share

Recommended Posts

Guys,
I picked up a PAL Atari 800 today, when I powered it up it was only displaying a black screen which did not sync - I managed to fix this by swapping the GTIA for one on an old 400 processor board.

 

So it's displaying a PAL picture and sound, and I can play cartridges fine, however, I cannot seem too get it to load anything from cassette or disk. I can't even get it to do the load 'beep' prompt or even boot error with the disk.

 

So, I have not got a cassette drive connected, but when I boot the 800 with Start held down, I would expect the beep - I don't get it.

I have a SIO2PC connected via USB, with the APE program loaded on the PC. When I boot on (holding option or not, it makes no difference) I just get the 'purr' noise as the computer starts up, it does not boot the disk.

I vaguely remember having a similar issue with a 400 or 800 a few years back, and swapped a chip to get the load 'beep' prompt to work, but I cannot remember - can anyone help me figure this out?

Thanks,

Paul

 

Link to comment
Share on other sites

does it pause as if it had beeped when you hold down start? The 800 has that internal speaker which could be broken, or disconnected.

Regardless of the sound from the internal speaker, it should boot DOS or any other executable from his SIO2PC device or at least try to load a program from cassette. SIO interface stuff goes through POKEY.
Link to comment
Share on other sites

Hi Guys,

There is a speaker connected and there is also sound coming from the TV, it does pause as if it has made the cassette beep, it just does not make the sound. I don't have a tape deck to hand to see if it would actually load a cassette - can you use the XC12 or whatever it is on the Atari 800 or are there power issues - I might have a working one of those.

 

I am sure I swapped the POKEY, but I'll give it another go. I am sure when I had the issue before it was a smaller chip I swapped, but I could be mistaken on that.

Thanks,

Paul

Link to comment
Share on other sites

Hi Guys,

There is a speaker connected and there is also sound coming from the TV, it does pause as if it has made the cassette beep, it just does not make the sound. I don't have a tape deck to hand to see if it would actually load a cassette - can you use the XC12 or whatever it is on the Atari 800 or are there power issues - I might have a working one of those.

 

I am sure I swapped the POKEY, but I'll give it another go. I am sure when I had the issue before it was a smaller chip I swapped, but I could be mistaken on that.

Thanks,

Paul

 

POKEY is on the mainboard on the 800, along with the 6520 PIA. POKEY handles not only sound, but also most keyboard IO and serial IO through the SIO port. I had a POKEY fail on a machine once in a way that it would still pass all sound and keyboard tests, but it WOULD NOT boot a disk or cassette, or access the SIO port at all. Swapped the chip and the problem was solved.

Link to comment
Share on other sites

Guys,

Thanks for all the advice - it turned out to be simple in the end, basically the internal speaker was shot! I swapped it for a spare from a 400 and the loading prompt is now loud and clear!

Managed to test this with Cart, Tape and Disk, plus the SIO2PC and all work fine.

 

One last little bit of strangeness is the sound gets slowly louder until it reaches the correct level - for instance, while booting a disk the loading beeps start low and slowly get louder over a 5-8 second time frame. What could be causing that? I will swap out the POKEY tomorrow, but wondered if anyone else had experienced this.

Thanks again,
Paul

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...