Jump to content

Harmony Encore - garbled characters


Recommended Posts



I just received a Harmony Encore and all I can say is ... WOW! This little gem brings back MANY childhood memories. The issue that I am having is that I have copied some games to an SD card, then plugged the SD card into the Harmony Encore cart. When I fire up the Atari 2600, I can get to the game list, but the names on the list do not match what the actual names of the files are.


Example: Adventure

Name of file: advntr.bin

Name that shows on Harmony Encore list: a3~15d.bin


There are others as well. Some do show the correct file name but a lot of them show this type of text.


Any ideas how to resolve?


Thank you,


Edited by jasonw970
Link to comment
Share on other sites

Thank you groundtrooper. Let me ask this - Would it matter where the ROMs are from? I ask because if I have one ROM on the SD card and name it 123.bin, shouldn't it show as 123.bin on the Harmony cart? I didn't manually name the ROMs a3~15d.bin or anything like that yet that's how they appear on the cart. On the SD card (via Explorer), that ROM shows as adventr.bin yet the Harmony lists it as a3~15d.bin Strange indeed. I'll play around with the ROMs and see what happens.

Edited by jasonw970
Link to comment
Share on other sites

Okay, did more testing. The first time I fire up the Harmony Encore cart, most of the games show their proper file name. If I move the joystick back one page and then forward to the first page again, the game listing becomes jumbled (incorrect file names). If I turn the power off then back on again, the game list shows jumbled text and not the proper game list. If I power off and back on again, 3 out 4 times the game list is jumbled and incorrect. The 1 out of 4 times it shows the first two pages correct but then after that, jumbled text. Very strange.


It doesn't matter where I get the ROMs from. It does this no matter what ROM sets I use.

Edited by jasonw970
Link to comment
Share on other sites

Hard to tell what's the reason, so here are some guesses, measures and tests you should try:

  1. The SD card is incompatible/broken or has dirty contacts. Try a different one or clean the contacts.
  2. The power supply is too weak, try a different one
  3. Something in the console is starting to fail. How does the Encore play the games? And how about normal carts?

If nothing helps, maybe the Encore is broken.


Some more questions to narrow the problem origin:

  1. Can you post pictures of the garbled text?
  2. What happens when you display long filenames (long fire button press). Do the long filenames behave like the directory display?
  3. And what happens when you return to the directory display? Does it look like before or does it change?
  4. And how about the credits screen [.]? Same problem here too?
Link to comment
Share on other sites

I have firmware 1.06 - the firmware that came with the Harmony Encore cart when I received it a few days ago. I haven't tried to do any updates to it as I assume 1.06 is the latest version.


Well, I seem to have it working, sort of.


If I power on the Harmony Encore the game list will sometimes be garbled.

If I power off and on once or twice, the game list looks normal.

If I move the joystick to the left, the game list becomes garbled.

If I move the joystick to the right, the list stays normal and remains normal

If I move the stick to the right, all is okay. If I move the stick to the left, the list stays normal UNTIL I get to the beginning of the game list. I f I move to the left from the beginning of the list, the game list becomes and stays garbled, no matter how I move the stick.

It seems that as long as I move the stick to the right, all is well.

I tried another joystick and got the same results

I tried replacing the SD card and got the same results.

At this point, I am going to enjoy the Harmony Encore and just deal with what I have, as long as I can get A list to work, I don't care how I have to move the controller.


Thank you for all that have tried assisting me with theis very strange issue.



Edited by jasonw970
Link to comment
Share on other sites

Update for those with similar issues (garbled characters in game list):


- I re-flashed the BIOS to from 1.06 to 1.05 (thank you Fred Quimby!)

Issue was still present

- I re-flashed the BIOS again from 1.05 to 1.06

Issue resolved


All is well with the game list (no gabled characters at all, no matter what way I move the stick).


Again, a HUGE THANK YOU to Fred for assisting me with this



Edited by jasonw970
  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...