Jump to content
IGNORED

Another Retropie question(MESS/Coleco tabletop)


SiberianSpForces
 Share

Recommended Posts

You need the coleco.zip for MAME 0.174

 

This is the 0.194 version, I don't know if any changes have happened to the coleco driver in the last couple of years, give it a try. coleco.zip

 

Here's a link to the RetroPie WIKI with instructions on how to set it up/where to put roms and bios files.

 

https://github.com/retropie/retropie-setup/wiki/MESS

 

Link to comment
Share on other sites

If that is MESS version 0.64 it is very, very old. What version is MESS 2016; should be no older than version 0.170.

 

That coleco.zip file is for coleco vision rather than the tabletop games. The mame files for the coleco tabletops might be called cdkong.zip, cfrogger.zip, cgalaxn.zip, cmspacmn.zip, and cpacman.zip.

Link to comment
Share on other sites

Thanks mr_me, SiberianSpForces caught me out because he's asking for something that doesn't work on RetroPie! I'm guessing MESS64 would be the 64bit MESS for PC. Judging from this post.. a couple of years ago too!

 

http://www.handheldmuseum.com/forum/viewtopic.php?t=2146&postdays=0&postorder=asc&start=60

 

The only MESS cores that get set up are :-

 

Colecovision (100% speed, driver: coleco)

CreatiVision (80-100% speed, driver: crvision, not added to the script yet)

Emerson Arcadia 2001 (100% speed, driver: arcadia)

Nintendo Entertainment System (100% speed, driver: nes)

Nintendo Gameboy (100% speed, driver: gameboy)

Sega Dreamcast VMU (100% speed, driver: svmu)

 

So you can see where I made my mistake!

Link to comment
Share on other sites

If that is MESS version 0.64 it is very, very old. What version is MESS 2016; should be no older than version 0.170.

 

That coleco.zip file is for coleco vision rather than the tabletop games. The mame files for the coleco tabletops might be called cdkong.zip, cfrogger.zip, cgalaxn.zip, cmspacmn.zip, and cpacman.zip.

IIRC, the MESS version I use is .161, I want to say it's the version that comes in the zip from Mr Robot's link. The zips for the tabletops are named like that.

 

Thanks mr_me, SiberianSpForces caught me out because he's asking for something that doesn't work on RetroPie! I'm guessing MESS64 would be the 64bit MESS for PC. Judging from this post.. a couple of years ago too!

 

http://www.handheldmuseum.com/forum/viewtopic.php?t=2146&postdays=0&postorder=asc&start=60

 

The only MESS cores that get set up are :-

 

Colecovision (100% speed, driver: coleco)

CreatiVision (80-100% speed, driver: crvision, not added to the script yet)

Emerson Arcadia 2001 (100% speed, driver: arcadia)

Nintendo Entertainment System (100% speed, driver: nes)

Nintendo Gameboy (100% speed, driver: gameboy)

Sega Dreamcast VMU (100% speed, driver: svmu)

 

So you can see where I made my mistake!

That's the link I got them from. And that's a big "aw nuts" for it not being able to work.
Link to comment
Share on other sites

That MAME build on ChoccyHobNob won't work on Jessie, and won't work on RetroPie so it's a double no. It needs the GCC 6+ C Libraries from Stretch and the SDL used isn't compatible with the custom one used by RetroPie.

 

If you have the 174 or 178 mame romset you almost certainly have the right roms for lr-mess2016 but you will have to set it all up by hand, that means dropping out of retropie and configuring retroarch from the command line to get the right games running. Only then will you be able to see if they run at all, what the error is of they dont run.

 

I'd get the PC binary for MAME 0.174 0r 0.178, whichever one you have roms for and set it up on your PC so you can test your ROMS. Get a collection of all the ROMS that you want to run, that you have tested running, and move those to a pi and work through the retroarch setup.

 

From a PC you can use commandline options like -verifyroms and -listall to help you get the roms right.

Link to comment
Share on other sites

I was thinking the ChoccyHobNob pre-compiled mame v0.188 would work with Raspbian jesse. I think it was compiled under jesse. The question is where to find it, maybe contact ChoccyHobNob. You are correct the current version is compiled for raspbian stretch and retropie is not yet compatible with stretch. You could do a dualboot with Raspbian stretch and raspbian jesse/retropie but an older ChoccyHobNob mame should be possible.

 

https://github.com/ChoccyHobNob

Edited by mr_me
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...