Jump to content
IGNORED

65xe Issues with Cartridge (I've replaced Ram, plus OS & Basic masked roms)


Gaetznes
 Share

Recommended Posts

Back Story

Last month I received this in trade. It was known dead, or at least it was a pure red screen of death. Previous owner plugged a C64 psu into it. I replaced the ram, which got me to the black screen of death. After which I replaced the masked os with a eprom. Everything seemed to work at the time. Though I had not tested it with a cartridge. I only performed a few simple commands on the screen. After It booted into basic with no problem.

 

Current Status

After attempting to play a cartridge game. I received a multitude of different results. In rare cases Blue Max did appear on screen. however it has not worked after hitting the reset button. Other results range from black screen, frozen at the blue screen (Ready not showing up), a bunch of random characters appearing on the blue screen, and varied result from the self test.

 

Self test prior to inserting cartridge will state both roms are good. After inserting cart and after removal of cart. I will get a black screen, if the game doesn't boot. I then have to use the option key to boot into self test. At this point both roms are red. I have tried this with two alternative OS and Basic masked roms and one burned OS on a eprom. The masked roms are out of known working 800xl's. All having the same effect. After forcing the self test, I can generally get back to some other resulting screen. That i've stated above they generally have been frozen. I can only get back to the normal basic screen with ready if I unplug and turn off and on the system several times over a min or leave it sitting for several mins.

 

Each hard restart is followed by at least 10-20 second, prior to another attempt.

 

Other points of note

I've followed the instructions for he Black Screen post by brensk

Tested all the caps, and they are good

PSU 5.12vdc

Once a shipment of sockets arrive, i'm considering swapping out the the MMU from one of my 800xl

I don't own an oscilloscope

 

Does anyone have any advice ?

 

29214828_2348904768460432_56221350826396

 

29215938_2348935885123987_31169433396356

 

29196789_2348901388460770_64164154964967

 

Plus this screen came up once.

27332221_2277647292252847_31213863149584

 

Link to comment
Share on other sites

Each hard restart is followed by at least 10-20 second, prior to another attempt.

 

Does your PCB use 8 DRAMs or the 2 x 4464s ?

 

4464s can take time to clear in between power cycling. I've definitely noticed this with my 65xe ( which uses 2 x 4464s ) and my Apple 2e platinum after power cycling or hitting reset.

Edited by shoestring
Link to comment
Share on other sites

Ok to answer the above questions.

 

The ram is a quantity of 8 (4164)

Voltage with a load on it, is 5.08v.

 

I'd be checking the MMU and the 6520 next.

 

That is also the plan, well the mmu was a consideration. I hadn't considered the pia chip. Good thing I have spares to follow that recommendation.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...