Jump to content

Sega Genesis Troubleshooting


Recommended Posts

Connected with HD retrovision cables to OSSC.  Also tried HD retrovision cables to retrotink 2x same flicker.  Used original power supply with new capacitor same flicker.  Tried retro game cave power supply same flicker.  Tried different genesis with same setups no flicker definitely the system.

Link to comment
Share on other sites

Interesting. I also use a set of HDretrovision cables directly into my OSSC from my model 1 and I think I've only seen that when my adapter cable to convert from the model 2 to model 1 plug port wasn't seated right or making a good connection from the Genesis AV out port. In fact, now that I think about it more, It used to happen quite often and it stopped once I started using my 32x instead and had the HDretrovision cable plugged off the 32x into the OSSC.


Link to comment
Share on other sites

Does moving the HDretrovision cables change it at all? Again I didn't get the flicker on mine, but I would have it where the color hues would brighten and darken on the image and it was do to something being loose on the HDretrovision cable side of things. Not sure the specific cause of your flicker unless something is up with the sync signal in some way? Sync isn't use on the output from the cables, but it likely is needed in the conversion process the cables do from RGB to component.


I know that doesn't help a ton but there is something different about the signal from the Genesis and that seems to be transferred through to the 32x as well in this case which, is more odd since my understanding is that the 32x just takes the RGB from the Genesis and routes it back through it own video encoder. That is why in many cases, you can get cleaned up video when using a 32x, especially on an earlier model 1 Genesis.


Just thought of something else to try...


Is this a model 1 or model 2 we are talking about here?


Link to comment
Share on other sites

Okay. Was going to suggest maybe one of the VRs wasn't doing its job right if you had a model 1 unit. I've not encountered this issue with a model 2, but did see it on my model 1 and it was due to connectivity issues between the console and along the HDretrovision cables to my OSSC from what I found.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...