Jump to content
IGNORED

Hera Primera


8bitAndy

Recommended Posts

On 4/22/2024 at 9:34 PM, sramirez2008 said:

Mine just arrived and it works as expected on my unmodded console. Btw, it doesn’t include a manual? Just want to confirm with those that have received theirs, as mine didn’t include a manual.

 

I haven't received mine yet, but email from Polyplay last September showed photos of manuals in both GCE & MB style, so I would think you should have had one.

Link to comment
Share on other sites

21 hours ago, minwah said:

I haven't received mine yet, but email from Polyplay last September showed photos of manuals in both GCE & MB style, so I would think you should have had one.

I tried contacting them via their website. Haven’t heard back yet. 

 

Note: I recived an email...the manual is in the mail.🙂

  • Like 1
Link to comment
Share on other sites

On 4/22/2024 at 1:34 PM, sramirez2008 said:

Mine just arrived and it works as expected on my unmodded console. Btw, it doesn’t include a manual? Just want to confirm with those that have received theirs, as mine didn’t include a manual.

IMG_4805.jpeg

Just cracked mine. We do have a manual. I saw that yours is on the way. This guy at poly play is pretty straight up IMG_2332.thumb.jpeg.47919774a50c4ce68da5f8a90bcadb3b.jpegIMG_2333.thumb.jpeg.44b018f0c30690605bdefb4aca5ea069.jpeg

  • Like 2
Link to comment
Share on other sites

On 4/23/2024 at 10:45 AM, Anjay75 said:

I received mine with a manual. The game runs but unfortunately, I have another problem I've never experienced before on any other vectrex game: while the ship and orb with the human are displayed correctly, the enemies flying down in formation have an extremely low brightness level making them nearly invisible even without the overlay. With the overlay, it's unplayable.

I don't think it's my vectrex because Minefield, Berzerk and Kristof's Vector Patrol are being displayed correctly, with and without overlays. My vectrex is an unmodded 3000-GI-Euro.

Does anyone have any idea what's happening here?

OK, so in case anybody makes the same stupid mistake, though unlikely;-)  - compared to other games this one needs the brightness level turned up high it seems...Btw, the nice chap at poly.play is already hard at work replacing the cartridge for owners of 31XXXX and 4XXXXX models. Awesome game, really enjoying it:-) 

Edited by Anjay75
  • Like 1
Link to comment
Share on other sites

  • 2 weeks later...
Posted (edited)

Beware! I received the game 1 month ago but it never worked. The above solution did not work for me (Vectrex with buzz). The worst: I contacted PolyPlay several times but they NEVER replied. It is not professional.

Edited by J.Vince
Link to comment
Share on other sites

Received this email just today. I guess all people that finished orders will also receive it soon:

 

Hallo,

unfortunately, after the completion of Hera Primera, it turned out that the modules do not work on all revisions of the Vectrex. The game only runs on older models with serial numbers 3XXXXXX. Unfortunately, the game does not work on models with serial numbers 31XXXXXXX or 4XXXXXX.
I have therefore stopped sending the games. I am currently working on a solution.  I have to open all the sealed game boxes again, take the modules apart and fix the circuit boards. As I am doing this on my own, it will unfortunately take some time.
As soon as I have finished reworking all the modules, shipping will continue. I think it will continue at the beginning of June.
All those who have already received their Hera Primera will receive a replacement board for exchange.

Best regrads
Sebastian Bach

 

I received my copy some weeks ago so please be patience, probably Sebastian is overloaded with this situation.

 

Link to comment
Share on other sites

Posted (edited)
On 5/18/2024 at 1:32 PM, J.Vince said:

Beware! I received the game 1 month ago but it never worked. The above solution did not work for me (Vectrex with buzz). The worst: I contacted PolyPlay several times but they NEVER replied. It is not professional.

Hi J. Vince!  By the above solution, do you mean the PCB modification I posted?  Poly.play verified it was working for them.

If you did try it, can you post some pictures of the repair?  Also to note, they made the circuit board kind of upside down from how you normally make them. 
On the Hera Primera cart, EPROM should face down towards the bottom shell, and the yellow cap should face up towards the top shell (with label). 
Or if you want to try to plug it in PCB only, the EPROM should dangle down on the bottom side.

Edited by playvectrex
Link to comment
Share on other sites

Posted (edited)
Hi Playvectrex,
 
Many thanks for your help and yes, I respected the way to solder the wire as explained in your diagram. It was very clear. Not sure that it was the same problem for me.
Following your advices, I checked that  I correctly inserted the board into the shell (indeed there is a risk to position it in the wrong way). Sorry for a photo of the repair, I’m not at home these days. Nevertheless to complete this message I have to precise that my buzz Vectrex is an european MB serial 30XXXXX.
And as I said in my previous message, I didn't imagine that there was only one person to do everything behind the PolyPlay shop. Now I totally understand how complicated it can be: all my respect for so much effort accomplished after repeated difficulties, especially about the overlays…
Edited by J.Vince
  • Like 1
Link to comment
Share on other sites

  • 3 weeks later...
On 5/24/2024 at 12:16 AM, J.Vince said:
Hi Playvectrex,
 
Many thanks for your help and yes, I respected the way to solder the wire as explained in your diagram. It was very clear. Not sure that it was the same problem for me.
Following your advices, I checked that  I correctly inserted the board into the shell (indeed there is a risk to position it in the wrong way). Sorry for a photo of the repair, I’m not at home these days. Nevertheless to complete this message I have to precise that my buzz Vectrex is an european MB serial 30XXXXX.
And as I said in my previous message, I didn't imagine that there was only one person to do everything behind the PolyPlay shop. Now I totally understand how complicated it can be: all my respect for so much effort accomplished after repeated difficulties, especially about the overlays…

Hmm, well if you made that mod I would guess it should work.  This is what Poly.play will be doing, so I'm not sure why it wouldn't work for you but hopefully theirs works when it arrives.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...