Jump to content

#FujiNet Testing and Bug Reporting Thread

Recommended Posts

1 minute ago, NISMOPC said:

Just an update on my issues above. Apparently, they resolved themselves. ?


I am not quite sure what corrected this, but here are a few things I recently did. Re-arranged my "Atari" room. Moved my shelving with my CRT TV, Atari 7800, Atari Video Music and carts to other side (right side instead of left), but left my 8-bit set-up alone. Same power supply, same S-video cable, same location, etc.


I updated the firmware yesterday to the latest version and removed the USB power to FujiNet.


All I can say is WOW! Picture quality is super clean. There are no drops in power with FujiNet being powered off 130XE. I am confused and overjoyed at the same time...


Not the best pictures and they do not do it justice.



just wait, until you throw a UAV in there. ;)


Link to comment
Share on other sites

I'm getting an Error 130 in BASIC when trying to access N:


I'm using the commands from the Fujinet "N: Has a JSON Parser!" video (bottom of email).


Atari 800 - Incognito - SpartaDOS X (w/Fujinet utilities) - (recent ROM flash on Fujinet).  I boot to SD X;  type 'BASIC',  then run both commands in the video:


DIM A$(99)




then receive ERROR-   130

(I receive the error regardless of whether I just try to open N: with no internet addresses or with the full type out above)


Any recommendations?  My goal is to see it work and then write a stock symbol/price lookup program (using JSON) as something to do on the Atari..  Thanks :)






Link to comment
Share on other sites

53 minutes ago, tschak909 said:

@Xebec if you don't load the handler (NDEV.COM), you don't get the N: device. ;)




LOL - Duh - that worked - thank you :) 


I am now getting occasional hangs on the XIO read/write commands (either they work immediately or they time out eventually with Error 138) but will mess around later today to see what's going on.   Thanks again for this wonderful device!

Link to comment
Share on other sites

7 minutes ago, StefanD said:

I'm currently experimenting with the FNC tools and the SIO API.

After using FEJECT to eject a drive, a following DIR to this drive resets the Fujinet cart and all drives are unmounted. Is this a bug in FEJECT (or the $E9 command)?


Can you give me a list of steps to reproduce? 


Link to comment
Share on other sites

The delightful (and gorgeous!) new game Albert does not load via FujiNet. However, it loads up perfectly via the XEL-CF loader in my 1088XLD. It will seem to load but crash with corrupted graphics all over the screen and screeching audio garbage. However, as noted, it will load perfectly via the Jon's Loader. I have not tested it via RespeQT and my SIO2PC device. If you want to try to reproduce, the game is PAL-only.


EDIT: DISREGARD! For some inexplicable reason, the game is now loading and running from my FujiNet fine tonight. I have no clue why it's behaving differently, but I didn't do a darn thing different testing tonight than the half-dozen or so attempts I made last night. 

  • Like 1
Link to comment
Share on other sites

That check was never meant to lock a program out, it was meant to allow the proper version of a game or portion of code to run with a caveat that a cartridge might display that it won't run on such and such system if the wrong OS or PAL/NTSC system were detected.. but today... the carts and banking methods negate almost any need for that either


The check seems to only get used for locking out these days...the opposite of it's intended purpose..

Edited by _The Doctor__
Link to comment
Share on other sites

  • 3 weeks later...

hey @Kyle22, do you still have the issue where if the sd card is in the wifi tells you to jump in a lake?

take the sd card out and everything is fine...

is it possible fujinet wants the SD card in a certain FAT type to read the config files for wifi and then gets lost if it isn't there in the format it desires?

maybe @tschak909 can chime in.... I must have missed if it has a need/preference for a fat type when skimming for an answer.

Link to comment
Share on other sites

Ok, I am going to keep reiterating, please, guys, listen and listen well:


When you have "Something doesn't work"


Can you please, ... PLEASE.... Load up the FujiNet flasher, start up the debugging monitor, and cut and paste the information emitted when the problem occurs?



Link to comment
Share on other sites

15 minutes ago, Kyle22 said:

I did and it made no change.


Remove card from fujinet, Delete fnconfig.ini from the card, keep card out of fujinet. Power up fujinet while holding button B. This will wipe the config from the internal storage also.


Then reinsert sd card and try again

Link to comment
Share on other sites

I deleted fnconfig.ini, power off booted while holding B button and it worked. Rebooted again it did NOT work. I had to delete the file again and hold B on power up for it to work.

I don't have debug output because I forgot to bring my live boot DVD so I can't fun the flasher.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...