Jump to content
IGNORED

Fujinet story— Weather program


Blues76
 Share

Recommended Posts

This is really cool, unfortunately the weather.exe linked to in the story isn't the latest version and has graphical bug in it.  I know some folks have it on their servers by I'd like to place a version on my SD card....

 

Also, is this first "app" developed for the Fujinet in the appstore sense?

 

As an aside:  has wunderground's telnet service stopped? I haven't been able to retrieve a weather report since I got my Fujinet.  Though you can connect to the server still.

Link to comment
Share on other sites

10 hours ago, 8bitguy1 said:

This is really cool, unfortunately the weather.exe linked to in the story isn't the latest version and has graphical bug in it.  I know some folks have it on their servers by I'd like to place a version on my SD card....

 

Also, is this first "app" developed for the Fujinet in the appstore sense?

 

As an aside:  has wunderground's telnet service stopped? I haven't been able to retrieve a weather report since I got my Fujinet.  Though you can connect to the server still.

write to them — maybe they will updated 

Link to comment
Share on other sites

This is really cool, unfortunately the weather.exe linked to in the story isn't the latest version and has graphical bug in it.  I know some folks have it on their servers by I'd like to place a version on my SD card....
 
Also, is this first "app" developed for the Fujinet in the appstore sense?
 
As an aside:  has wunderground's telnet service stopped? I haven't been able to retrieve a weather report since I got my Fujinet.  Though you can connect to the server still.

Updated build available through the link in the story...


Sent from my iPhone using Tapatalk
Link to comment
Share on other sites

New version of my weather application has been released!

 

Improvements:
- now user settings and last location are stored, so it starts faster,
- you can set and use custom API key, and then change auto-refresh interval
- 2 new awesome visual themes by PG!
- some bugfixes
- It should work on all XL/XE computers, but not sure if it will work on 400/800. I don't have any of them to check it out, sorry ?
- Now application starts from .atr image.

 

Boot it from TNFS fujinet.pl /networking/weather.atr

 

Make sure you have the latest version of the firmware installed on your #FujiNet device, otherwise saving options will not work.

weather.atr

  • Like 6
Link to comment
Share on other sites

  • 2 months later...

Has anyone been having issue getting the forecast with Weather.xex/atr today? Yesterday everything worked great for me, but today I can only get current conditions and when I go to forecast it hangs at "checking forecast" and sometimes it freezes and I have to reboot and other times I can get back to the current conditions. Everything else seems to be working right though. If you have looked at the weather on your fujinet today can you tell me if the forecaster is working for you or not? I want to figure out if it's an issue on my end or with the service maybe?

Link to comment
Share on other sites

Just now, Gunstar said:

Has anyone been having issue getting the forecast with Weather.xex/atr today? Yesterday everything worked great for me, but today I can only get current conditions and when I go to forecast it hangs at "checking forecast" and sometimes it freezes and I have to reboot and other times I can get back to the current conditions. Everything else seems to be working right though. If you have looked at the weather on your fujinet today can you tell me if the forecaster is working for you or not? I want to figure out if it's an issue on my end or with the service maybe?

It's most likely due to the N: rewrite, the weather probably needs a fix. paging @bocianu.

 

-THom

  • Thanks 1
Link to comment
Share on other sites

@Gunstar, do you have latest firmware on your #FN?

I'm not experiencing any issues...

Does anyone else have a similar problem?

 

EDIT: Just updated to latest one and still no issues.

 

@tschak909: Does "N: rewrite" affect my app, if I'm doing direct SIO communication with #FN?

 

 

Edited by bocianu
Link to comment
Share on other sites

27 minutes ago, bocianu said:

@Gunstar, do you have latest firmware on your #FN?

I'm not experiencing any issues...

Does anyone else have a similar problem?

 

EDIT: Just updated to latest one and still no issues.

 

@tschak909: Does "N: rewrite" affect my app, if I'm doing direct SIO communication with #FN?

 

 

Yeah, because the firmware has changed, will test shortly.

-Thom

 

Link to comment
Share on other sites

@bocianuI updated to the latest firmware as of yesterday, unless it's changed again since then. I only got my Fujinet a few days ago. It was working fine yesterday too. I'll check it out again though...I just tried again and it still hangs at the "checking forecast" screen, sometimes when it does it show a "c" down in the corner. And for the heck of it I changed cities, I tried London,UK, and it also gave me the current weather, but when I tried to load the forecast it hung again, but has a "ca" down in the corner sometimes, sometimes nothing.

 

I can hit ESC and it will go back to current weather and all the other options work like changing the graphics and units and refresh. etc. If I let it sit on "checking forcast" for a while, the screen sometimes changes to light blue, showing my city, state and country at the bottom, and if I hit the space bar the "next", "back", and "quit" options show up, but "next" does noting and back will load the current forecast screen back up. sometimes this doesn't happen, but I can go back with ESC. And sometimes the entire program just freezes and I have to do a cold start.

 

20210122_203758.jpg

20210122_204546.jpg

Edited by Gunstar
Link to comment
Share on other sites

I just figured out the problem. I had set my HSIO on Incognito and on Fujinet to divisor 0. I just changed my Incognito BIOS back to standard SIO speed and now weather.atr works fine. I hadn't thought about that until now. So I'll do some further testing as different divisors and see when it stops working right.

Edited by Gunstar
Link to comment
Share on other sites

Ok, the results are that Weather.atr works fine up to divisor 5: 73Kb, most of the time, after that it crashes or hangs if you try to get a forecast. Divisor 6: 69Kb seems to work every time.

Edited by Gunstar
Link to comment
Share on other sites

1 hour ago, Gunstar said:

Ok, the results are that Weather.atr works fine up to divisor 5: 73Kb, most of the time, after that it crashes or hangs if you try to get a forecast. Divisor 6: 69Kb seems to work every time.

Yeah, this basically means that weather needs some slight refinement as to making sure all data is gathered.

-Thom

 

  • Like 3
Link to comment
Share on other sites

is there a way for a program or batch file to change fujinet divisor on the fly? might make for a slick way to load stuff that is not hs or ultra capable load without issue... ie the batch or launch file could set the fujinet and the dos to the required divisor without config prog screen setting rebootting etc etc.

  • Like 2
Link to comment
Share on other sites

Another good idea by @_The Doctor__! I've reduced from Divisor 0 to 6 because I'm now using the Weather.atr on a daily basis and even multiple times a day, but so far, which isn't much I grant you, Divisor 0 on Fujinet has worked fine otherwise and it would be great if the program was adjusted to work at divisor 0, but I would like to use 0 and then change it to whatever is needed on the fly because I'm sure this won't be the last program loaded over Fujinet that behaves this way, and probably isn't the first, except to me.

Edited by Gunstar
Link to comment
Share on other sites

8 minutes ago, _The Doctor__ said:

is there a way for a program or batch file to change fujinet divisor on the fly? might make for a slick way to load stuff that is not hs or ultra capable load without issue... ie the batch or launch file could set the fujinet and the dos to the required divisor without config prog screen setting rebootting etc etc.

I will add commands for this.

-Thom

  • Like 4
Link to comment
Share on other sites

19 hours ago, Gunstar said:

Ok, the results are that Weather.atr works fine up to divisor 5: 73Kb, most of the time, after that it crashes or hangs if you try to get a forecast. Divisor 6: 69Kb seems to work every time.

Gotta be an ISP/LAN or other network congestion issue - I just booted up the weather.atr file at Divisor 0 from the server in Poland without issue. There was a bit of stuttering once but it worked fine, as it has the half-dozen other times I've played around with it over the last couple months. 

  • Thanks 2
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...