Jump to content

Stella mouse as paddle x-axis


Recommended Posts

I'm putting together a spinner mounted on an upside-down mouse (pillow block bearings with a knob), as I've seen describe here in the hardware gallery. 

It works well except I have to mount the whole thing on the side of the mouse where there's not much room.


Is it possible to change Stella to use the mouse x-axis instead of the y-axis for the paddle?  That would make a more natural position for the knob.

I'm using Stella 6.0.1 on raspberry pi with retropi.


thanks in advance.



Link to comment
Share on other sites

You will need to attach a keyboard and standard mouse to do this.  If you are comfortable navigating a menu system with a keyboard only, then you don't really need a mouse, but it would be easier with a mouse attached.


After you start any Atari game, then you press the TAB button on the keyboard and the emulator menu will appear.


From within the menu you can go to the input menu and swap the axis - I think


Let's see if @stephena can come in here for confirmation.


I've not read the documentation, but maybe there is a clue in there, too :)

Stella - user guide

Link to comment
Share on other sites

Not sure if you can do it globally but you can do it for each game.  Some games like video olympics default to the mouse y-axis while others default to the x-axis.  You can find the setting to manually change it here (Stella 6.0.2).


Options > Game Properties > Specific mouse axes



Edited by mr_me
Link to comment
Share on other sites

Thanks for the replies.  I read the whole manual and I did try the specific game option to change the axis but it isn't changing the behaviour any.  I've tried with paddle0 and paddle1.  I tried with each of the four paddle types in the dropdown (Paddles, Paddles_IAxDr, etc)


I don't understand the global 'map' function; I can't see how to map an analog action.


My version is downloaded from within the retropi front-end (regular Stella -- not the bundled stella-lr).  It doesn't have a 'mouse' tab as I've seen in some screenshots.


In order to use a spinner-mouse I'll need to fix it to one axis.  Seems like that's what the 'specific axis' option is supposed to do, but it's just not working.  I only have one mouse attached.

Anybody else have this working?


Link to comment
Share on other sites

The default game in video olympics has Paddle 0 (left) controlled by the computer; try setting it to paddle 1.  You also have to exit the game and restart for these changes to take effect.  The only glitch I noticed is setting x-axis to none causes y-axis to be ignored.

Link to comment
Share on other sites

It works!   It's always something stupid....  I tested on Linux with v 5.1.1 and it worked fine.  I noticed on that version the game options are chosen before launching the game.


So I went back to defaults on the rPi, changed paddle1 specific axis to x-axis and y-axis to none. 

I realized didn't read the most important bit! :

(*) Changes to properties require a ROM reload


Quitting and going back in solved the problem.


Thank you everyone for helping me troubleshoot this!


  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...