Jump to content

Fujinet TNFS Server Image


Recommended Posts

  • 2 weeks later...
  • 4 months later...

I got my FujiNet 1.5 yesterday.  Found the link to your TNFS server for Pi and got it going today.


With basically zero Linux experience since the 90's when Red Hat was free, it was easy to setup and put a few files on it.


Fun stuff...



  • Like 5
Link to comment
Share on other sites

  • 6 months later...

Hi Mr Robot, Please can you assist me on setting up the sd card image you've created for the raspberry pi. Ive followed your instructions and now ive finally found the wpa_supplicant.config file. Ive also change the network settings to my SSID and Password and saved before transferring the sd card to the raspberri pi3b.


On booting i see the network is online then i have to login so i entered tnfs and pi as password.  Now thats as far as i get? Im not sure if its on my network and in my list there is some unknown with an ip address but not sure what im looking for?

Also on the sd card mine has 2 partitions , 1 for the d:BOOT and the other is f:empty So do i put atari xl atr's in that part of the sd card ? and what ip address do i enter in the TNFS host list on the fujinet?


Does the rasp pi know that there is the 2nd partition with the atr's? and accessing them from the atari???? 


I did ONCE get this TNFS server up and running on my windows10 and it worked like a charm but i reset the router and lost what settings i put in there but although i have done this over and over again to the letter ive given up on windows10 . So now as it appears simpler to use a rasp pi i thought id have a go at that but its not so plug and play? please can you help what i am to do with the log in stage on the pi and what do i enter on the fujinet to access the atr's and where do i put the atr's for the fujinet to see them?


Thank you


just checked in my router and the raspberry pis ip address is there online... So i know thats ok but not sure where the atr's go on the sd card the F:drive has gone now?

Edited by Back2skooldaze
Link to comment
Share on other sites

you need a little more experience with raspberry pi's. the pi sd has two partitions, one is fat32 and accessible in windows, it contains the base boot configuration, the other is ext3 and only accessible to the pi, the fat32 partition appears on the pi as the /boot/ dir


you cannot copy atari files to the sd card, you have to access it via ftp/sftp/samba over your network once it's in the pi and the pi is booted. 


login with pi as username, tnfs as password, not the other way around


in windows open an explorer window and click on network in the sidebar, the tnfs server should appear there if it's running correctly, you can put files onto the server there.


Link to comment
Share on other sites

Hi Mr Robot, Cheers for your reply,  Ive finally achieved the setup. Once i found the wpa_supplicant.config file i used Visual studio code to edit the file and entered my SSID and Password. Once the sd card was in the pi booting i could see i was online and i found the pi's IP address. So now ive entered the pi's IP on the fujinet its working great. Only thing is i get an empty message which means there's no Atr's etc.. Thats where i got confused as to where the Atr's go?

So now you've told me to go to network on the Win10 I'll go try.


Thanks Mr Robot much appreciated :)


Link to comment
Share on other sites

Hi Mr Robot, I've got the pi connected to my windows and on the fujinet its working obviously with an empty as theres no Atr's in there yet . I've also check in my router in connected devices under wifi and the tnfs is there working but i can not find it in windows? Ive gone to network and i see the connected devices connected but theres no rasp pi/ip address? I'm stuck now as to where to put the Atr's on the pc?


Ive redone the sd card a few times and its not showing in the network on pc but yet its working on the fujinet?

Link to comment
Share on other sites

  • 1 year later...
On 1/11/2021 at 2:56 PM, Mr Robot said:

I just tried it on a 3B and a 3B+, also a 2B and a 1 with USB wifi dongles in them and it worked fine in all of them. 


I'd try writing the card and setting up the wpa_supplicant.conf again, it's definitely something screwy at your end @tsom!

Dandy news.  I'm late to the game but I'm setting up my old Atari 130XE and ATR8000.  I bought a Fujinet as well and the next thing would be a TNFS server.  I happen to have a couple of Raspberry Pi 3Bs looking for something to do and this will suit well, I think.


Thanks for the work you've done testing these different Raspberry Pi models.

Link to comment
Share on other sites

On 1/9/2022 at 12:45 PM, Back2skooldaze said:

Can i change from wifi to etherent in the tnfs server?


On 1/9/2022 at 4:47 PM, Mr Robot said:

yep you should just be able to rename the wpa supplicant config so the wifi doesn't get initialized. 



One other method:


Edit /boot/config.txt.  Find the section in that file named '[all]'.  Immediately below the '[all]' line, enter "dtoverlay=disable-wifi" without the quotes.  Save the file, reboot and wifi is disabled.


If you also want to disable bluetooth, add a second line after the first that reads, "dtoverlay=disable-bt" (again, no quotes).  Save, reboot, bluetooth is disabled.

Link to comment
Share on other sites

  • 2 weeks later...

Thank you for your hard work.


I'm a big fan of the raspberry pi, I have a dozen of them which I use mainly for emulation or home automaton, but I think that to build a server with 24/7 presence on the Internet, a Linux x86-64 image that you could easily set up on a cheap VPS plan like Digital Ocean or Contabo would make more sense.


I hope I don't offend or discourage you, just trying to make a constructive comment.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...