Jump to content

Original Magnavox Odyssey (1972) Help


Recommended Posts

Hello everyone, not sure where to post this, but I thought this might be the best spot. I just got my original Magnavox odyssey out yesterday and today to mess around with it and now it is not working all of a sudden. Had some very minor problems yesterday, but all in all there was a picture on the screen and I was able to play game card 1 for the most part. Today I plugged in an Atari 2600 adapter in the back using a small converter for external power to save on batteries and couldn't get a signal to come onto the television. So I switched to using the c-batteries for the bottom battery port putting, removing the external power before putting them back in but had the same problem, so I removed the cover of the console and plugged in the game card 1 and still nothing. Removed the card and for some reason I just tried gently putting in the game card and the game came on the screen. Wiggling the card very very gently on the screen got the net to come down and spawned players 1 and 2 and the ball, but the console would "shut off" and the picture would go away. When I say wiggling I mean just resting the card at the edge of the cartridge slot and if it wasn't placed on the very edge of the connector the odyssey couldn't read it essentially. Even trying to push it in a little caused the console to "shut off". I was wondering if someone has experience with these console and could help me figure out what is going on or if some small electronic part failed or something like that. The picture was working great yesterday with the card fully inserted and now nothing. I opened up the console and reflowed the cartridge slot but there is 0 improvement. Hopefully me explanation makes sense, any help is greatly appreciated. Thank you all. 

  • Like 1
Link to comment
Share on other sites

First off just want to say I'm not technical minded in any way, just a gamer, I might also just about to repeat what you've already said in a different way if so, ignore me... Haha.


I'm wondering if you tried any of the other cards and got any luck, I recently got shooting gallery and one of the cards had its pins rusted, it took a bit of work to get them working again by clearing it. 


For the odyssey 1, Pin 1 and 2 of the cards links the power supply and turns it on by completing the circuit whether it's batteries or plugged in. If you appear to be losing power (on new batteries presumably too) randomly or having to hold it in a certain way - it might be the contacts isn't quite enough to maintain it, or the pins isn't connecting in some way. 


Saying you see the display flicker on suggests its going through the circuit for a little while though because otherwise you'd get nothing. Having it working not so long ago probably also discounts using some of the internal adjustments. 


My fear is that plugging the 2600 adapter has not done it any good, as someone in the UK with a US model, I haven't risked any PSUs and kept to using batteries! So not much help in this either as I don't know US ratings etc. Did you use batteries the first time when it did work? Also what is the battery content? I don't know if the system is funny about anything other than Zink, when i don't know I try to keep the batteries as basic as possible. 


Edit: when in doubt with the odyssey 1,open it up and remove and reinsert all boards. Mine has this thing where the ball stops half way in some game modes. Sometimes doing this fixes it. It might not be the card inserted that is a problem, but the boards in its 'motherboard'. 


Edited by Mikebloke
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...