Jump to content

Harmony Cartridge Troubles


Recommended Posts

So something weird happened, the Harmony Cartridge was working great for a few hours. But I had accidentally placed a Sega Genesis rom onto the Harmony Cart. And I clicked this Sega Genesis rom accidentally thinking it was some Atari Hack, this lead to the spinning Yin Yang symbol forever. I turned the system off removed the cart placed it back in, and now it just has an infinite Yin Yang spin on the start up. I tried it in multiple Atari systems since this incident and it just infinitely loops the yin yang screen. I really think this has something to do with accidentally booting this Sega Genesis rom, like everything going wrong followed from that. (My Atari's are recapped and have very nice insides)


This is my first day having the Harmony Cartridge and I was very excited to use it, and it worked great until the above happened. Is there anyway using the usb port that I can fix this issue, cause I think that Genesis rom scrambled things, and if I could plug the harmony into my computer and fix it, that would be great.

Link to comment
Share on other sites

33 minutes ago, Thomas Jentzsch said:

Have you tried flashing the BIOS again?

Yeah so two issues, The Harmony Programming Tool doesn't recognize that the cart is plugged in. I'm on a windows 10, I installed the drivers mentioned somewhere else on this forum (but no way to know if that post is older and not relevant anymore) I just got my cart yesterday.  I noticed that in the manual it was talking about a Mini-B connector, but like I said my cart is brand new, and the Mini-B cable I have doesn't fit, only my android phone charger fits into the plug. Windows 10 makes a sound when I plug the cart in. But in Device Manager there is a question mark beside it, even though I installed drivers and restarted the computer.


Is it possible to reflash the bios right onto the sd card, or does the harmony cart itself require a connection?

Link to comment
Share on other sites

2 minutes ago, Thomas Jentzsch said:

I know there is an option where you can put the BIOS file onto the SD card just like a game. Harmony then updates the BIOS during boot. But you have to look it up yourself. And since your Harmony doesn't boot anymore, I suppose it might not work.

I was able to fix the problem, by downloading the newest drivers for micro usb ports that is on the very last (most current) page of the thread that discusses it. From there I just Reflashed both the eeprom and the bios and my cart started working great once again. Thank you for the help 

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...