Jump to content

Factory Reset New JagSD


Recommended Posts

I think I may have messed up a firmware upgrade (v1.11), as after the upgrade, everything I load goes to a red jag screen. I tried to use the original firmware.upd file from 210108, which attempted to update the firmware, but still the red jag screen. I attempted to update the firmware to the 210413 release, and the same thing. Everything worked before I tried this upgrade. I have tried a different memory card, and cleaning the contacts.


Is it possible that the firmware update failed, and if so, is there a "hard reset" option to get this back to the factory settings? I saw posts about renaming to firmware.upd to firmware.ovr, but that just brings me straight to the QR screen. Not sure if that is meant for the older carts or not.



I got this back up and running. I'm not sure if this is an official downgrade/upgrade process, but

1) I placed the 210413 firmware update in the root, and it updated as normal

2) I selected OPTION during boot-up, and downloaded the firmware update from that specific direct link. Placed that update on the root of the SD, and that worked.


I think I had an old firmware upgrade link saved in my browser, and whatever version I downloaded might have messed things up

Edited by cubeboy
  • Like 1
  • Thanks 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...