Jump to content

Franklin Ace-1000 Beeps (sometimes) with a Garbage Screen


Recommended Posts

Just picked up a Franklin ACE 1000 and I have an issue.  The computer powers with a screen full of garbage (various random characters, many inverted, with a few random solid and checkered blocks mixed in), and will beep on power-up most of the time (every so often it's silent).  Usually hitting reset will cause it to beep, and typically change the garbage on screen (fewer characters, or more spaces, lots of exclamation points).  
So far I haven't done much to it.  Cleaned it out.  Removed something like a dozen acorns from inside.  I didn't see or smell any evidence of something living in there, and some of the actors were too large to fit through the slots in the back.  I can only conclude that someone did that intentionally.  I just can't figure out why.  I also opened the PSU to check the REFAs and tested the voltages (they seem good).  Removed the two cards (a Microtek parallel printer card and a Franklin disk controller).  I should note that with the disk controller installed, there is no beep at all, and the garbage on the screen consists of blocks and patterns.  I got a similar result out of an Apple ROM card with Integer BASIC.  
That's about it.  Beyond that, I really don't know what I'm doing with this.  While I do own several Apple IIs, up till this week, the oldest was a //e, which is a very different animal (even if largely compatible).  I now have an Apple ][ Plus as well, but currently it's in worse shape as it neither beeps nor gives a picture.  I may post about that later if replacing the 74S86 doesn't help.  For now, I've been going through Sam's Troubleshooting guide (how I knew about the 74S86), but I'm not sure how much of this will translate?  Does anyone know of a troubleshooting guide specifically for the Franklin?  Or have some idea where I should be looking?  Any help would be appreciated.
Below is a photo of the motherboard.  There's a strange jumper wire that runs from the IC at B12 all the way to R62 [missing] at A14.  I'm not sure if that's normal or not.  Also, there are two screenshots, the first is of the initial power-up, the second is after I hit reset.




Link to comment
Share on other sites

Update:  On advice from Applefritter and 68kMLA, I tried swapping RAM chips between rows.  The machine booted after swapping the first chip!  Then, after repeated testing, it went right back to what it was doing before.  Weirdly, the first chip I swapped looked to be Apple-branded.  Don't know if this is important, but all the RAM chips are ceramic cases, and the one at F6 is soldered to the board.  It's literally the only IC that is (has me wondering about the sockets).  I ended up swapping every chip with the first row (except the one soldered into F6 obviously) with no success.  


So at this point, this has become a tale of two computers.  Not making any progress with the RAM, I tried swapping chips between the Apple ][ Plus and the Franklin, trying to see if the no video/no beep would follow a damaged chip.  I ended up swapping the 74S86 (B2), and transplanting (as several of the legs from the Frankin ICs snapped right off as soon as they left the sockets) the 74S175 (B1), 74LS153 (C1), 74S195 (C2), with no change in the Franklin's behavior.  (Side note, I knew this thing was a clone, but I had no idea just how much of it was copy and paste.)  At this point, according to the Sam's guide, IC failure is not my ][ Plus's problem.  I still have to get replacements for B1, C1, and C2 anyway as I have two computers that need them, and now only enough chips for one.  




I suppose I'll try swapping the RAM from the ][ Plus to the Franklin?  I still don't know if that bodge wire on the Franklin board is normal or not, but it doesn't seem to be interfering with operation, so I guess I'll leave it.  Also, now I know that the keyboard is nonresponsive.  So progress!  Still, if anyone has any ideas...

Link to comment
Share on other sites

  • 3 weeks later...

 The garbage screen is back, and I still don't know why??? 


I've tried every socketed RAM chip on the board in an Apple ][ Plus and every chip tested good.  So... not the RAM?  There were several ICs with corroded legs that I replaced, but there has been no change in behavior.  I'm starting to turn my attention to the sockets themselves.  I had sprayed them all with contact cleaner before it came back to life, but maybe there's some oxidation or corrosion that I missed?  It would make sense if the chips were corroded that the sockets would be too, but the thing is, none of the RAM is corroded, only a handful of logic ICs.   I don't know.  It might explain why rearranging the RAM temporarily brought the computer back to life? Any suggestions?

Link to comment
Share on other sites

On 11/30/2021 at 11:02 PM, DistantStar001 said:
Possibly fixed! The 74LS195 at C2 was in backward and I didn't notice it. Swapped it out (as turning it around revealed that it was fried) and so far the computer has come back to life! Also., the keyboard seems to be fully functional as well!


The 195 is used for RAM refresh. This may be helpful in the future...


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...