Jump to content

SNES EEPROM programming help?

Recommended Posts

Hello, first post on this site! My name is Per and I’m from Norway, known as The Hillbilly Gamer. I’m at my wits end and I’m now going around asking for all the help I can get if any. ?


I have been repairing, refurbishing, modding, cleaning etc games, consoles and periferals for over 10 years now. And I have mastered a lot. I got a request some months ago to help out making some repro snes carts. I my self collect a lot of Japan only games and use my retron 5 to play them in English so I had been playing with the idea before but not jumped in to it before. I went in to it head first and bought my self a GQ-4x4 USB programmer with the adp-054 adapter, a bunch of chips and even a bunch of other stuff for making wire leads etc. 


Prepared for everything, I thought, I started preparing a bunch of games for reproing. Found a lot of good guides and felt I was getting it. Then when i came around to writing the eeproms it all came to a screeching holt. My fancy programmer has little to no tutorials or YouTube vids and I have tried a lot of things. But my chips do not either write or they do not verify. I have bought more chips, different brands etc. I need to be using the 27c322 chips and I just can’t find any good help with my programmer or the chips. Is there anyone here that can help out? Or point me to somewhere or someone that can? ?


Im at the point where I am considering I need to buy a “lesser” programmer and adapter to make it all work as I have found lots of tutorials for the cheaper programmers ???


hope someone here can help.


Per The Hillbilly Gamer

Link to comment
Share on other sites

  • 8 months later...

Well, I'm pulling my hair out a bit too. I'm trying to learn assembly language programing on the SNES. (Already did Atari 2600, Nintendo, and a Colecovision game). I have a GQ 4x4 as well and the ADP-054 adaptor for 16 bit stuff. I try getting tutorial stuff to assemble and it will run on emulators after tweaking many things but trying to write it on to Eproms I have not gotten any tutorial stuff to work yet. (I have a few more ideas of what to possibly tweak but I'm running out of ideas. I can say it "looks" more right. Header has the right information, file size is right...). However I know my GQ 4x4 is working right with and without the adaptor. I tested with making a couple test eproms with homebrew stuff like Classic Kong Complete and Jet Pilot Rising to test LOROM and HIROM stuff. I am using Muramasa boards so everything is new and does mot need "rewiring". I guess that's a thing using donar carts. I think all SNES stuff needs rewiring. Also I am using 27C040 eproms (no adaptor needed 512K chip), and 27c160s (2 Meh chip... Needs the adaptor. On the Muramasa site they made it sound like 27C322s could be used but I think it was a misprint for my board type. I have the "basic" boards and it doesn't show 27c322 on it and I could not get them to work on SNES. They DO read and write fine though as I desoldered a couple of Sega genesis games and tried to write them on 27c322s. (I don't have a Genesis to test with it the files match.) Also if you are trying to write 27c322s on GQ 4x4 I think you need the LATEST version of their adaptor. Version 4 or 4.1 I think it is. Others are for the older models I think. Also if writing to 27c322s you need to change the jumper setting on the upper left corner of the board. (The lower 2 pins). I tried reading without and I think it was reading every other byte if the jumper was not set right.

Link to comment
Share on other sites

I also noticed you said eeproms... Not eproms. Eeprom are electronically erasable. (You can have the GQ 4x4 erase them and then blank check them. 27c322s are eproms. You need an eprom eraser to clear them out again. The chips got that little window on the top. You need a "special" UV light to shine on it to erase them. They are cheap. A little plastic box with a timer. Don't look at the light as I guess it can damage your eyes. Takes my larger chips about 30 to 45 minutes to erase properly. You can't just "overwrite" an eprom unless you are trying to write the exact same thing. For my Muramasa boards I think they put the wrong information down on my "basic" board types. (1 Meg LOROM, and another that can do 2 MEG LOROM or HIROM, etc) The boards show which chips to use and a 27c322 isn't one of them. (4Megabyte chip) The 27c322s seem to write a little different. Anyway I messed up before. I think I tried reading a couple of my Genesis Roms As 27c322s and every other byte was missing because I think I forgot to change the jumper setting in the upper left. I did WRITE a Super Nintendo tech demo I think it was and it did verify correctly. I just didn't have the board type to test a 4Meg game on. Other stuff was running fine for a few different SNES homebrew games.

Link to comment
Share on other sites

My results from my 2 Megabyte HIROM test board running the homebrew game Jet Pilot Rising. (A "one button" game with a rocket riding cat) The 2 green capacitors "should" be tiny ceramic ones but I had no choice. I've been waiting a month on the proper ones. This "type" is supposed to be OK I think after watching a capacitor video. The other one needs to have the polarity right. All I can say is that "it works". Using a 27C160 eprom on it.


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...