Jump to content

Batocera (Emulation system) and TI-99/4A


Recommended Posts

Batocera is an emulation system very easy to run from an USB stick on a Laptop PC for example

(I used the USB on different laptop PC's and works excellent)

(example to setup explained by Wagner's Tech Talk - https://www.youtube.com/watch?v=F1GshnAYrII)


The zip file is already provided in v33 of Batocera and you only have to add the .rpk format as it is based on MAME/MESS

(list of cartridges) https://ftp.whtech.com/Cartridges/MAME/rpk/


Setup instructions - https://wiki.batocera.org/systems:ti99


  • Like 3
  • Thanks 1
Link to comment
Share on other sites

Basically I use Batocera for playing games, but the Speech Synthesizer is not working

in the emulation mode it is possible to press TAB to see all the MESS settings. 


Question to @mizapf to get the Speech to work is that very simple to do by using the  .zip files (ti99_speech.zip)? 

or is something needed in the Batocero system to get Speech to work?



  • Like 2
Link to comment
Share on other sites

Okay I got Speech working as follows:

1.  install the ti99_speech.zip  file in the /bios folder 

2. start a program like Alpiner

3. press TAB

4. select  Slot Devices

5. select ioport "peb" 

6. select ioport:peb:slot3  "speech"

7. select "Reset Machine"


(only after getting back to Batocera and starting the game, the settings are not saved, so I guess there is somewhere a mame startup command where these parameters can be set.  something like "

mame64 ti99_4a -ioport peb  -ioport:peb:slot3 speech


  • Like 3
Link to comment
Share on other sites

First time that I heard about Batocera, so I can't really give you a lot of help here. I don't know what MAME version it is based on. By the way, the claim that the software list files don't work is wrong; the ZIP files are those files, and they are working perfectly. You should not unzip the ZIP files, though.

  • Like 1
Link to comment
Share on other sites

  • 3 weeks later...
  • 3 weeks later...


(Batocera version 34 for x86 x64 bit  - https://updates.batocera.org/x86_64/stable/last/batocera-x86_64-34-20220523.img.gz




Here are some notes to myself which tools I used to make the package.



(inside the .rpk is a file layout.xml, sometimes 378, 379i, or gromemu need to be used)




(1x laptop runs Batocera is connected to the Wi-Fi network)

(other laptop uses ESGME to open file via Wi-Fi   \\\gamelist.xml directly in Batocera)


Windows explorer  //192.168.1/191

Default login: batocera / linux


EmulationStation Gamelist Metadata Editor 

·        https://www.jeffersoftware.com/esgme/index.php

·        To edit in /roms/ti99/gamelist.xml

o   Use SAVE

o   Edit the names of games

o   Edit the link to images (preview)

o   Edit the link to video files (preview)


Bulk Rename Utility   (to rename files, like   filaabc_x264.mp4  to file.mp4

(play around with the filters)




Js99er.net to make screenshots in .png format

Js99er.net to make video snapshots in webpm



Also use Screenhunter - https://www.wisdom-soft.com/index.htm

To do image snaphots or video recording, select an area to capture  (e.g. from Classic99)


Use Any Video Converter to convert from  .webm format to .mp4 format


·        Output select Customized MP4 Movie (*.mp4)  format

·        Change video size 320 x 240

·        Drag and drop all .webm  and .mp4 files to Any Video Converter

·        And convert


Copy the .png files to Batocera //

Copy the .mp4 files to Batocera //



once the .zip file is available, just copy everything to .../roms/ti99   

(then in Batocera press "spacebar"  for main menu,  select Game Settings and update gamelists)

then back  and the TI99 should be available now with 289 games, image and video previews.





  • Like 3
Link to comment
Share on other sites


(list of all games: https://ftp.whtech.com/Cartridges/Batocera/Batocera-ti99-rpk-image-video.xlsx)



1. install Batocera image on a USB, Raspberry PI, or any other device

    USB for PC (to boot from USB) - Batocera version 34 for x86 x64 bit  - https://updates.batocera.org/x86_64/stable/last/batocera-x86_64-34-20220523.img.gz


2. Download the .zip and unzip (e.g. using WinRar)



3. Copy all files in /share/roms/ti99

    (it copies .rpk format (game modules), images and videos preview snaps.




  • Like 3
Link to comment
Share on other sites


Additional useful tools to do mass renaming and organising gamelist.xml  with images and videos in Batocera

*  Explanation https://www.digimoot.com/retropie-generate-xml-mass-rename-media-roms/

*  Fat Match file renamer (to map roms with images or videos), run the tool 2x (for images and videos) https://emumovies.com/files/file/227-fatmatch-file-renamer/

Gengal.zip - Gengal (very difficult to find it online) to generate the gamelist.xml with images and videos


*  Use ESGME to load the gamelist.xml to validate. If it gives errors then probably filenames have the "&" (ampersand) character in the filename  (change it to "+" (plus)),

*  Use the Bulk Rename Utility to rename the files (include the subdirectories !)


EmulationStation Gamelist Metadata Editor 

·        https://www.jeffersoftware.com/esgme/index.php

·        To edit in /roms/ti99/gamelist.xml

o   Use SAVE

o   Edit the names of games

o   Edit the link to images (preview)

o   Edit the link to video files (preview)


Bulk Rename Utility   (to rename files, like   filaabc_x264.mp4  to file.mp4

(play around with the filters)






  • Like 3
Link to comment
Share on other sites

  • 4 weeks later...
  • 4 months later...
  • 1 month later...


Today I got Batocera working in a (Oracle) Virtual Box (VM) environment (not booting from USB). 

(as with VMware Player I did not had much success to boot from an USB image and to install VMWare tools)


* I still suggest to boot Batocera from a USB stick on a PC as it works very well 

   (it works on all x64 PCs I have been testing so far and is perfect, for some modern PC, in the BIOS you need to turn on Legacy support to boot, that's a bit inconvenient). 



* Note: in a VM environment Batocera performance itself has sometimes audio distortions, but sometimes it is okay (see Batocera audio settings),

   most systems (MAME, MSX, Commodore64, NES, TI-99/4A) seems to work too fast and for TI-99 somehow the screensize is smaller than other systems.

   Have not had time to figure out if it is a Virtual Box, or Batocera or MAME setting.



* the reason for the VM is that if I do not have my USB with me (or other laptop), I still can do some work on the Batocera system 


* Once installed. (right click on the icon) and run as "administrator"




   (I am using a Lenovo to run Virtual Box on Windows 11 64-bit)




1.Download the latest Batocera x86_64 image.

2.    Install Oracle's VirtualBox.   (Virtual Box 7.x)
3.    VirtualBox 7.0.4 Oracle VM VirtualBox Extension Pack  All supported platforms
       Install the VirtualBox #.#.# Oracle VM VirtualBox Extension Pack too.


Important is to select "Linux"  (and not Windows as it will hang the system)

For the rest follow these instructions (also enable 3D acceleration !)




















Note" TI-screen is a bit small and speed is too fast.







Edited by globeron
  • Like 2
Link to comment
Share on other sites

On 12/6/2022 at 11:37 PM, globeron said:

Addendum v2:

* Blockbuster

* Tetris (2 player version)

* gamelist.xml


.csv list with a complete list of all modules in the v2 package


Batocera-ti99v2-addendum.zip 655.35 kB · 5 downloads


TI99-v2-and-addendum-gamelist.csv 90.5 kB · 5 downloads



Addendum for Batocera -- spac-man




  • Like 1
Link to comment
Share on other sites

  • 2 months later...

Anyone else having problems running the ti99 emu under beta 36?  I setup a b35 VirtualBox image and it worked fine.  I moved it to my b36 beta and the TI99 games wont start.  They act like they are starting but return to the select menu.

Link to comment
Share on other sites

@Goochman normally I run Batocera from a USB drive, also I have issues in v35 as well ad v36 with TI not running, try to repeat opening it then sometimes after a while it suddenly opens. 


I think also to do with the GPU card it seems to detect it first (my older laptop seems to have this issue)


I also noticed something to do with USB Controllers,try to unplug.  Try only with a keyboard to open TI


If that all does not work, do a factory reset that worked for me

  • Log in through SSH, then enter:
    /etc/init.d/S31emulationstation stop
    mv /userdata/system /userdata/system.old
Edited by globeron
  • Like 1
Link to comment
Share on other sites

I think its GPU related running in a VM - for v35 it runs, but v365 it doesnt.  I have this problem with XBOX not running in 35 or 36, but the PS1 does - unfor the only 2 systems I want to run are TI-99 and XBOX for the most part :P


Not sure if you are using CoinOps and the Sauce edition - trying to find a TI-99 setup for that but so far no luck - that would solve my problem as well for what Im trying to accomplish (I have an Ultimate Gamer Pro)

Link to comment
Share on other sites

  • 2 months later...
  • 5 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...