Jump to content
IGNORED

CosmosEx corrupting RPi whenever turned off?


Recommended Posts

Has anyone run into a problem with the CosmosEx 3.0 constantly corrupting the RPi micro sd card consistently when it is turned off? I thought perhaps the micro sd went bad, so I replaced with a brand new SanDisk, but after flashing the new card then running in the CosmosEx, it runs fine until I turn off the CosmosEx. Next boot and the non-fat partitions are corrupt.

The CosmosEx worked great when I first got it, but it went on the shelf for a while. Now that I finally acquired a TT, I pulled it off the shelf, but have run into this problem.

Am I doing something wrong to cause this? when I'm done using the unit, I just power it off at it's power switch.

Thanks for any help!

Link to comment
Share on other sites

10 hours ago, vattari said:

How is the device being powered?  Externally, or using an internal power source?

Externally with 5v 2a adapter. This did get me thinking though, that I am using a different adapter and usb cable. I'm going to locate the adapter and cable I had used previously when the CosmosEx was not having this issue. Thank you for the idea!

  • Like 1
Link to comment
Share on other sites

8 hours ago, 351coug said:

Reading your post you say I got a TT, implying that is a new machine (to you) and that is where the problem is seen. Put it back in the machine you used when it worked and see if it still does. Unless im reading you wrong. 

Yes, I was using this previously with a Mega ST, when the unit was working without issue. However, the card will corrupt before even being hooked up to the TT. I will flash the card, then take the CosmosEx upstairs to hookup to the network via Ethernet (no ethernet downstairs), and get it configured. Once done, I turn off the unit by it's power switch. When I power the device backup, even before connecting to the TT, the CosmosEx just boot loops. Taking the RPi out of the CosmosEx and hooking up to hdmi, I can see it starting the boot process, but then reports it cannot find the other partition. 

Link to comment
Share on other sites

So it appears to have been a bad usb cable. Swapper out the one I was recently using with the cable I had been originally using and now the CosmosEx works fine. No corruption of the micro sd anymore.

 

Thank you @vattari for getting me to think about the difference in power to the device!

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...