Jump to content

Sundog City map glitches

Recommended Posts

Hi *,


In Sundog I'm having "glitches" when walking around in the city . The blocks are randomly changing and I see broken ships here and there. Walking around in the city simply doesn't make sense it seems to be broken.

I'm having it using an STX image from Atarimania in emulation and also using PPs version on Real HW.


I wonder what I'm doing wrong. Any advice?



Link to comment
Share on other sites

I think what is supposed to be can be seen in this video i.e. 8:28



But what I see is a "single pixel" for character and when I walk around the city map is not "scrolling" (switching) accordingly. The results is a broken map / city view.




also the ship appears multiple times.







Link to comment
Share on other sites

Long ago, when I tried playing this (and winning) in the early 2k's with Hatari, I found that the newer TOS's did this.  Try the emulator with the original TOS and see how it goes.


I never really bothered trying all the tos versions to see which had problems, but I do remember having the same issue with my Mega STE but not my original 520.


Also I should note, that when I did this, these were from the original disks, and an image made from my original disk... so this likely isn't anything to do with the conversion.

Link to comment
Share on other sites

If works with 1.02 most likely works with 1.04 too. I did not see those errors, and I run/test games mostly with 1.04 in Steem 3.2 Debugger. Dealt with Sundog some 14 years ago

TOS loader - with it can load 1.04 in RAM . Please test with it, or with 1.04 as regular TOS in Steem. If it is OK then I can make new adaptation with TOS 1.04 in RAM, what will run on all machines from ST to TT, will have state saves, simple exit to Desktop .

Link to comment
Share on other sites

Actually, I could be wrong.. (It was long ago) but I think I tried 1.04 in the emulator and it didn't work.....


But I had the same issue... that's why I played it in the emulator instead of my Mega STE with TOS 2.05 (at the time) and by that point my 520 was burried somewhere in storage (but it had worked, since Sundog was my first ST game).


Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...